Subject: Re: [Pce] Adoption of draft-xiong-pce-lsp-flag-03

From: <[email-masked]>
Date: Mon, 22 Feb 2021 09:35:53 +0800 (CST)

Hi  Adrian and Julien,

Many thanks for your suggestions!

I fully agree with you. The two wg drafts could be viewed as two implementations to use the flag carried in LSP-EXTENDED-FLAG TLV.

I will add informative references to those two drafts if necessary.  And I also suggest those two drafts could add references to the draft-xiong-pce-lsp-flag.

Regards,

Quan

>Re: [Pce] Adoption of draft-xiong-pce-lsp-flag-03
Adrian Farrel <[email-masked]> Fri, 19 February 2021 16:05 UTCShow header

>Ah, that's useful. Thanks Julien.

>Makes this work more pressing.

>Informative references to those two drafts would help focus the reviewer's mind and might be handy when this draft overtakes those other two documents and goes to the IESG.

>Cheers,
>Adrian

-----Original Message-----
From: [email-masked] <[email-masked]> Sent: 19 February 2021 14:38
To: [email-masked]: [email-masked]: Re: [Pce] Adoption of draft-xiong-pce-lsp-flag-03

>Hi Adrian,

>Thank you for your feedback.

>If evidence is needed, how about binding label?https://tools.ietf.org/html/draft-ietf-pce-binding-label-sid-06#section-11.2Note it's also reused inhttps://tools.ietf.org/html/draft-ietf-pce-sr-path-segment-03#section-4.2Have a nice week-end,

>Julien

On 18/02/2021 16:57, Adrian Farrel wrote:
> Thanks to the authors for cleaning this up a lot since last time.
>
> I don't object to adoption. Would be nice to have evidence of someone
> needing a bit now, but by the time this becomes an RFC it is reasonably
> possible.
>
> Adrian
>
> -----Original Message-----
> From: Pce <[email-masked]> On Behalf Of Dhruv Dhody
> Sent: 01 February 2021 17:48
>
> Hi WG,
>
> This email begins the WG adoption poll for draft-xiong-pce-lsp-flag-03.
>
> https://datatracker.ietf.org/doc/html/draft-xiong-pce-lsp-flag-03>
> This is a small draft that extends the flags in the LSP Objects by
> defining a new LSP-EXTENDED-FLAG TLV. Note that the existing
> sub-registry "LSP Object Flag Field" is almost fully assigned.
>
> https://www.iana.org/assignments/pcep/pcep.xhtml#lsp-object-flag-field>
> Should this draft be adopted by the PCE WG? Please state your reasons
> - Why / Why not? What needs to be fixed before or after adoption? Are
> you willing to work on this draft? Review comments should be posted to
> the list.
>
> Please respond by Monday 15th Feb.
>
> Thanks!
> Dhruv & Julien
>
> _______________________________________________
> Pce mailing list
> [email-masked]> https://www.ietf.org/mailman/listinfo/pce>
> _______________________________________________
> Pce mailing list
> [email-masked]> https://www.ietf.org/mailman/listinfo/pce>

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Dhruv Dhody <[email-masked]>
Date: Mon, 22 Feb 2021 09:16:06 +0530

Hi Quan,

To clarify,

- draft-ietf-pce-binding-label-sid is asking for the allocation in the
existing LSP Object Flag Field, after this allocation, there won't be
any flags left.
- as an example of usage of the new LSP-EXTENDED-FLAG TLV, you should
site draft-peng-pce-entropy-label-position!

Hope this helps you with the text in your draft!

Thanks!
Dhruv

On Mon, Feb 22, 2021 at 7:06 AM <[email-masked]> wrote:
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce

---

From: <[email-masked]>
Date: Mon, 22 Feb 2021 16:10:16 +0800 (CST)

Hi Dhruv,

Thanks for your suggestion! I agree with you to cite the draft-peng-pce-entropy-label-position as an example.

But I am not sure about the two wg drafts including draft-ietf-pce-binding-label-sid-06 and draft-ietf-pce-sr-path-segment-03. As far as I know, the last unassigned bit in LSP object is bit 0. It is not enough for the two drafts.

Regards,

Quan

原始邮件

发件人：DhruvDhody
收件人：熊泉00091065;
抄送人：[email-masked];
日 期 ：2021年02月22日 11:48
主 题 ：Re: [Pce] Adoption of draft-xiong-pce-lsp-flag-03

Hi Quan,
 
To clarify,

 
Thanks!
Dhruv

---

From: Dhruv Dhody <[email-masked]>
Date: Mon, 22 Feb 2021 14:36:49 +0530

Hi Quan,

Path segment reuses the bit (and does not define a new bit) see
https://tools.ietf.org/html/draft-ietf-pce-sr-path-segment-03#section-4.2

Thanks!
Dhruv