Subject: [Pce] Roman Danyliw's No Objection on draft-ietf-pce-pcep-extension-for-pce-controller-12: (with COMMENT)

From: Roman Danyliw via Datatracker <[email-masked]>
Date: Wed, 24 Feb 2021 10:57:53 -0800

Roman Danyliw has entered the following ballot position for
draft-ietf-pce-pcep-extension-for-pce-controller-12: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-pce-pcep-extension-for-pce-controller/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thank you to Yaron Sheffer for the SECDIR review and the updates made as a
result to improve the Security Considerations.  I endorse the revised text that
minimally RECOMMENDs the use of “mutually-authenticated and encrypted
sessions.”  My question is why can’t we go even further and require (use MUST)
this crucial provisioning channel always be protected.  When would we NOT want
to use TLS?  I appreciate that mandating the use of security primitives in
routing is challenging due to a long tail of legacy investment.  However, this
extension seems like a near "green field" focused on a modern, SDN architecture
which seems unlikely to have less capable legacy elements.

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Fri, 26 Feb 2021 03:36:24 +0000

Hi Roman, 

Thank you for your comments! Please find the diff and the responses in line below. Thank you!

Diff: https://tools.ietf.org/tools/rfcdiff/rfcdiff.pyht?url1=draft-ietf-pce-pcep-extension-for-pce-controller-12&url2=https://raw.githubusercontent.com/dhruvdhody/ietf/master/draft-ietf-pce-pcep-extension-for-pce-controller-13.txt

-----Original Message-----
From: Roman Danyliw via Datatracker [mailto:[email-masked]] 
Sent: Thursday, February 25, 2021 2:58 AM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; Julien Meuric <[email-masked]>; [email-masked]
Subject: Roman Danyliw's No Objection on draft-ietf-pce-pcep-extension-for-pce-controller-12: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Thank you to Yaron Sheffer for the SECDIR review and the updates made as a result to improve the Security Considerations.  I endorse the revised text that minimally RECOMMENDs the use of “mutually-authenticated and encrypted sessions.”  My question is why can’t we go even further and require (use MUST) this crucial provisioning channel always be protected.  When would we NOT want to use TLS?  I appreciate that mandating the use of security primitives in routing is challenging due to a long tail of legacy investment.  However, this extension seems like a near "green field" focused on a modern, SDN architecture which seems unlikely to have less capable legacy elements.

Shuping> This is a case of blending elements of SDN into the existing distributed control plane and devices without necessarily completely replacing it and enhancing PCEP as an SBI. It is true that the central control instructions allows greater control to label allocation but it is not far from what is already done for segment routing label stack (which uses 'RECOMMEND').

Best Regards, 
Shuping