Subject: [Pce] Adoption of draft-xiong-pce-lsp-flag-03

From: Dhruv Dhody <[email-masked]>
Date: Mon, 1 Feb 2021 23:17:36 +0530

Hi WG,

This email begins the WG adoption poll for draft-xiong-pce-lsp-flag-03.

https://datatracker.ietf.org/doc/html/draft-xiong-pce-lsp-flag-03

This is a small draft that extends the flags in the LSP Objects by
defining a new LSP-EXTENDED-FLAG TLV. Note that the existing
sub-registry "LSP Object Flag Field" is almost fully assigned.

https://www.iana.org/assignments/pcep/pcep.xhtml#lsp-object-flag-field

Should this draft be adopted by the PCE WG? Please state your reasons
- Why / Why not? What needs to be fixed before or after adoption? Are
you willing to work on this draft? Review comments should be posted to
the list.

Please respond by Monday 15th Feb.

Thanks!
Dhruv & Julien

---

From: <[email-masked]>
Date: Wed, 3 Feb 2021 16:07:41 +0800 (CST)

Hi WG,

I think this draft is very useful and support the adoption for it.

Best Regards,

Ran

原始邮件

发件人：DhruvDhody
收件人：[email-masked];
日 期 ：2021年02月02日 01:56
主 题 ：[Pce] Adoption of draft-xiong-pce-lsp-flag-03

Hi WG,

 

 
 
Thanks!
Dhruv & Julien
 
_______________________________________________
Pce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pce

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Wed, 3 Feb 2021 13:09:01 +0000

Yes, support. This document can addresses the issue of running out the flag bits.

Thanks to the author!
Cheng

-----邮件原件-----
发件人: Pce [mailto:[email-masked]] 代表 Dhruv Dhody
发送时间: 2021年2月2日 1:48
收件人: [email-masked]
主题: [Pce] Adoption of draft-xiong-pce-lsp-flag-03

Hi WG,

This is a small draft that extends the flags in the LSP Objects by defining a new LSP-EXTENDED-FLAG TLV. Note that the existing sub-registry "LSP Object Flag Field" is almost fully assigned.

Should this draft be adopted by the PCE WG? Please state your reasons
- Why / Why not? What needs to be fixed before or after adoption? Are you willing to work on this draft? Review comments should be posted to the list.

Thanks!
Dhruv & Julien

---

From: Greg Mirsky <[email-masked]>
Date: Wed, 3 Feb 2021 13:03:58 -0800

Dear All,
I've read the draft and support it being adopted by the PCE WG. The draft
provides an elegant future-proof solution to the real problem. I have one
suggestion for a future revision of this document. You've already
considered backward compatibility between implementations that support the
new TLV and ones that do not. I think we can envision a situation when
implementations with, for example, 32 bit-long LSP Extended Flags field
interwork with implementations that use 64 bit-long field. Such a situation
might be far away today but it might help developers later. Also, might be
helpful to explicitly note that the value in the Length field equals the
length of the LSP Extended Flags field in octets (some bytes used to be
only seven-bit-long).

Regards,
Greg

---

From: Dhruv Dhody <[email-masked]>
Date: Thu, 4 Feb 2021 14:43:38 +0530

Hi WG,

Greg, Quan, and I discussed this offline and have this proposed text -

Note that, PCEP peers MAY encounter different length of the
LSP-EXTENDED-FLAG TLV.

   o If a PCEP speaker receives the LSP-EXTENDED-FLAG TLV
     of a length more than it currently supports or understands,
     it will simply ignore the bits beyond that length.

   o If a PCEP speaker receives the LSP-EXTENDED-FLAG TLV of
     a length less than the one supported by the implementation,
     it will consider the bits beyond the length to be unset.

Thoughts?

Dhruv (as a WG member)

---

From: Cyril Margaria <[email-masked]>
Date: Thu, 4 Feb 2021 10:36:18 +0000

Support,

I have the following comments:
  - The TLV is, as specified, is not forbidden  in other PCEP Objects,
  - It might be only defined as LSP object TLV and error code defined for
other cases, but it could also be allowed in any object and the extended
flags defined themselves within the context of an object.

BR
Cyril

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 16 Feb 2021 16:58:13 +0530

Hi WG,

We *need* to hear from more of you before taking a call on adoption. It is
a straightforward "house-keeping" document, but we need to see explicit
expressions of support (and comments).

We are extending the call till Friday, Feb 19th. Please respond with your
support (or not) for this adoption.

Regards,
Dhruv & Julien

---

From: Zhenghaomian <[email-masked]>
Date: Thu, 18 Feb 2021 03:35:18 +0000

Yes/Support. The usage of flags in PCEP needs to be carefully managed, and the LSP-based extension is an essential step to move forward.

Best wishes,
Haomian

发件人: Pce [mailto:[email-masked]] 代表 Dhruv Dhody
发送时间: 2021年2月16日 19:28
收件人: [email-masked]
主题: Re: [Pce] Adoption of draft-xiong-pce-lsp-flag-03

Hi WG,

We *need* to hear from more of you before taking a call on adoption. It is a straightforward "house-keeping" document, but we need to see explicit expressions of support (and comments).

We are extending the call till Friday, Feb 19th. Please respond with your support (or not) for this adoption.

Regards,
Dhruv & Julien

On Mon, Feb 1, 2021 at 11:17 PM Dhruv Dhody <[email-masked]<mailto:[email-masked]>> wrote:
Hi WG,

Thanks!
Dhruv & Julien

---

From: Aijun Wang <[email-masked]>
Date: Thu, 18 Feb 2021 16:03:08 +0800

Hi, Dhruv:
Yes, support its adoption.
I think the extension can give more spaces to describe the future state of LSP.
One question, is it necessary to be variable length? How to keep align when the bit position is fixed but the length is variable?

Aijun Wang
China Telecom

> On Feb 16, 2021, at 19:29, Dhruv Dhody <[email-masked]> wrote:
> 
> 
> Hi WG,
>

---

From: Dhruv Dhody <[email-masked]>
Date: Thu, 18 Feb 2021 19:56:43 +0530

Hi Aijun,
On Thu, Feb 18, 2021 at 1:33 PM Aijun Wang <[email-masked]>
wrote:

> One question, is it necessary to be variable length? How to keep align
> when the bit position is fixed but the length is variable?
>
>
Not necessary but for what it's worth it has been done in the past, see
https://www.rfc-editor.org/rfc/rfc5088.html#section-4.5
The allocation would start from the most significant bit as bit zero and
remain fixed.

Thanks!
Dhruv

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 18 Feb 2021 15:57:22 -0000

Thanks to the authors for cleaning this up a lot since last time.

I don't object to adoption. Would be nice to have evidence of someone
needing a bit now, but by the time this becomes an RFC it is reasonably
possible.

Adrian

-----Original Message-----
From: Pce <[email-masked]> On Behalf Of Dhruv Dhody
Sent: 01 February 2021 17:48
To: [email-masked]
Subject: [Pce] Adoption of draft-xiong-pce-lsp-flag-03

Hi WG,

Thanks!
Dhruv & Julien

---

From: <[email-masked]>
Date: Fri, 19 Feb 2021 15:37:48 +0100

Hi Adrian,

Thank you for your feedback.

If evidence is needed, how about binding label?
https://tools.ietf.org/html/draft-ietf-pce-binding-label-sid-06#section-11.2
Note it's also reused in
https://tools.ietf.org/html/draft-ietf-pce-sr-path-segment-03#section-4.2

Have a nice week-end,

Julien

> Please respond by Monday 15th Feb.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Fri, 19 Feb 2021 16:00:15 +0100

Hi,

I support this draft.

Regards

Olivier

Le 16/02/2021 à 12:28, Dhruv Dhody a écrit :

> On Mon, Feb 1, 2021 at 11:17 PM Dhruv Dhody <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Hi WG,
>
-- 
Orange logo <http://www.orange.com>

Olivier Dugeon
Orange Expert, Future Networks
Open Source Referent
Orange/IMT/OLN/WTC/IEE/iTeQ

fixe : +33 2 96 07 28 80
mobile : +33 6 82 90 37 85
[email-masked] <mailto:[email-masked]>

---

From: "Samuel Sidor (ssidor)" <[email-masked]>
Date: Fri, 19 Feb 2021 15:05:59 +0000

Hi Dhruv,

I support adoption of this draft.

Regards,
Samuel

From: Pce <[email-masked]> On Behalf Of Dhruv Dhody
Sent: Tuesday, February 16, 2021 12:28 PM
To: [email-masked]
Subject: Re: [Pce] Adoption of draft-xiong-pce-lsp-flag-03

Hi WG,

Regards,
Dhruv & Julien

Thanks!
Dhruv & Julien

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 19 Feb 2021 16:04:56 -0000

Ah, that's useful. Thanks Julien.

Makes this work more pressing.

Informative references to those two drafts would help focus the reviewer's mind and might be handy when this draft overtakes those other two documents and goes to the IESG.

Cheers,
Adrian

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: 19 February 2021 14:38
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Pce] Adoption of draft-xiong-pce-lsp-flag-03

Hi Adrian,

Have a nice week-end,

Julien

---

From: Dhruv Dhody <[email-masked]>
Date: Mon, 22 Feb 2021 15:23:41 +0530

Hi WG,

Thanks to all who responded to the adoption poll. We have support to
adopt this as a WG item. Please continue to provide your comments as
the document moves through the WG process.

Authors, please post a -00 version
'draft-ietf-pce-lsp-extended-flags-00' with only the name/date change,
and be sure to set the "replaces" option during submission ("extended"
is added in the file name for clarity).

Please post the -01 version that handles the comments received during
the adoption call as well.

Thanks!
PCE Chairs

---

From: "Stone, Andrew (Nokia - CA/Ottawa)" <[email-masked]>
Date: Mon, 22 Feb 2021 22:13:33 +0000

+1 thanks Julien, also support the document. 

Did not recognize that binding label and path segment we're requesting bits as well. Seems like this draft is pre-empting the inevitable exhaustion at a good time. 

Thanks
Andrew

On 2021-02-19, 11:05 AM, "Pce on behalf of Adrian Farrel" <[email-masked] on behalf of [email-masked]> wrote:

    Cheers,
    Adrian

    -----Original Message-----
    From: [email-masked] <[email-masked]> 
    Sent: 19 February 2021 14:38
    To: [email-masked]
    Cc: [email-masked]
    Subject: Re: [Pce] Adoption of draft-xiong-pce-lsp-flag-03

    Hi Adrian,

    Have a nice week-end,

    Julien

---

From: Jeff Tantsura <[email-masked]>
Date: Mon, 22 Feb 2021 14:19:17 -0800

+1

Regards,
Jeff

> On Feb 22, 2021, at 14:13, Stone, Andrew (Nokia - CA/Ottawa) <[email-masked]> wrote:
>