Subject: [Pce] Implementation option of draft-ietf-pce-stateful-interdomain-01.txt

From: <[email-masked]>
Date: Mon, 22 Feb 2021 19:35:20 +0100

Dear all,

According to the remark about implementation we got during the WG call
for adoption, we would start a new thread to discuss this point.
The goal isto prepare the discussion for next IETF meeting and reach a
consensusin order to edit revision 2 of the draft.

The stitching label principle requires at least a certain number of
modifications in the current PCEP version:

 a) A new PCE Capability to announce the inter-domain behaviour
 b) A new PCE Association Group to associate the local paths identifier
    to the inter-domain identifier
 c) new PCEP Errors to manage the Stitching Label exchange
 d) A mechanism to convey the Stitching Label

If there is no other choice than to reuse existing PCEP Objects by
allocating new code points for modifications a-c,there is several
options for point d, which we have tried to list below:

 d1) Use ERO and RRO in conjunction to new Path Setup code points as
     described in version 01 of the draft. It is the simplest
     implementation but as mention by Dhruv, each time a new path
     enforcement appear, a new PST code point must be allocated.
     For example, when Segment Routing v6 will be standardized, we must
     allocate a new Stitching label PST code point for SRv6.
 d2) Use ERO and ERO in conjunction to a new flag in LSP. Simple as for d1,
     but need to use the LSP Extended Flag draft as all LSP flags have been
     already allocated.
 d3) Same as d2 but find another place for the flag e.g. SRP or LSPA Object.
 d4) Define a new PCEP sub-Objet TLV within the LSP Object to convey the
     stitching label. This is more independent but need extra parsing from
     an implementation point of view.

Please, give us your opinion about these different options and don't hesitate
to propose others.

Regards

Olivier on be-half of co-author's

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Dhruv Dhody <[email-masked]>
Date: Fri, 26 Feb 2021 10:05:20 +0530

Hi Olivier,

Thanks for starting this thread.

As a WG participant...

>      an implementation point of view.
My preference would for d2 or d3 (in that order).
LSP Extended Flag is adopted by the WG and is ready for prime-time use --
let's use it :)
Authors of LSP Extended Flag are waiting for the draft blockade to be
lifted to post the -00 WG I-D.

Thanks!
Dhruv

> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce
>