Subject: Re: [Pce] draft-dhodylee-pce-pcep-ls next steps!

From: Gyan Mishra <[email-masked]>
Date: Wed, 25 Aug 2021 00:44:04 -0400

Hi Adrian

See section 1.1 should have answers to your questions related to the
experimental draft.

https://www.ietf.org/archive/id/draft-dhodylee-pce-pcep-ls-21.html#section-1.1

Kind Regards

Gyan
On Sun, Jul 18, 2021 at 2:40 PM Adrian Farrel <[email-masked]> wrote:

> Hi Gyan,
>
>
>
> I am very much in favour of positioning this work as Experimental.
>
>
>
> It is important (as with all IETF Experiments) to capture:
>
> -          What stops this extension “escaping" in the Internet?
>
> -          What stops this experiment clashing with other work or harming
> deployed equipment?
>
> -          How will you judge the success or failure of the experiment,
> and when?
>
> -          What follow-up to the experiment do you propose?
>
>
>
> Best,
>
> Adrian
>
>
>
> *From:* Gyan Mishra <[email-masked]>
> *Sent:* 05 July 2021 07:43
> *To:* Adrian Farrel <[email-masked]>; Dhruv Dhody <[email-masked]>;
> [email-masked]; pce-chairs <[email-masked]>;
> [email-masked]
> *Subject:* draft-dhodylee-pce-pcep-ls next steps!
>
>
>
>
>
> Dear PCE WG,
>
>
>
> We presented the PCEP-LS [1] I-D [2] in the IETF 110 with a quick recap
> and a summary of past discussions. Some new scenarios such as PCECC, H-PCE
> were highlighted where the PCEP session could be reused.
>
>
>
> This is an experimental I-D with the aim to progress research and
> development efforts. This work is not a replacement for any of the existing
> mechanisms. There are specific scenarios highlighted where the reuse of
> PCEP sessions for this information is deemed useful. To make progress, it
> may not be useful to rehash the beauty context between everyone's favorite
> protocol :). What would be useful would be - finding out if there is still
> interest in this experimental work by some in the WG; are there strong
> technical objections for the experiment in its limited scope etc...
>
>
>
> As a next step, it would be good to define the scope of the experiments
> and expected output especially targeting the scalability concerns as well
> as impact in other protocols and the network, etc.
>
>
>
> From the last query on this draft March 18th we received positive feedback
> from Aijun Wang with China Telecom mentioned that as a telco are interest
> in deploying in their network PCEP-LS once the Huawei implementation is
> ready.  Aijun pointed out in the thread that using this draft simplifies
> the implementation of SDN controller.  One question asked by Aijun was
> related to section 9.2.1 LS Capability TLV R=1 remote allowed meaning
> hybrid mode to provide flexibility for operators not yet using SDN
> (SDN-like) SBI.  For any operators already using PCEP as SDN (SDN-like)
> SBI, a direct PCEP session already exist between all the nodes in the
> network and the PCE which would be the PCECV SDN scenario in which case the
> R flag in the open message is set to 0.
>
>
>
> We also received positive feedback from Peter Park with telco KT regarding
> interest in PCEP-LS.
>
>
>
> We also had feedback from Bin as they have implemented PCEP and have
> interest in this experimental implementation of this work.
>
>
>
> I would like to poll the WG again for interest in progressing research and
> development efforts of this draft as experimental.
>
>
>
> As stated in the last WG poll, I would like get feedback from the WG on
> scope of experiments especially related to scalability concerns and impact
> to other protocols on the network.
>
>
>
> Thanks!
>
> Gyan (on behalf of co-authors)
>
>
>
> [1]
> https://datatracker.ietf.org/meeting/110/materials/slides-110-pce-42-pcep-ls-00.pdf
>
> [2] https://datatracker.ietf.org/doc/draft-dhodylee-pce-pcep-ls/
>
> ==
>
>
>
>  <http://www.verizon.com/>
>
> *Gyan Mishra*
>
> *Network Solutions Architect *
>
> *Email [email-masked] <[email-masked]>*
>
> *M 301 502-1347*
>
>
>
> --
>
>  <http://www.verizon.com/>
>
> *Gyan Mishra*
>
> *Network Solutions Architect *
>
> *Email [email-masked] <[email-masked]>*
>
> *M 301 502-1347*
>
>
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*Email [email-masked] <[email-masked]>*

*M 301 502-1347*

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 25 Aug 2021 15:30:06 +0100

Yes, thanks, Gyan.

I think you have captured it all, although some of the behaviours are “hidden” in assumptions in the text.

That is:

*	A PCEP speaker that offers this feature to its peer that does not support or does not wish to support the feature will not receive indication of support in the Open message, and so is expected to not use the feature.

*	A PCEP speaker that receives any of the objects that are part of the feature when use of the feature has not been agreed, will <do something> as described in <reference>.

Of course, this is “business as usual” but the reviewer of the text will not necessarily know this.

Cheers,

Adrian

From: Gyan Mishra <[email-masked]> 
Sent: 25 August 2021 05:44
To: [email-masked]
Cc: Dhruv Dhody <[email-masked]>; [email-masked]; [email-masked]; pce-chairs <[email-masked]>
Subject: Re: draft-dhodylee-pce-pcep-ls next steps!

Hi Adrian 

See section 1.1 should have answers to your questions related to the experimental draft.

 <https://www.ietf.org/archive/id/draft-dhodylee-pce-pcep-ls-21.html#section-1.1> https://www.ietf.org/archive/id/draft-dhodylee-pce-pcep-ls-21.html#section-1.1 

Kind Regards 

Gyan

On Sun, Jul 18, 2021 at 2:40 PM Adrian Farrel <[email-masked] <mailto:[email-masked]> > wrote:

Hi Gyan,

-          What stops this experiment clashing with other work or harming deployed equipment? 

-          How will you judge the success or failure of the experiment, and when? 

Best,

Adrian

From: Gyan Mishra <[email-masked] <mailto:[email-masked]> > 
Sent: 05 July 2021 07:43
To: Adrian Farrel <[email-masked] <mailto:[email-masked]> >; Dhruv Dhody <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> ; pce-chairs <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> 
Subject: draft-dhodylee-pce-pcep-ls next steps!

Dear PCE WG,

We presented the PCEP-LS [1] I-D [2] in the IETF 110 with a quick recap and a summary of past discussions. Some new scenarios such as PCECC, H-PCE were highlighted where the PCEP session could be reused. 

This is an experimental I-D with the aim to progress research and development efforts. This work is not a replacement for any of the existing mechanisms. There are specific scenarios highlighted where the reuse of PCEP sessions for this information is deemed useful. To make progress, it may not be useful to rehash the beauty context between everyone's favorite protocol :). What would be useful would be - finding out if there is still interest in this experimental work by some in the WG; are there strong technical objections for the experiment in its limited scope etc... 

As a next step, it would be good to define the scope of the experiments and expected output especially targeting the scalability concerns as well as impact in other protocols and the network, etc.   

>From the last query on this draft March 18th we received positive feedback from Aijun Wang with China Telecom mentioned that as a telco are interest in deploying in their network PCEP-LS once the Huawei implementation is ready.  Aijun pointed out in the thread that using this draft simplifies the implementation of SDN controller.  One question asked by Aijun was related to section 9.2.1 LS Capability TLV R=1 remote allowed meaning hybrid mode to provide flexibility for operators not yet using SDN (SDN-like) SBI.  For any operators already using PCEP as SDN (SDN-like) SBI, a direct PCEP session already exist between all the nodes in the network and the PCE which would be the PCECV SDN scenario in which case the R flag in the open message is set to 0.  

We also received positive feedback from Peter Park with telco KT regarding interest in PCEP-LS.

We also had feedback from Bin as they have implemented PCEP and have interest in this experimental implementation of this work.

I would like to poll the WG again for interest in progressing research and development efforts of this draft as experimental.  

As stated in the last WG poll, I would like get feedback from the WG on scope of experiments especially related to scalability concerns and impact to other protocols on the network.

Thanks! 

[1] https://datatracker.ietf.org/meeting/110/materials/slides-110-pce-42-pcep-ls-00.pdf

==

Gyan Mishra

Network Solutions Architect 

Email [email-masked] <mailto:[email-masked]> 

M 301 502-1347

-- 

Gyan Mishra

Network Solutions Architect 

Email [email-masked] <mailto:[email-masked]> 

M 301 502-1347

-- 

Gyan Mishra

Network Solutions Architect 

Email [email-masked] <mailto:[email-masked]> 

M 301 502-1347

---

From: Gyan Mishra <[email-masked]>
Date: Fri, 27 Aug 2021 01:51:42 -0400

Hi Adrian

Agreed.  We will make it more clear.

Many Thanks!

Gyan

On Wed, Aug 25, 2021 at 10:30 AM Adrian Farrel <[email-masked]> wrote:

>    - A PCEP speaker that offers this feature to its peer that does not
>    support or does not wish to support the feature will not receive indication
>    of support in the Open message, and so is expected to not use the feature.
>
>
>
>    - A PCEP speaker that receives any of the objects that are part of the
>    feature when use of the feature has not been agreed, will <do something> as
>    described in <reference>.
>
>
>
> *Sent:* 25 August 2021 05:44
> *To:* [email-masked]
> *Cc:* Dhruv Dhody <[email-masked]>; [email-masked];
> [email-masked]; pce-chairs <[email-masked]>
> *Subject:* Re: draft-dhodylee-pce-pcep-ls next steps!
>
>
>
> Hi Adrian
>
>
>
>
>
-- 

*Gyan Mishra*

*M 301 502-1347*

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 27 Aug 2021 13:01:24 +0100

-22 captures it. Thanks,

Adrian

From: Gyan Mishra <[email-masked]> 
Sent: 27 August 2021 06:52
To: [email-masked]
Cc: Dhruv Dhody <[email-masked]>; [email-masked]; [email-masked]; pce-chairs <[email-masked]>
Subject: Re: draft-dhodylee-pce-pcep-ls next steps!

Hi Adrian 

Many Thanks!

Gyan

On Wed, Aug 25, 2021 at 10:30 AM Adrian Farrel <[email-masked] <mailto:[email-masked]> > wrote:

Yes, thanks, Gyan.

That is:

Cheers,

Adrian

From: Gyan Mishra <[email-masked] <mailto:[email-masked]> > 
Sent: 25 August 2021 05:44
To: [email-masked] <mailto:[email-masked]> 
Cc: Dhruv Dhody <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; pce-chairs <[email-masked] <mailto:[email-masked]> >
Subject: Re: draft-dhodylee-pce-pcep-ls next steps!

Hi Adrian 

Kind Regards 

Gyan

Hi Gyan,

Best,

Adrian

 

Dear PCE WG,

Thanks! 

==

Gyan Mishra

M 301 502-1347

-- 

Gyan Mishra

M 301 502-1347

-- 

Gyan Mishra

M 301 502-1347

-- 

Gyan Mishra

M 301 502-1347

---

From: Gyan Mishra <[email-masked]>
Date: Sat, 28 Aug 2021 03:27:29 -0400

Perfect!

Thanks

Gyan
On Fri, Aug 27, 2021 at 8:01 AM Adrian Farrel <[email-masked]> wrote:

> *Sent:* 27 August 2021 06:52
-- 

*Gyan Mishra*

*M 301 502-1347*