Subject: Re: [Pce] [Lsr] WG Last Call for IGP extension for PCEP security capability support in the PCE discovery - draft-ietf-lsr-pce-discovery-security-support-05

From: Qin Wu <[email-masked]>
Date: Thu, 5 Aug 2021 08:10:54 +0000

Hi, Acee
Thanks for valuable comments, see reply inline below.

发件人: Lsr [mailto:[email-masked]] 代表 Acee Lindem (acee)
发送时间: 2021年7月22日 23:11
收件人: Acee Lindem (acee) <acee=[email-masked]>; [email-masked]
抄送: [email-masked]
主题: Re: [Lsr] WG Last Call for IGP extension for PCEP security capability support in the PCE discovery - draft-ietf-lsr-pce-discovery-security-support-05

Speaking as a WG member, I support publication.

I only have one functional comment and that is on Appendix A. Note that a key-chain or key-id would be useful for MD5 as well as TLS and TCP-AO. I’m not suggesting that you add MD5 since it is historic but support of MD5 as specified in RFC 5440 would require configuration of the same key or key-chain on the PCC and PCE server.
[Qin]: Good comment, I think we can add one statement at the end of the paragraph to say:
“
Irrespective of which security capability support is selected, the same key or key-chain on the PCC and PCE server should be configured.
”

I also have some editorial comments that you can decide whether or not to apply. Of note are that I don’t think you need to say “looking for connecting with a” and can simply say “looking for a”. Also, once this document is published the capability bits and sub-TLVs are not longer “new”.

See full set of editorial comments in attached RFC diff.
[Qin]: I agree with the most of comments and will incorporate them in.
One little tweak or fallback is s/ capability flag bit in the PCE-CAP-FLAGS sub-TLV in IS-IS is set to/ capability flag bit of PCE-CAP-FLAGS sub-TLV in IS-IS is set to
I think the original text is more clear here, using two ‘in’ is a little bit verbose in my view.
Thanks,
Acee

From: Lsr <[email-masked]<mailto:[email-masked]>> on behalf of "Acee Lindem (acee)" <acee=[email-masked]<mailto:acee=[email-masked]>>
Date: Wednesday, July 21, 2021 at 12:46 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Lsr] WG Last Call for IGP extension for PCEP security capability support in the PCE discovery - draft-ietf-lsr-pce-discovery-security-support-05

This begins a 3-week WG Last Call, ending on August 4th, 2021, for draft-ietf-lsr-pce-discovery-security-support. Please indicate your support or objection to this list before the end of the WG last call. The longer WG last call is to account for IETF week.

  https://datatracker.ietf.org/doc/draft-ietf-lsr-pce-discovery-security-support/

Thanks,
Acee

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 16 Aug 2021 20:31:56 +0000

The LSR WG last call has ended and I will request publication once the SECDIR comments are satified.

Thanks,
Acee

From: Lsr <[email-masked]> on behalf of "Acee Lindem (acee)" <acee=[email-masked]>
Date: Wednesday, July 21, 2021 at 12:46 PM
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [Lsr] WG Last Call for IGP extension for PCEP security capability support in the PCE discovery - draft-ietf-lsr-pce-discovery-security-support-05

Thanks,
Acee