Subject: Re: [Pce] I-D Action: draft-ietf-pce-pcep-yang-17.txt

From: Robert Varga <[email-masked]>
Date: Mon, 3 Jan 2022 10:27:13 +0100

On 23/10/2021 13:33, [email-masked] wrote:
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Path Computation Element WG of the IETF.
> 
>          Title           : A YANG Data Model for Path Computation Element Communications Protocol (PCEP)
>          Authors         : Dhruv Dhody
>                            Jonathan Hardwick
>                            Vishnu Pavan Beeram
>                            Jeff Tantsura
> 	Filename        : draft-ietf-pce-pcep-yang-17.txt

A minor question:

I noticed the draft is using inet:ip-address, which may include a zone 
index. Is that intentional, or should inet:ip-address-no-zone be used 
instead?

Regards,
Robert

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 25 Jan 2022 15:47:28 +0530

Hi Robert,

Thanks for noticing this. I see that this inconsistency is already steeped
in with most of the YANG models that are using inet:ip-address and only a
few (MLDP, DETNET, NVO3, I2NSF, BGP-Policy) opting for the
inet:ip-address-no-zone.

That said, "ip-address-no-zone" is the right thing to do and I have updated
it in the latest version.

https://www.ietf.org/rfcdiff?url2=draft-ietf-pce-pcep-yang-18

Thanks!
Dhruv

On Mon, Jan 3, 2022 at 2:57 PM Robert Varga <[email-masked]> wrote:

> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce
>

---

From: tom petch <[email-masked]>
Date: Tue, 25 Jan 2022 16:47:34 +0000

From: Pce <[email-masked]> on behalf of Dhruv Dhody <[email-masked]>
Sent: 25 January 2022 10:17

Hi Robert,

Thanks for noticing this. I see that this inconsistency is already steeped in with most of the YANG models that are using inet:ip-address and only a few (MLDP, DETNET, NVO3, I2NSF, BGP-Policy) opting for the inet:ip-address-no-zone.
<tp>

Gosh, they are the ones that I have been reviewing, along with dhcp etc - what a coincidence:-)

Tom Petch

That said, "ip-address-no-zone" is the right thing to do and I have updated it in the latest version.

Thanks!
Dhruv

On Mon, Jan 3, 2022 at 2:57 PM Robert Varga <[email-masked]<mailto:[email-masked]>> wrote:

A minor question:

Regards,
Robert
_______________________________________________
Pce mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pce