Subject: [PCN] identify an aggregation

From: Tina TSOU <[email-masked]>
Date: Tue, 20 Mar 2007 06:57:10 +0100

Hi Kwok,
We had a nice PCN meeting yesterday.
I asked the question about how to identify an aggregation in PCN. People 
gave several replies. Would you like to give a summary here?

B. R.
Tina 

_______________________________________________
PCN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pcn

---

From: Michael Menth <[email-masked]>
Date: Tue, 20 Mar 2007 08:42:12 +0100

Dear Tina,

you may want to have a look at Section II of the paper referenced in the
attached email. It's a short summary of how PCN basically works. The
scope of the aggregation level for measured variables is expressed by
mathematical dependencies. Example:
* AR(l): aggregation scope is all traffic on a specific link l
* ASR(Y,Z): aggregation scope is all traffic between ingress Y and
egress Z

Kind regards,

    Michael

Tina TSOU wrote:
> I asked the question about how to identify an aggregation in PCN. 
> People gave several replies. Would you like to give a summary here?
>
> B. R.
> Tina
>

-- 
Dr. Michael Menth, Assistant Professor
University of Wuerzburg, Institute of Computer Science
Am Hubland, D-97074 Wuerzburg, Germany, room B206
phone: (+49)-931/888-6644, fax: (+49)-931/888-6632
mailto:[email-masked]
http://www3.informatik.uni-wuerzburg.de/research/ngn

---

From: Tina TSOU <[email-masked]>
Date: Tue, 20 Mar 2007 09:44:53 +0100

Dear Michael,
Where did you attach the "attached email"? ;-)
As interior node in PCN domain, I might receive many packets, when packet A 
comes, how do I know packet A belongs to AR(1), AR(2), ASR(Y,Z), or 
ASR(W,X)? From the multicast destination address of Packet A? Or an 
identifier in the header of Packet A?

B. R.
Tina

---

From: "Kwok-Ho Chan" <[email-masked]>
Date: Tue, 20 Mar 2007 09:52:33 +0100

Tina:
As the way I understand your question on the mic,
the aggregation you were asking is about what happens at the Interior Nodes.
At the Interior Nodes, we assume packets can be identified as PCN 
traffic packets,
for example all PCN packets uses a specific DiffServ Code Point (DSCP).  Hence
we have a dependency on using a DiffServ Domain (as the scope of the 
current Charter).

At the Interior Node, there should be a filter (diffserv classifier) 
that will identify the
PCN packets.  (see slide 5 lower left corner of my presentation).

The aggregate is the traffic packets that follows the YES branch of 
the "PCN pkt?"
going into the "PCN pkt queue".

Hence the aggregate in the Interior Node includes all the PCN packets 
that traverse
that specific Interior Node (router) link.

I hope this answers your question completely.
Please let me know if additional clarification is needed.

Thanks!
-- Kwok --

---

From: <[email-masked]>
Date: Tue, 20 Mar 2007 08:56:58 -0000

an interior node doesnt know what AR a pkt belongs to. 
it makes measurements for *all* PCN packets (ie all pkts in the PCN class, ie with the DSCP that's being protected by PCN admission control). it doesnt know anything about which particular flow (or ingress-egress aggregate) a packet belongs to. similarly, the interior node PCN-marks packets independently of which particular flow (or ingress-egress aggregate) a packet belongs to. 

the current architecture draft says things like "each router in the CL-
   region runs an algorithm to determine whether to Admission Mark the 
   packet. The algorithm measures the aggregate CL traffic on the link"
perhaps the term "total PCN traffic" would be clearer?
http://www.watersprings.org/pub/id/draft-briscoe-tsvwg-cl-architecture-04.txt 

thanks
phil
-----Original Message-----
From: Tina TSOU [mailto:[email-masked]]
Sent: Tue 20/03/2007 08:44
To: [email-masked]
Cc: [email-masked]
Subject: Re: [PCN] identify an aggregation
 
Dear Michael,

B. R.
Tina

---

From: Michael Menth <[email-masked]>
Date: Tue, 20 Mar 2007 09:58:03 +0100

Dear Tina,

oops, i forgot the attachement. Here is the link to the paper:
http://www3.informatik.uni-wuerzburg.de/~menth/Publications/Menth07-Sub-18.pdf 

Regarding your question: interior routers just measure the rates of all 
high priority packets on the link, i.e., no difficult aggregate mapping 
is required. Only PCN egress routers need to map packets to 
ingress-egress aggregates and measure their rate. However, I don't know 
how this mapping is done by the routers in an efficient manner.

Best wishes,

   Michael

Tina TSOU wrote:
> As interior node in PCN domain, I might receive many packets, when 
> packet A comes, how do I know packet A belongs to AR(1), AR(2), 
> ASR(Y,Z), or ASR(W,X)? From the multicast destination address of 
> Packet A? Or an identifier in the header of Packet A?
>
> B. R.
> Tina
>
> ----- Original Message ----- From: "Michael Menth" 
> <[email-masked]>

---

From: Lars Westberg <[email-masked]>
Date: Tue, 20 Mar 2007 12:15:16 +0100

I think you can use this refernce  into the discussions. These 
references is the starting point for the RMD-concept.
http://www.comet.columbia.edu/~zoltan/LoadControl.pdf
I do not remeber which conference it was published.
I am also  lacking the following reference into the discussion
http://www.watersprings.org/pub/id/draft-westberg-loadcntr-01.txt

We have published more work into this topic during the period of 99-02
 so, if there are interest I can try to find them.

regards Lasse

Michael Menth wrote:

> <http://www3.informatik.uni-wuerzburg.de/%7Ementh/Publications/Menth07-Sub-18.pdf>
>
>