Subject: [PCN] addressing

From: Tina TSOU <[email-masked]>
Date: Wed, 25 Jul 2007 10:01:17 -0500

Hi all,
What I was going to comment on "eardley-pcn-architecture-00" presentation just after the line cut is below.
How about refine slide page 7
"PCN-egress-node needs to know address of PCN-ingress-node (or ‘centralised node’) that will decide whether to admit the new flow"
into
"PCN-boundary-node needs to know address of admission-decision-node that will decide whether to admit the new flow"

Then it can cover the following scenario the original texts did not cover.
1) admission control is made on the egress node (the original text only includes the ingress node makes the decision)
2) ingress node can also notify the centralised node (the original text only includes the egress node notifies the centralised node)
 
B. R.
Tina
Messengers: 
MSN: [email-masked]   Yahoo: tina_tsou    Skype: tinaTSOU    Jabber: [email-masked]    Google talk: [email-masked]

_______________________________________________
PCN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pcn

---

From: "Jozef Babiarz" <[email-masked]>
Date: Fri, 27 Jul 2007 18:43:18 -0400

Hi Tina,

I think the issue is that the egress node needs to know the address and
port number of the ingress node that physically admitted the flow into
the PCN-domain.

The egress node needs to send pre-congestion and congestion information
that is associated with the flow or flow aggregate back to the ingress
node directly or possible through a centralized entity. The ingress node
needs to enforce the stop admission or flow termination decision.

The issue of where admission or flow termination decision is made is a
separate topic of discussion. We should have a discussion on the
benefits of where the decision should be made, on ingress, egress, some
centralizes point or hybrid e.g., flow admission is done in ingress and
flow termination at egress, but in all cases enforcement of the decision
in at the ingress node.

Regards, Joe 
email:[email-masked] 
Telephone:613-763-6098 

________________________________

From: Tina TSOU [mailto:[email-masked]] 
Sent: July 25, 2007 11:01 AM
To: [email-masked]
Subject: [PCN] addressing

Hi all,
What I was going to comment on "eardley-pcn-architecture-00"
presentation just after the line cut is below.
How about refine slide page 7
"PCN-egress-node needs to know address of PCN-ingress-node (or
'centralised node') that will decide whether to admit the new flow"
into
"PCN-boundary-node needs to know address of admission-decision-node that
will decide whether to admit the new flow"

Then it can cover the following scenario the original texts did not
cover.

1) admission control is made on the egress node (the original text only
includes the ingress node makes the decision)

2) ingress node can also notify the centralised node (the original text
only includes the egress node notifies the centralised node)

B. R.
Tina
Messengers: 
MSN: [email-masked]   Yahoo: tina_tsou    Skype: tinaTSOU
Jabber: [email-masked]    Google talk: [email-masked]

---

From: "Tina TSOU" <[email-masked]>
Date: Sat, 28 Jul 2007 00:09:50 -0500

Hi Joe,
Thanks for reply:) I saw the need egress needs to know the address and port number of the ingress. If only pre-congestion and congestion information is sent, I agree that the original texts already cover all the cases.
I thought not only pre-congestion and congestion information is sent, so my comments were based on the architecture draft have the decision made in any of the ingress, egress, and centralized node.
 
B. R.
Tina
Messengers: 

  ----- Original Message ----- 
  From: Jozef Babiarz 
  To: Tina TSOU ; [email-masked] 
  Sent: Friday, July 27, 2007 5:43 PM
  Subject: RE: [PCN] addressing

  Hi Tina,

  I think the issue is that the egress node needs to know the address and port number of the ingress node that physically admitted the flow into the PCN-domain.

  The egress node needs to send pre-congestion and congestion information that is associated with the flow or flow aggregate back to the ingress node directly or possible through a centralized entity. The ingress node needs to enforce the stop admission or flow termination decision.

  The issue of where admission or flow termination decision is made is a separate topic of discussion. We should have a discussion on the benefits of where the decision should be made, on ingress, egress, some centralizes point or hybrid e.g., flow admission is done in ingress and flow termination at egress, but in all cases enforcement of the decision in at the ingress node.

  Regards, Joe 
  email:[email-masked] 
  Telephone:613-763-6098 

------------------------------------------------------------------------------

  Hi all,
  What I was going to comment on "eardley-pcn-architecture-00" presentation just after the line cut is below.
  How about refine slide page 7
  "PCN-egress-node needs to know address of PCN-ingress-node (or 'centralised node') that will decide whether to admit the new flow"
  into
  "PCN-boundary-node needs to know address of admission-decision-node that will decide whether to admit the new flow"

  B. R.
  Tina
  Messengers: