Subject: RE: [PCN] Fwd: I-D ACTION:draft-westberg-pcn-load-control-00.txt

From: <[email-masked]>
Date: Thu, 19 Jul 2007 15:22:28 +0100

Lars

I started reading your draft, but have a couple of clarification
questions about what you're proposing.

As I understand it:-

* there are two marking algorithms on the interior routers

* Admission-marking: if the rate exceeds threshold-1, then all pkts are
Adm marked

* Termination-marking: if the rate exceeds threshold-2, the
excess-traffic rate is measured and a fraction (1/N) of the excess rate
is Termination marked.

The adm marking algo is a bit unclear to me, sometimes it's described as
marking all pkts as soon as threshold-1 is exceeded - sometimes (eg
S4.1.3) it seems that a fraction of the excess traffic is marked (same
idea as above under " * Termination marked"). Which is correct?

I'm also not sure what "encoded DSCP" and "notified DSCP" mean. Do they
correspond to Admission-marking and Termination-marking, or do they mean
something else?

A point that doesn't just apply to this draft:

http://www.watersprings.org/pub/id/draft-briscoe-tsvwg-byte-pkt-mark-00.
txt which looks at "whether to allow for packet size when the network
codes or when the transport decodes congestion notification." This draft
argues that, when marking, the packet size should not be taken into
account. 
 
Thanks
phil

-----Original Message-----
From: Lars Westberg [mailto:[email-masked]] 
Sent: 25 June 2007 12:22
To: [email-masked]
Subject: [PCN] Fwd: I-D ACTION:draft-westberg-pcn-load-control-00.txt

Dear all

The "LC-PCN - The Load Control PCN solution" draft can be found via:
http://www.ietf.org/internet-drafts/draft-westberg-pcn-load-control-00.t
xt

Abstract

There is an increased interest of simple and scalable resource
provisioning
solution for Diffserv network.
The Load Control PCN (LC-PCN) addresses the following issues:

1. Admission control for real time data flows in stateless Diffserv
Domains
2. Flow termination: Termination of flows in case of exceptional events,
such as severe congestion after re-routing.
Admission control in a Diffserv stateless domain is a combination of:

  1. Probing, whereby a probe packet is
   sent along the forwarding path in a network to determine
   whether a flow can be admitted based upon the current
   congestion state of the network

  2. Admission control based on data marking, whereby in congestion
    situations the data packets are marked to notify the egress node
    that a congestion occurred on a particular ingress to egress
    path.
    The scheme provides the capability of controlling the traffic load
in
    the network without requiring signaling or any per-flow processing
in
    the core routers. The complexity of Load Control is kept to a
minimum
    to make implementation simple.

Kind regards,

Lars

_______________________________________________
PCN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pcn

---

From: <[email-masked]>
Date: Thu, 19 Jul 2007 17:01:15 +0100

Lars

I have just been reading
http://www.ietf.org/internet-drafts/draft-babiarz-pcn-3sm-00.txt. it
seems a very similar proposal? So one way it might be useful to clarify
your proposal is to compare it with the babiarz proposal.

Could you clarify how it differs:

* in the 2 algorithms at the PCN-interior-nodes, ie for
admission-marking & termination-marking
* in the encoding used for for admission-marking & termination-marking
(I think it's simply that draft-babiarz doesn't define encodings (ECN
field mentioned in passing), whereas draft-westberg says use new dscps).
* in the reaction at the PCN-boundary-nodes

thanks,

phil

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: 19 July 2007 15:22
To: [email-masked]; [email-masked]
Subject: RE: [PCN] Fwd: I-D
ACTION:draft-westberg-pcn-load-control-00.txt

Lars

As I understand it:-

 
Thanks
phil

-----Original Message-----
From: Lars Westberg [mailto:[email-masked]] 
Sent: 25 June 2007 12:22
To: [email-masked]
Subject: [PCN] Fwd: I-D ACTION:draft-westberg-pcn-load-control-00.txt

Dear all

Abstract

Kind regards,

Lars

---

From: Michael Menth <[email-masked]>
Date: Thu, 19 Jul 2007 18:09:20 +0200

Hi Phil,

the following is the contribution of the 3sm draft:
1) It proposes marked flow termination (aka explicit marking) which is a 
flow termination method alternative to the one presented in the cl-draft.
2) It proposes the behavior of the meters and markers that may be used 
in the cl-draft and and for the new termination scheme. This is not 
covered by the load-control draft in such detail.

We do not define encodings as this is done by other documents.

Regards,

Michael

[email-masked] wrote:
> seems a very similar proposal? So one way it might be useful to 
> clarify your proposal is to compare it with the babiarz proposal.
>
> * in the 2 algorithms at the PCN-interior-nodes, ie for admission-marking & termination-marking
> * in the encoding used for for admission-marking & termination-marking (I think it’s simply that draft-babiarz doesn’t define encodings (ECN field mentioned in passing), whereas draft-westberg says use new dscps).
> *From:* [email-masked] [mailto:[email-masked]]
> *Sent:* 19 July 2007 15:22
> *To:* [email-masked]; [email-masked]
> *Subject:* RE: [PCN] Fwd: I-D 
> questions about what you’re proposing.
>
> As I understand it:-
>
> * Admission-marking: if the rate exceeds threshold-1, then all pkts 
> are Adm marked
>
> excess-traffic rate is measured and a fraction (1/N) of the excess 
> rate is Termination marked.
>
> The adm marking algo is a bit unclear to me, sometimes it’s described 
> as marking all pkts as soon as threshold-1 is exceeded – sometimes (eg 
> idea as above under “ * Termination marked”). Which is correct?
>
> I’m also not sure what “encoded DSCP” and “notified DSCP” mean. Do 
> they correspond to Admission-marking and Termination-marking, or do 
> they mean something else?
>
> A point that doesn’t just apply to this draft:
>
> http://www.watersprings.org/pub/id/draft-briscoe-tsvwg-byte-pkt-mark-00.txt which looks at “whether to allow for packet size when the network codes or when the transport decodes congestion notification.” This draft argues that, when marking, the packet size should not be taken into account. 
>  
> Thanks
> phil
>
> *From:* Lars Westberg [mailto:[email-masked]]
> *Sent:* 25 June 2007 12:22
> *To:* [email-masked]
> *Subject:* [PCN] Fwd: I-D ACTION:draft-westberg-pcn-load-control-00.txt
>
> Dear all
>
> http://www.ietf.org/internet-drafts/draft-westberg-pcn-load-control-00.txt
>
>
> Abstract
>
> The scheme provides the capability of controlling the traffic load in
> the network without requiring signaling or any per-flow processing in
> the core routers. The complexity of Load Control is kept to a minimum
> ------------------------------------------------------------------------
>

-- 
Dr. Michael Menth, Assistant Professor
University of Wuerzburg, Institute of Computer Science
Am Hubland, D-97074 Wuerzburg, Germany, room B206
phone: (+49)-931/888-6644, fax: (+49)-931/888-6632
mailto:[email-masked]
http://www3.informatik.uni-wuerzburg.de/research/ngn

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Fri, 20 Jul 2007 16:38:39 +0200

Hi Phil
 
Thank you very much for reading the draft!
Please see comments in line!

> 
> ________________________________
> 
> 	Sent: donderdag 19 juli 2007 16:22
> I started reading your draft, but have a couple of 
> clarification questions about what you're proposing.
> 
> 	 
> 
> 	As I understand it:-
> 

Georgios: Yes you are right!

> 
> 	* Admission-marking: if the rate exceeds threshold-1, 
>     then all pkts are Adm marked

Georgios: Note that here the "encoded DSCP" marking is used. Thus also in
this state the excess-traffic rate is measured and a fraction (1/N) of the
excess rate is Termination (encoded) marked. However, another type of
marking could also be used, which is not explicitly described in this
document, but is somehow projected in the draft as "notified DSCP" . Sorry
for this!
We will clarify this operation in a next version of the draft. For the time
being assume that the "encoded DSCP" marking is used for both admission
control and flow termination features.
If this is applied then:
For both cases the excess-traffic rate is measured and a fraction (1/N) of
the excess rate is Termination (encoded) marked.

> 
> 	* Termination-marking: if the rate exceeds threshold-2, 
> the excess-traffic rate is measured and a fraction (1/N) of 
> the excess rate is Termination marked.

Georgios: agree!

> 	 
> 
> 	The adm marking algo is a bit unclear to me, sometimes 
> it's described as marking all pkts as soon as threshold-1 is 
> exceeded - sometimes (eg S4.1.3) it seems that a fraction of 
> the excess traffic is marked (same idea as above under " * 
> Termination marked"). Which is correct?

Georgios: You are right that the text is unclear. When the "encoded DSCP"
marking is used for admission control, 
then the excess-traffic rate is measured and a fraction (1/N) of the excess
rate is Termination (encoded) marked.
We will clarify this in the next version of the draft!

> 
> 	 
> 
> 	I'm also not sure what "encoded DSCP" and "notified 
> DSCP" mean. Do they correspond to Admission-marking and 
> Termination-marking, or do they mean something else?

Georgios: the "notified DSCP" is just projected somewhere in the text, and
that is not correct.
This marking is related to the scenario that an additional DSCP is needed
for the admission control feature, which is vaguely described in the draft.
For the time being assume that the "encoded DSCP" marking is used for both
admission control and flow termination features. We will clarify this in the
next version of the draft.
 
> http://www.watersprings.org/pub/id/draft-briscoe-tsvwg-byte-pk
> t-mark-00.txt
> which looks at "whether to allow for packet size when the 
> network codes or when the transport decodes congestion 
> notification." This draft argues that, when marking, the 
> packet size should not be taken into account. 

Georgios: Thank you for the pointer I will read the draft and discuss it
during the Chicago IETF meeting!

Best regards and see you in Chicago!
Georgios

> 	Subject: [PCN] Fwd: I-D
> 	There is an increased interest of simple and scalable 
> resource provisioning
> 	1. Admission control for real time data flows in 
> stateless Diffserv Domains
> 	Admission control in a Diffserv stateless domain is a 
> combination
> of:
>

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Fri, 20 Jul 2007 17:40:11 +0200

Hi Phil, Michael, Joe

I have read the 3sm draft, see below, and quicly compared it with the LC-PCN
draft.

http://www.ietf.org/internet-drafts/draft-babiarz-pcn-3sm-00.txt

>From a quick comparison I could derive is the following:
* Both algorithms can provide admission control, flow termination and 
ECMP handling during admission control and flow termination.

* Both algoriuthms use excess rate measurements at the interior. The
semantics are the same, but 
the implementation type is different, token bucket versus bandwidth
measurements.

* Both algorithms use probing during the admission control process and the
egress rejects a 
request when they are in "admission-stop" (or "congestion notification"
state.

The LC-PCN can support two encoding modes/states:
* One encoding mode/state for admission control and flow termination
In the current version only this option is described in detail. The marking
and metering used 
For admission control in 3SM and LC-PCN are different. Note that the 3SM
does not use the reduction factor "s"
In case of admission control, while in LC-PC, when the "encoded DSCP"
 marking is used, then the relation factor between metering and marking (N)
is used.

* Two encoding mode/state: one for admission control and one for flow
termination
(in this case the "notified DSCP"" is used for admission control and the
"encoded DSCP"
Is used for flow termination. Note that in this option the factor N is not
used for admission control in LC-PCN.
In this case the metering and marking 
Schemes used in 
LC-PCN and 3SM are semantically very similar.

* For flow termination, when only one value of the "s" parameter is used in
whole PCN domain (in LC-PCN one N value should be used in whole domain) then
the metering and marking algorithms in 3SM and LC-PCN are from a semantic
point of view the same. The mechanisms at the edges are somehow different.
In 3SM all flows that are marked are selected for termination, while in
LC-PCN flows the excess rate is measured and according to this rate
(corrected by using the value of N)
a number of flows that are  "affected marked" and "encoded marked" are
selected for termination.
Note that the LC-PCN algorithm at the egress takes into account the priority
of flows. 
However, the LC-PCN algorithm also works when no priority differentiation
between flows is used.

Best regards,
Georgios

I think that semantically the metering and marking mechanism are similar.
hen the parameter "s" is set to be equal in whole PCN domain 

> From: Georgios Karagiannis [mailto:[email-masked]] 
> Sent: vrijdag 20 juli 2007 16:44
> To: 'Georgios Karagiannis'
> 	Sent: donderdag 19 juli 2007 18:01
> http://www.ietf.org/internet-drafts/draft-babiarz-pcn-3sm-00.t
> xt. it seems a very similar proposal? So one way it might be 
> useful to clarify your proposal is to compare it with the 
> babiarz proposal.
> 
> 	 
> 
> 	* in the encoding used for for admission-marking & 
> termination-marking (I think it's simply that draft-babiarz 
> doesn't define encodings (ECN field mentioned in passing), 
> whereas draft-westberg says use new dscps).

---

From: Michael Menth <[email-masked]>
Date: Sat, 21 Jul 2007 08:24:59 +0200

Hi Georgios,

thank you very much for this email. It clarified things that I haven't 
understood or overseen when reading the draft.

> the implementation type is different, token bucket versus bandwidth

3sm does not perform excess rate measurement, but a token bucket marks 
excess traffic. Interior routers do not calculate rates!

> request when they are in "admission-stop" (or "congestion notification"

3sm allows probing as an option when necessary, but it is not the 
default mode.

>  marking is used, then the relation factor between metering and marking (N)

What's the benefit of using the "relation factor N" for admission 
marking? I haven't understood the objective of that mechanism.

> point of view the same. 

I'm not so sure whether they are the same. What's the objective of using 
N in combination with termination marking?

> The mechanisms at the edges are somehow different.

Best regards,

    Michael

---

From: <[email-masked]>
Date: Tue, 24 Jul 2007 17:55:15 +0100

let me clarify
you have only one sort of encoding, which is used for both adm ctrl & termination (as per charny-pcn-single-marking)
 
the marking algo is based on the excess-rate above some configured traffic rate on each node.
 
i couldnt work out whether this rate is the configured-admissible-rate or the configured-termination-rate (to use the terminology of the architecture draft)
 
i think you may be using the same idea as the single marking draft, ie assuming that every node in the PCN-domain has the same value for {admissible-rate / termination-rate} - is this right?
 
thanks
phil 

From: Georgios Karagiannis [mailto:[email-masked]]
Sent: Fri 20/07/2007 15:38
To: Eardley,PL,Philip,CXR9 R
Cc: [email-masked]; [email-masked]
Subject: RE: [PCN] Fwd: I-D ACTION:draft-westberg-pcn-load-control-00.txt

 Hi Phil

Georgios: agree!