Subject: [PCN] RE: draft-babiarz-pcn-3sm-00 pseudocode nit

From: "Jozef Babiarz" <[email-masked]>
Date: Tue, 4 Sep 2007 12:17:18 -0400

Bob, 
We selected this approach to reduce the number of instructions.
Our original rational was, since the pseudo-code in the "if" statement
does not subtract packet.size there is no need to set TB.fill = 0. We
believe there would be no meaningful difference between leaving the TB
at TB.fill versus empty since the TB is less than the size of the packet
from being empty and we are doing threshold marking. We also assumed
that TB.threshold is several times larger than the size of the largest
packet. 

Let us know if you disagree and we can add TB.fill = 0; line to the
example pseudo-code.
 
Regards, Joe
email:[email-masked]
Telephone:613-763-6098
-----Original Message-----
From: Bob Briscoe [mailto:[email-masked]] 
Sent: August 30, 2007 4:11 AM
To: Babiarz, Jozef (CAR:0S03)
Cc: [email-masked]
Subject: draft-babiarz-pcn-3sm-00 pseudocode nit

Joe,

In the admission marking pseudo-code in draft-babiarz-pcn-3sm-00
S.2.2.2, 
if a packet arrives that is larger than the current depth of the token 
bucket, you correctly mark the packet with admission stop marking, but I

think you've omitted to empty the bucket to zero as well.

/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\
      if (TB.fill < packet.size)
          TB.fill = 0;           // BB: Suggested amendment
          packet.mark = AS;
      else
          TB.fill = TB.fill - packet.size;
          if (TB.fill < TB.threshold)
              packet.mark = AS;
          endif
      endif
/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\

Bob

________________________________________________________________________
____
Bob Briscoe, <[email-masked]>      Networks Research Centre, BT
Research
B54/77 Adastral Park,Martlesham Heath,Ipswich,IP5 3RE,UK.    +44 1473
645196 

_______________________________________________
PCN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pcn

---

From: "Jozef Babiarz" <[email-masked]>
Date: Wed, 5 Sep 2007 09:25:10 -0400

Bob, 
No problem, added the one line to S.2.2.2
TB.fill = 0;           // BB: Suggested amendment

Regards, Joe
email:[email-masked]
Telephone:613-763-6098

-----Original Message-----
From: Bob Briscoe [mailto:[email-masked]] 
Sent: September 4, 2007 4:18 PM
To: Babiarz, Jozef (CAR:0S03)
Cc: PCN IETF list
Subject: Re: FW: [PCN] RE: draft-babiarz-pcn-3sm-00 pseudocode nit

Joe,

OK, I understand the desire to reduce the no. of instructions, and that 
this accuracy isn't deadly important.

But it's in the smaller branch and the less typically used branch of the

two anyway. So it doesn't reduce the max intructions per packet, nor
even 
the typical instructions per packet. It only saves one instruction for a

packet arriving in one fairly rare case.

It just gives a TB with a depth that isn't predictable - instead the
depth 
is approximately the same but the exact depth experienced depends on the

history of previously arrived packets. Larger packets tend to see a TB
with 
slightly less depth (probabilistically) than smaller ones, because
whenever 
a larger packet arrives at a bucket with fill less than the packet's
size, 
it invokes this approximate code, while a smaller packet won't,
necessarily.

I doubt there's a huge problem doing that. The only problem I can think
of 
is it will be less easy to verify experimentally against an analytical 
model of the bucket.

As I said, a nit that we don't really need to talk about at the IETF - I

wouldn't expect us to have to standardise whether or not this happens!

[PS - tho my jungle mail @ seems OK now, I'll look into why it bounced -

let me know if you get a bounce again.]

Bob

At 17:23 04/09/2007, Jozef Babiarz wrote:
>Bob, I'm forwarding you this email as I got a bounce from
>[email-masked]
>
>Regards, Joe
>email:[email-masked]
>Telephone:613-763-6098
>
>From: Babiarz, Jozef (CAR:0S03)
>Sent: September 4, 2007 12:17 PM
>To: Bob Briscoe
>Cc: [email-masked]
>Subject: [PCN] RE: draft-babiarz-pcn-3sm-00 pseudocode nit
>
>Bob,