Subject: RE: [PCN] Questions on probing

From: Steven Blake <[email-masked]>
Date: Mon, 28 Jan 2008 11:47:12 -0500

Philip,

Did you and Georgios come to some agreement on how to revise the probing
text in the architecture draft?  By my judgement the rough consensus of
the working group is that:

- we *will* discuss probing in the architecture draft
- we *will not* start any protocol work on probing.

I would like to see us get agreement on the probing text in the
architecture draft ASAP.

Thanks.

On Thu, 2007-12-13 at 16:44 +0000, [email-masked] wrote:

> Great, we're in violent agreement that I need to clarify this!
> 
> > -----Original Message-----
> > From: Georgios Karagiannis [mailto:[email-masked]]
> > Sent: 13 December 2007 16:07
> > To: Eardley,PL,Philip,CXR9 R; [email-masked]; [email-masked]
> > Subject: RE: [PCN] Questions on probing
> > 
> > Hi Phil
> > 
> > Sorry, but reading the text in Section 7.3 it gives me the impression
> that
> > the architecture draft is trying to get out of the PCN scope the
> feature
> > that provides
> > admission control when probing is used.
> > 
> > The given argumentation on the aggregation issue is in my opinion only
> > valid
> > for some
> > implementations/scenarios and cannot be extrapolated to cover all
> possible
> > scenarios/implementations
> > that are covered by the PCN scope.
> > 
> > Best regards,
> > Georgios
> > 
> > 
> > 
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]]
> > > Sent: donderdag 13 december 2007 15:46
> > > To: [email-masked]; [email-masked]; [email-masked]
> > > Subject: RE: [PCN] Questions on probing
> > >
> > > I don't see why this depends on implementation. Surely it
> > > depends on the scenario. The scenario I was thinking of was
> > > where the PCN-domain reaches out towards the end terminals
> > > where link capacity is low. (Well that could be better
> > > written - it's possible that there might be high link
> > > capacity near the end terminals, but normally link cap is
> > > lower near the edge.) Low link cap, in general, breaks the
> > > aggregation assumption.
> > >
> > > Now there're some people who have in mind using PCN in such
> > > scenarios, and doing adm ctrl by probing (for all new flows).
> > > The text does not make any judgement about whether such an
> > > approach is feasible, merely that it's out of the current scope.
> > >
> > > phil
> > >
> > > > -----Original Message-----
> > > > From: Georgios Karagiannis [mailto:[email-masked]]
> > > > Sent: 13 December 2007 14:34
> > > > To: Eardley,PL,Philip,CXR9 R; [email-masked];
> > > [email-masked]
> > > > Subject: RE: [PCN] Questions on probing
> > > >
> > > > Hi Phil
> > > >
> > > > My point is that I do not agree that the below bullet breaks
> > > > Assumption 3 (aggregation). This depends on how the algorithm
> > > is
> > > > implemented and I thought that the architectural draft should not
> > > describe
> > > > implementation steps.
> > > >
> > > > > o  Simply admitting the new flow has a significant risk of
> leading
> > > to
> > > > > overload, because the PCN-domain reaches out towards the end
> > > > > terminals where link capacity is low.
> > > >
> > > > Best regards,
> > > > Georgios
> > > >
> > > >
> > > >
> > > > > -----Original Message-----
> > > > > From: [email-masked] [mailto:[email-masked]]
> > > > > Sent: donderdag 13 december 2007 13:34
> > > > > To: [email-masked]; [email-masked];
> > > [email-masked]
> > > > > Subject: RE: [PCN] Questions on probing
> > > > >
> > > > > Hi Georgios
> > > > > To pick up on our of your comments, which concerns the
> > > archit draft
> > > > >
> > > > > >
> > > > > > "The first point breaks Assumption 3 (aggregation) and
> > > hence means
> > > > > that
> > > > > > this
> > > > > > viewpoint is out of scope of initial Charter of the PCN WG."
> > > > > >
> > > > > > I do not agree with this conclusion, since I do not
> > > agree with the
> > > > > > argumentation that the first point breaks Assumption 3 more
> > > > > than the
> > > > > > situation that no probing is used during admission control.
> > > > > > Therefore, please remove the sentence:
> > > > > > "The first point breaks Assumption 3 (aggregation) and
> > > hence means
> > > > > that
> > > > > > this
> > > > > > viewpoint is out of scope of initial Charter of the PCN WG."
> > > > > >
> > > > >
> > > > > I don't understand your comment, and wonder if it's just that
> the
> > > > > section is not very clear about the context of the draft at this
> > > > > point.
> > > > >
> > > > > the third viewpoint on 'why do probing' is simply
> > > 'admission control
> > > > > is always done by probing'.  It assumes the following:
> > > > >
> > > > >    o  Simply admitting the new flow has a significant risk of
> > > > > leading to
> > > > >       overload, because the PCN-domain reaches out towards the
> end
> > > > >       terminals where link capacity is low.
> > > > >
> > > > >    o  Every admission control decision involves probing, using
> the
> > > > >       signalling set-up message as the probe packet (eg
> > > RSVP PATH).
> > > > >
> > > > >    o  The PCN-marking behaviour is such that every packet is
> > > > > PCN-marked
> > > > >       if the flow should be blocked, hence only a single probing
> > > > > packet
> > > > >       is needed.
> > > > >
> > > > >    I think the first of these bullets breaks Assumption 3
> > > > > (aggregation) and hence means that this viewpoint is out
> > > of scope of
> > > > > the initial Charter of the PCN WG.
> > > > >
> > > > > phil 

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Steven Blake                <[email-masked]>
Ericsson/Redback Networks               +1 919-472-9913

_______________________________________________
PCN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pcn

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Tue, 29 Jan 2008 09:57:10 +0100

Hi Steven

According to the email discussion, I expect that Phil will update the text
in Section 7.3 
such that the feature that provides admission control when probing is used
is not considered
to be out of the scope of the PCN activities.

Your question in the original "Questions on probing" email was:
> 3. Does the working group need to do protocol work on probing prior to
>    last call for the architecture draft?

Therefore, I assume that your above observation should be:
- we *will not* start any protocol work on probing prior to
   last call for the architecture draft

Best regards,
Georgios

> From: Steven Blake [mailto:[email-masked]] 
> Sent: maandag 28 januari 2008 17:47
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Did you and Georgios come to some agreement on how to revise 
> the probing text in the architecture draft?  By my judgement 
> the rough consensus of the working group is that:
> 
> I would like to see us get agreement on the probing text in 
> the architecture draft ASAP.
> 
> 
> Thanks.
> 
> 
> > > The given argumentation on the aggregation issue is in my opinion 
> > > only valid for some implementations/scenarios and cannot be 
> > > extrapolated to cover all
> > possible
> > > > I don't see why this depends on implementation. Surely 
> it depends 
> > > > on the scenario. The scenario I was thinking of was where the 
> > > > PCN-domain reaches out towards the end terminals where link 
> > > > capacity is low. (Well that could be better written - it's 
> > > > possible that there might be high link capacity near the end 
> > > > terminals, but normally link cap is lower near the 
> edge.) Low link 
> > > > cap, in general, breaks the aggregation assumption.
> > > >
> > > > > > section is not very clear about the context of the draft at 
> > > > > > this point.
> > > > > >
> > > > > >       if the flow should be blocked, hence only a single 
> > > > > > probing packet
> > > > > >       is needed.
> > > > > >

---

From: <[email-masked]>
Date: Tue, 29 Jan 2008 14:43:26 -0000

Georgios

Currently working on draft, how about following:

   The third viewpoint assumes the following:

   o  Every admission control decision involves probing, for example
using the signalling set-up message as the probe packet (eg RSVP PATH).

   o  The PCN-marking behaviour is such that every packet is PCN-marked
      if the flow should be blocked, hence only a single probing packet
      is needed.

   This viewpoint has in particular been suggested for the scenario
where the PCN-domain reaches out to the end terminals.  See section 11.

Section 11 is a new section called something like "Beyond the scope of
the initial charter" (suggested by steven blake)
There I'll say something like (English needs tweaking):

Referring to the scenario where the PCN-domain reaches out to the end
terminals. Link capacity is likely to be low at the edge of the
PCN-domain. This breaks Assumption 3 (aggregation) and hence further
consideration is out of scope of the initial Charter of the PCN WG.

It has also been suggested to probe for admission of all calls in other
scenarios where Assumption 3 does hold. It has been agreed not to
consider this further <at least until blah>

<...> means some text I will agree off list with Steven to make sure it
is accurate (rather than bashing it on list)

Phil

> Sent: 29 January 2008 08:57
> To: 'Steven Blake'
> Cc: [email-masked]; Eardley,PL,Philip,CXR9 R
> > > > > > implemented and I thought that the architectural draft
should
> > > > > > not

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Tue, 29 Jan 2008 15:49:04 +0100

Hi Phil

Can you please provide some more information on the below point:

 > It has also been suggested to probe for admission of all 
> calls in other scenarios where Assumption 3 does hold. It has 
> been agreed not to consider this further <at least until blah>
> 

To which other scenarios will you refer?

Best regards,
Georgios

> Sent: dinsdag 29 januari 2008 15:43
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
>    o  Every admission control decision involves probing, for 
> example using the signalling set-up message as the probe 
> packet (eg RSVP PATH).
> 
>    This viewpoint has in particular been suggested for the 
> scenario where the PCN-domain reaches out to the end 
> terminals.  See section 11.
> 
> Section 11 is a new section called something like "Beyond the 
> scope of the initial charter" (suggested by steven blake) 
> Referring to the scenario where the PCN-domain reaches out to 
> the end terminals. Link capacity is likely to be low at the 
> edge of the PCN-domain. This breaks Assumption 3 
> (aggregation) and hence further consideration is out of scope 
> of the initial Charter of the PCN WG.
> 
> It has also been suggested to probe for admission of all 
> calls in other scenarios where Assumption 3 does hold. It has 
> been agreed not to consider this further <at least until blah>
> 
> <...> means some text I will agree off list with Steven to 
> make sure it is accurate (rather than bashing it on list)
> 
> Phil
> 
> > According to the email discussion, I expect that Phil will 
> update the
> text
> > in Section 7.3
> > such that the feature that provides admission control when 
> probing is
> used
> > is not considered
> > > 3. Does the working group need to do protocol work on 
> probing prior
> to
> > > Did you and Georgios come to some agreement on how to revise the 
> > > probing text in the architecture draft?  By my judgement 
> the rough

---

From: <[email-masked]>
Date: Tue, 29 Jan 2008 15:50:16 -0000

I was just going to leave it generic (" where Assumption 3 does hold").
I'm not that adding specific text is good - danger of wither just
repeating the scenarios given in the Intro or else giving the impression
"these are scenarios where we, the WG, think you should use probing"
(cos I don't think we'll get consensus on that).
Text suggestion welcome!

phil 

> Sent: 29 January 2008 14:49
> To: Eardley,PL,Philip,CXR9 R; [email-masked]
> Cc: [email-masked]
> > > > > > > > > section is not very clear about the context of the
draft
> > at

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Tue, 29 Jan 2008 16:58:03 +0100

Hi Phil

Agree with your proposal, on leaving it generic (" where Assumption 3 
does hold").  

Best regards,
Georgios

> Sent: dinsdag 29 januari 2008 16:50
> I'm not that adding specific text is good - danger of wither 
> just repeating the scenarios given in the Intro or else 
> giving the impression "these are scenarios where we, the WG, 
> think you should use probing"
> > > calls in other scenarios where Assumption 3 does hold. It 
> has been 
> > > agreed not to consider this further <at least until blah>
> > >
> > 
> > > where the PCN-domain reaches out to the end terminals.  
> See section 
> > > 11.
> > >
> > > Section 11 is a new section called something like "Beyond 
> the scope 
> > > of the initial charter" (suggested by steven blake) There 
> I'll say 
> > > something like (English needs tweaking):
> > >
> > > Referring to the scenario where the PCN-domain reaches out to the 
> > > end terminals. Link capacity is likely to be low at the 
> edge of the 
> > > (aggregation) and hence further consideration is out of 
> scope of the 
> > > initial Charter of the PCN WG.
> > >
> > > It has also been suggested to probe for admission of all calls in 
> > > other scenarios where Assumption 3 does hold. It has been 
> agreed not 
> > > to consider this further <at least until blah>
> > >
> > > <...> means some text I will agree off list with Steven 
> to make sure 
> > > it is accurate (rather than bashing it on list)
> > >
> > > Phil
> > >
> > > > > > > Sorry, but reading the text in Section 7.3 it 
> gives me the 
> > > > > > > impression
> > > > > > that
> > > > > > > > approach is feasible, merely that it's out of 
> the current
> > > scope.
> > > > > > > >
> > > > > > > > phil
> > > > > > > >

---

From: Steven Blake <[email-masked]>
Date: Tue, 29 Jan 2008 11:28:09 -0500

>    last call for the architecture draft

You sir are correct.

Regards,

---

From: Lars Eggert <[email-masked]>
Date: Tue, 29 Jan 2008 18:36:23 +0200

> the initial charter" (suggested by steven blake)

I think this would be better moved to an appendix, with a crystal  
clear indication that it discusses possibilities only.

I'd also like to caution the WG that steady progress on the current  
milestones is essential - effort spent on out-of-charter items is  
unlikely to advance those.

Lars

---

From: "Geib, Ruediger" <[email-masked]>
Date: Wed, 30 Jan 2008 08:41:22 +0100

Phil,

| Referring to the scenario where the PCN-domain reaches out to 
| the end terminals. Link capacity is likely to be low at the 
| edge of the PCN-domain. This breaks Assumption 3 
| (aggregation) and hence further consideration is out of scope 
| of the initial Charter of the PCN WG.

I'm a bit puzzled here - so far probing was suggested to cope 
with an absence of flows on an ingress egress aggregate, but 
in my recollection of the discussion assumption 3 was holding 
between edge nodes. While I agree that it may be useful to 
see marked packets travelling further then PCN edge nodes, 
I don't see a point in discussing measurement based 
admission control on links where it doesn't work (that's 
the meaning of "assumption 3 doesn't hold").

Regards,

Ruediger

---

From: <[email-masked]>
Date: Wed, 30 Jan 2008 13:03:34 -0000

Hi,

Not sure I exactly get what point is puzzling. 

But to clarify: [quoting from Arch draft]

"3.3. Assumption 3: Many flows and additional load
We assume that there are many flows on any bottleneck link in the
   PCN-domain ...
We do not make explicit assumptions on how many PCN-flows are in each
   ingress-egress-aggregate."

And on the reasons for probing:

"7.3. Discussion of rationale for probing, its downsides and open issues
   It is an unresolved question whether probing is really needed, but
   three viewpoints have been put forward as to why it is useful.  The
   first is perhaps the most obvious: there is no PCN-traffic on the
   ingress-egress-aggregate.  The second assumes that multipath routing
   ECMP is running in the PCN-domain.  The third viewpoint is that
   admission control is always done by probing."

> | of the initial Charter of the PCN WG.
Mention of Charter scope will be moved to Appendix.

> the meaning of "assumption 3 doesn't hold").

I agree with that!

Thanks,
phil

> From: Geib, Ruediger [mailto:[email-masked]]
> Sent: 30 January 2008 07:41
> To: Eardley,PL,Philip,CXR9 R
> Cc: [email-masked]

---

From: "Geib, Ruediger" <[email-masked]>
Date: Wed, 30 Jan 2008 14:13:09 +0100

Phil,

your first statement reads:

"Link capacity is likely to be low at the edge 
of the PCN-domain. This breaks Assumption 3
(aggregation) and hence further consideration 
is out of scope of the initial Charter of 
the PCN WG."

My statement is: in the case that Assumption 3 
doesn't hold on a link, measurement based 
admission control and probing don't make sense. 
This issue should never appear on any charter.

Regards,

Ruediger 

| -----Original Message-----
| From: [email-masked] [mailto:[email-masked]] 
| Sent: Wednesday, January 30, 2008 2:04 PM
| To: Geib, Rüdiger
| Cc: [email-masked]
| Subject: RE: [PCN] Questions on probing
| 
| Hi,
| 
| Not sure I exactly get what point is puzzling. 
| 
| But to clarify: [quoting from Arch draft]
| 
| "3.3. Assumption 3: Many flows and additional load We assume 
| that there are many flows on any bottleneck link in the
|    PCN-domain ...
| We do not make explicit assumptions on how many PCN-flows are in each
|    ingress-egress-aggregate."
| 
| And on the reasons for probing:
| 
| "7.3. Discussion of rationale for probing, its downsides and 
| open issues
|   It is an unresolved question whether probing is really needed, but
|   three viewpoints have been put forward as to why it is useful.  The
|   first is perhaps the most obvious: there is no PCN-traffic on the
|   ingress-egress-aggregate.  The second assumes that multipath routing
|   ECMP is running in the PCN-domain.  The third viewpoint is that
|   admission control is always done by probing."
| 
| > | (aggregation) and hence further consideration is out of scope of the 
| > | initial Charter of the PCN WG.
| Mention of Charter scope will be moved to Appendix.
| 
| > I don't see a point in discussing measurement based admission control 
| > on links where it doesn't work (that's the meaning of "assumption 3 
| > doesn't hold").
| 
| I agree with that!
| 
| Thanks,
| phil
| 
| > -----Original Message-----
| > From: Geib, Ruediger [mailto:[email-masked]]
| > Sent: 30 January 2008 07:41
| > To: Eardley,PL,Philip,CXR9 R
| > Cc: [email-masked]
| > Subject: RE: [PCN] Questions on probing
| > 
| > Phil,
| > 
| > | Referring to the scenario where the PCN-domain reaches out to the 
| > | end terminals. Link capacity is likely to be low at the edge of the 
| > | PCN-domain. This breaks Assumption 3
| > | (aggregation) and hence further consideration is out of scope of the 
| > | initial Charter of the PCN WG.
| > 
| > I'm a bit puzzled here - so far probing was suggested to cope with an 
| > absence of flows on an ingress egress aggregate, but in my 
| > recollection of the discussion assumption 3 was holding between edge 
| > nodes. While I agree that it may be useful to see marked packets 
| > travelling further then PCN edge nodes, I don't see a point in 
| > discussing measurement based admission control on links where it 
| > doesn't work (that's the meaning of "assumption 3 doesn't hold").
| > 
| > Regards,
| > 
| > Ruediger
|