Subject: [PCN] PCN response to ITU-T liaison

From: Steven Blake <[email-masked]>
Date: Wed, 09 Apr 2008 21:34:42 -0400

ITU-T Study Group 11 sent the PCN working a liaison statement in
February, titled: "Intended work on the application of PCN in a
RACF-controlled environment".  The statement is available at:

https://datatracker.ietf.org/liaison/423/

The chairs have drafted the following liaison response.  We would like
to have working group consensus on this response before sending it to
SG11.  Please send comments to the list within the next two weeks.

-------------------------

To: ITU-T Study Group 11

Thank you for your liaison from your Seoul meeting on
your intent to utilize PCN in a RACF-controlled environment.

At this time, key details of the PCN architecture, such as packet
encoding, interior node marking behaviors, and edge node computations
and communication flows, still remain to be decided.  Hence it would be
premature for the ITU-T to begin work on the use of PCN in a
RACF-controlled environment.

We encourage you to continue monitoring developments in the PCN working
group, and to keep us informed as you investigate the requirements of
using the IETF PCN architecture and protocols in a RACF-controlled 
environment.

Thank you,

Scott Bradner and Steven Blake, PCN working group co-chairs

// Steve

_______________________________________________
PCN mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcn

---

From: "Geib, Ruediger" <[email-masked]>
Date: Thu, 10 Apr 2008 10:15:14 +0200

Steve,

I have no objections to the proposed liaison response text. 

A question is, which architecture is assumed to support RACF. 
I'm not an expert there, but I wouldn't wonder if it is a 
centralised functionality. And the alternative reference 
document to be found in the ITU doc point to this direction 
(COPS, H.248 and DIAMETER). I don't regard this as a bad 
thing per se, as I didn't finally make up my mind on the 
best possible solution (Joe's last proposal on marking 
however requires on path signaling). What I want to say is, 
we should be careful here to avoid ITU to put architectural 
constraints on our work.

Regards,

Rudiger

| -----Original Message-----
| From: [email-masked] [mailto:[email-masked]] On 
| Behalf Of Steven Blake
| Sent: Thursday, April 10, 2008 3:35 AM
| To: pcn
| Subject: [PCN] PCN response to ITU-T liaison
| 
| ITU-T Study Group 11 sent the PCN working a liaison statement 
| in February, titled: "Intended work on the application of PCN 
| in a RACF-controlled environment".  The statement is available at:
| 
| https://datatracker.ietf.org/liaison/423/
| 
| The chairs have drafted the following liaison response.  We 
| would like to have working group consensus on this response 
| before sending it to SG11.  Please send comments to the list 
| within the next two weeks.
| 
| -------------------------
| 
| To: ITU-T Study Group 11
| 
| Thank you for your liaison from your Seoul meeting on your 
| intent to utilize PCN in a RACF-controlled environment.
| 
| At this time, key details of the PCN architecture, such as 
| packet encoding, interior node marking behaviors, and edge 
| node computations and communication flows, still remain to be 
| decided.  Hence it would be premature for the ITU-T to begin 
| work on the use of PCN in a RACF-controlled environment.
| 
| We encourage you to continue monitoring developments in the 
| PCN working group, and to keep us informed as you investigate 
| the requirements of using the IETF PCN architecture and 
| protocols in a RACF-controlled environment.
| 
| Thank you,
| 
| Scott Bradner and Steven Blake, PCN working group co-chairs
| 
| 
|  
| // Steve
| 
| _______________________________________________
| PCN mailing list
| [email-masked]
| https://www.ietf.org/mailman/listinfo/pcn
| 
_______________________________________________
PCN mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcn

---

From: Tom Taylor <[email-masked]>
Date: Thu, 10 Apr 2008 12:22:22 -0400

My internet connection is so poor tonight I haven't been able to finish 
downloading my messages. It's pretty late at night where I am at the moment, so 
I figure I'd better respond to this one regardless of what else follows in the 
list and get to bed.

As I argued in our meeting with management, the broad structure of PCN has been 
set. What is the essential subject matter for the PCN WG is more on the level of 
detail when considering how to apply PCN in a RACF-controlled environment. I 
agree that the ITU-T should proceed with caution, and clearly should not produce 
a final document before the PCN WG has delivered. I also agree that the ITU-T's 
initial work should be on requirements, to the benefit of both themselves and 
the PCN WG. However, I also believe that because the ITU-T is building a 
framework around PCN rather than working on the protocol itself, it may well be 
possible that the ITU-T can accomplish some design work in advance of completion 
of PCN design.

Bottom line: rather than "premature for the ITU-T to begin work ..." I think it 
reasonable to say "be advisable for the ITU-T to use caution in their work ...".

---

From: Steven Blake <[email-masked]>
Date: Sun, 20 Apr 2008 13:12:23 -0400

> we should be careful here to avoid ITU to put architectural 

Ruediger,

I believe the ITU-T work assumes some centralized component(s) in the
architecture.  On the other hand, I don't believe that what they have in
mind at the moment imposes any architectural constraints on PCN.  Your
point is well taken.

Note: I will be (mostly) off line over the next week.

Regards,

// Steve

---

From: Steven Blake <[email-masked]>
Date: Sun, 20 Apr 2008 13:14:26 -0400

> reasonable to say "be advisable for the ITU-T to use caution in their work ...".

Tom,

I don't object to this re-phrasing.

Regards,

// Steve