Subject: [PCN] PCN WG last call for draft-ietf-pcn-architecture-05.txt

From: 佐藤 大輔 <[email-masked]>
Date: Thu, 14 Aug 2008 19:32:34 +0900

Hi all,

I have been interested in PCN WG and I have joined PCN WG since IETF69(Chicago).

I have reviewed the architecture draft and have a comment on Sec 6.3. 
The third option (both admission control and flow termination) almost
describes the single marking algorithm itself. This description seems to
exclude a future new algorithm and to limit a solution. In my opinion, a
new algorithm should not be excluded. Actually, a new algorithm idea was
presented in Dublin by Roudiger Geib.

I propose that the third option is modified as follows,
o both admission cotrol and flow termination: Either excess-traffic-marking
algorithm or threshold-marking algorithm writes PCN-marks. As an example
of excess-traffic-marking case (Figure 2), [I-D.
charney-pcn-single-marking] describes how both admission control and
flow termination can be triggered and also gives some of the pros and
cons of this approarch. The main downside is that admission control is
less accurate.

Best regards,
Daisuke SATOH

> Date: Fri, 08 Aug 2008 20:03:40 -0400
> From: Steven Blake <[email-masked]>
> Subject: [PCN] PCN WG last call for draft-ietf-pcn-architecture-05.txt
> To: pcn <[email-masked]>
> Message-ID: <1218240220.16668.6.camel@tachyon>
> Content-Type: text/plain
> 
> This message starts a 2+-week PCN working group last call for advancing
> 
>         Title           : Pre-Congestion Notification Architecture
>         Author(s)       : P. Eardley
>         Filename        : draft-ietf-pcn-architecture-05.txt
>         Pages           : 54
>         Date            : 2008-08-07
> 
> as an Informational RFC.  Substantive comments and statements of support
> for this draft should be sent to the pcn mailing list.  Editorial
> suggestions can be sent directly to the document editor.  
> The last call will end on Wednesday August 27.
> 
> // Steve
> 
> 
> 
> ------------------------------
> 
> _______________________________________________
> PCN mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcn
> 
> 
> End of PCN Digest, Vol 25, Issue 6
> **********************************

_______________________________________________
PCN mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcn

---

From: <[email-masked]>
Date: Thu, 14 Aug 2008 13:24:56 +0100

Thanks Daisuke.
Your point seems reasonable to me. Just from a text point of view, I
think it would be easier to keep the existing bullet as is (since it
describes a well-understood scheme), and add a new bullet that says
they're might be something else (currently unknown scheme) to achieve
adm ctrl & flow termin with a single marking algo

Best wishes,
phil

{ -----Original Message-----
{ From: [email-masked] [mailto:[email-masked]] On Behalf Of
{ [email-masked]
{ Sent: 14 August 2008 11:33
{ To: [email-masked]
{ Subject: [PCN] PCN WG last call for draft-ietf-pcn-architecture-05.txt
{ 
{ Hi all,
{ 
{ 
{ I have been interested in PCN WG and I have joined PCN WG since
{ IETF69(Chicago).
{ 
{ I have reviewed the architecture draft and have a comment on Sec 6.3.
{ The third option (both admission control and flow termination) almost
{ describes the single marking algorithm itself. This description seems
to
{ exclude a future new algorithm and to limit a solution. In my opinion,
a
{ new algorithm should not be excluded. Actually, a new algorithm idea
was
{ presented in Dublin by Roudiger Geib.
{ 
{ 
{ 
{ I propose that the third option is modified as follows,
{ o both admission cotrol and flow termination: Either excess-traffic-
{ marking
{ algorithm or threshold-marking algorithm writes PCN-marks. As an
example
{ of excess-traffic-marking case (Figure 2), [I-D.
{ charney-pcn-single-marking] describes how both admission control and
{ flow termination can be triggered and also gives some of the pros and
{ cons of this approarch. The main downside is that admission control is
{ less accurate.
{ 
{ 
{ 
{ 
{ Best regards,
{ Daisuke SATOH
{ 
{ 
{ 
{ 
{ 
{ > Date: Fri, 08 Aug 2008 20:03:40 -0400
{ > From: Steven Blake <[email-masked]>
{ > Subject: [PCN] PCN WG last call for
draft-ietf-pcn-architecture-05.txt
{ > To: pcn <[email-masked]>
{ > Message-ID: <1218240220.16668.6.camel@tachyon>
{ > Content-Type: text/plain
{ >
{ > This message starts a 2+-week PCN working group last call for
advancing
{ >
{ >         Title           : Pre-Congestion Notification Architecture
{ >         Author(s)       : P. Eardley
{ >         Filename        : draft-ietf-pcn-architecture-05.txt
{ >         Pages           : 54
{ >         Date            : 2008-08-07
{ >
{ > as an Informational RFC.  Substantive comments and statements of
support
{ > for this draft should be sent to the pcn mailing list.  Editorial
{ > suggestions can be sent directly to the document editor.
{ > The last call will end on Wednesday August 27.
{ >
{ > // Steve
{ >
{ >
{ >
{ > ------------------------------
{ >
{ > _______________________________________________
{ > PCN mailing list
{ > [email-masked]
{ > https://www.ietf.org/mailman/listinfo/pcn
{ >
{ >
{ > End of PCN Digest, Vol 25, Issue 6
{ > **********************************
{ 
{ _______________________________________________
{ PCN mailing list
{ [email-masked]
{ https://www.ietf.org/mailman/listinfo/pcn
_______________________________________________
PCN mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcn