Subject: Re: [PCN] Initial Draft: draft-briscoe-pcn-3-in-1-encoding-00

From: Michael Menth <[email-masked]>
Date: Thu, 06 Nov 2008 14:03:25 +0100

Hi Bob,

also from my perspective this encoding proposal is most sensible IF the 
tunneling issues will ever be resolved. Prerequisite for its application 
is that all tunnel ingress and egress nodes within a PCN domain use the 
new tunneling modes specified in

http://www.ietf.org/internet-drafts/draft-ietf-tsvwg-ecn-tunnel-01.txt

Correct?

Regards,

    Michael

Bob Briscoe wrote:
> Hi,
>
> I just posted this new draft-briscoe-pcn-3-in-1-encoding-00.txt 
> documenting another proposed experimental encoding that Toby described 
> in a slide at the Dublin IETF.
>
> I just wrote this because draft-ietf-tsvwg-ecn-tunnel-01.txt recenty 
> became a WG item in tswvwg, so there's a chance we could finally fix 
> ECN tunnelling behaviour. If we do, then we can have this much simpler 
> 3-state PCN encoding in one Diffserv codepoint. I've called it the 
> 3-in-1 PCN encoding.
>
> It's just to put a stake in the ground so people can refer to it. We 
> won't be pushing for this to become a PCN WG item until the baseline 
> encoding has gone thru, and until draft-ietf-tsvwg-ecn-tunnel-01.txt 
> has got a bit further in TSVWG.
>
>
> Bob
>
>
>> From: IETF I-D Submission Tool <[email-masked]>
>> To: <[email-masked]>
>> Subject: New Version Notification for
>>          draft-briscoe-pcn-3-in-1-encoding-00
>> Date: Mon, 27 Oct 2008 08:46:29 -0700
>> X-OriginalArrivalTime: 27 Oct 2008 15:46:37.0589 (UTC) 
>> FILETIME=[32640C50:01C9384B]
>> X-Spam-Score: 0 ()
>> X-Scanned-By: MIMEDefang 2.56 on 132.146.168.158
>>
>>
>> A new version of I-D, draft-briscoe-pcn-3-in-1-encoding-00.txt has 
>> been successfuly submitted by Bob Briscoe and posted to the IETF 
>> repository.
>>
>> Filename:       draft-briscoe-pcn-3-in-1-encoding
>> Revision:       00
>> Title:          PCN 3-State Encoding Extension in a single DSCP
>> Creation_date:  2008-10-27
>> WG ID:          Independent Submission
>> Number_of_pages: 8
>>
>> Abstract:
>> Pre-congestion notification (PCN) is a mechanism designed to protect
>> the quality of service of inelastic flows.  It does this by marking
>> packets when traffic load on a link is approaching or has exceeded a
>> threshold below the physical link rate.  This document specifies an
>> extension to the two-state PCN baseline encoding that enables three
>> encoding states to be carried in the IP header without using more
>> than one Diffserv codepoint.  It presupposes a standards action has
>> removed the limit of two encoding states in current tunnelling
>> mechanisms.
>>
>>
>>
>>
>> The IETF Secretariat.
>
> ____________________________________________________________________________ 
>
> Bob Briscoe, <[email-masked]>      Networks Research Centre, BT 
> Research
> B54/77 Adastral Park,Martlesham Heath,Ipswich,IP5 3RE,UK.    +44 1473 
> 645196
> _______________________________________________
> PCN mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcn

-- 
Dr. Michael Menth, Assistant Professor
University of Wuerzburg, Institute of Computer Science
Am Hubland, D-97074 Wuerzburg, Germany, room B206
phone: (+49)-931/888-6644, fax: (+49)-931/888-6632
mailto:[email-masked]
http://www3.informatik.uni-wuerzburg.de/research/ngn

_______________________________________________
PCN mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcn

---

From: <[email-masked]>
Date: Thu, 6 Nov 2008 13:24:41 -0000

Michael,

Yes, I believe that's right
- If the tunnelling issue are sorted (in general), then something on the
lines of this proposal is the most sensible option
- if the tunnelling issues are sorted in a specific PCN domain (but not
sorted out in general), then this encoding proposal would be possible in
that domain. 
- otherwise this encoding is not a good choice.
- the tunnelling work should make progress before it's worth the
proposal progressing much further (eg before it becomes a WG doc)

phil
{ -----Original Message-----
{ From: [email-masked] [mailto:[email-masked]] On Behalf Of
{ Michael Menth
{ Sent: 06 November 2008 13:03
{ To: Briscoe,RJ,Bob,XVR9 BRISCORJ R
{ Cc: PCN IETF list
{ Subject: Re: [PCN] Initial Draft: draft-briscoe-pcn-3-in-1-encoding-00
{ 
{ Hi Bob,
{ 
{ also from my perspective this encoding proposal is most sensible IF
the
{ tunneling issues will ever be resolved. Prerequisite for its
application
{ is that all tunnel ingress and egress nodes within a PCN domain use
the
{ new tunneling modes specified in
{ 
{ http://www.ietf.org/internet-drafts/draft-ietf-tsvwg-ecn-tunnel-01.txt
{ 
{ Correct?
{ 
{ Regards,
{ 
{     Michael
{ 
{ Bob Briscoe wrote:
{ > Hi,
{ >
{ > I just posted this new draft-briscoe-pcn-3-in-1-encoding-00.txt
{ > documenting another proposed experimental encoding that Toby
described
{ > in a slide at the Dublin IETF.
{ >
{ > I just wrote this because draft-ietf-tsvwg-ecn-tunnel-01.txt recenty
{ > became a WG item in tswvwg, so there's a chance we could finally fix
{ > ECN tunnelling behaviour. If we do, then we can have this much
simpler
{ > 3-state PCN encoding in one Diffserv codepoint. I've called it the
{ > 3-in-1 PCN encoding.
{ >
{ > It's just to put a stake in the ground so people can refer to it. We
{ > won't be pushing for this to become a PCN WG item until the baseline
{ > encoding has gone thru, and until draft-ietf-tsvwg-ecn-tunnel-01.txt
{ > has got a bit further in TSVWG.
{ >
{ >
{ > Bob
{ >
{ >
{ >> From: IETF I-D Submission Tool <[email-masked]>
{ >> To: <[email-masked]>
{ >> Subject: New Version Notification for
{ >>          draft-briscoe-pcn-3-in-1-encoding-00
{ >> Date: Mon, 27 Oct 2008 08:46:29 -0700
{ >> X-OriginalArrivalTime: 27 Oct 2008 15:46:37.0589 (UTC)
{ >> FILETIME=[32640C50:01C9384B]
{ >> X-Spam-Score: 0 ()
{ >> X-Scanned-By: MIMEDefang 2.56 on 132.146.168.158
{ >>
{ >>
{ >> A new version of I-D, draft-briscoe-pcn-3-in-1-encoding-00.txt has
{ >> been successfuly submitted by Bob Briscoe and posted to the IETF
{ >> repository.
{ >>
{ >> Filename:       draft-briscoe-pcn-3-in-1-encoding
{ >> Revision:       00
{ >> Title:          PCN 3-State Encoding Extension in a single DSCP
{ >> Creation_date:  2008-10-27
{ >> WG ID:          Independent Submission
{ >> Number_of_pages: 8
{ >>
{ >> Abstract:
{ >> Pre-congestion notification (PCN) is a mechanism designed to
protect
{ >> the quality of service of inelastic flows.  It does this by marking
{ >> packets when traffic load on a link is approaching or has exceeded
a
{ >> threshold below the physical link rate.  This document specifies an
{ >> extension to the two-state PCN baseline encoding that enables three
{ >> encoding states to be carried in the IP header without using more
{ >> than one Diffserv codepoint.  It presupposes a standards action has
{ >> removed the limit of two encoding states in current tunnelling
{ >> mechanisms.
{ >>
{ >>
{ >>
{ >>
{ >> The IETF Secretariat.
{ >
{ >
{
________________________________________________________________________
__
{ __
{ >
{ > Bob Briscoe, <[email-masked]>      Networks Research Centre, BT
{ > Research
{ > B54/77 Adastral Park,Martlesham Heath,Ipswich,IP5 3RE,UK.    +44
1473
{ > 645196
{ > _______________________________________________
{ > PCN mailing list
{ > [email-masked]
{ > https://www.ietf.org/mailman/listinfo/pcn
{ 
{ --
{ Dr. Michael Menth, Assistant Professor
{ University of Wuerzburg, Institute of Computer Science
{ Am Hubland, D-97074 Wuerzburg, Germany, room B206
{ phone: (+49)-931/888-6644, fax: (+49)-931/888-6632
{ mailto:[email-masked]
{ http://www3.informatik.uni-wuerzburg.de/research/ngn
{ 
{ _______________________________________________
{ PCN mailing list
{ [email-masked]
{ https://www.ietf.org/mailman/listinfo/pcn
_______________________________________________
PCN mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcn

---

From: Bob Briscoe <[email-masked]>
Date: Thu, 06 Nov 2008 16:45:53 +0000

Michael,

>sorted out in general), then this encoding proposal would be possible in

ecn-tunnel contains a new ECN encap and decap. The idea is:
* All docs say PCN excess-rate marking needs the new ECN encap
* The experimental PCN 3-in-1 encoding needs the new ECN decap

- new ECN encap behaviour (S.5): looks hopeful for stds track
- new ECN decap behaviour (Appx C): possible for stds track, 
otherwise I'll put it in for expt track

If Appx C goes to:
- stds track, it would seem obvious to make the 3-in-1 coding stds track too.
- expt track, the 3-in-1 coding ought to be expt track too, and the 
two together would be needed to define the experiment with this encoding.

Bob

____________________________________________________________________________
Bob Briscoe, <[email-masked]>      Networks Research Centre, BT Research
B54/77 Adastral Park,Martlesham Heath,Ipswich,IP5 3RE,UK.    +44 1473 645196