Subject: [PCN] Comments on draft-satoh-pcn-ST-marking-00.txt

From: <[email-masked]>
Date: Wed, 19 Nov 2008 23:37:38 -0000

Hi Daisuke,
your draft is very interesting, and good discussion over the last couple of days!
 
here are some questions & comments on your draft, http://www.ietf.org/mail-archive/web/pcn/current/msg01868.html
i tried to briefly summarise the points i remembered from the WG meeting, as we didn't have time to get to the bottom of them all yesterday.
 
1. Only threshold marking or only excess marking
With the current draft, if you only have 1 encoding state for PCN-marking, then you have 3 possibilities:
- just do threshold marking for accurate adm ctrl
- just do excess marking for accurate flow termination
- do excess marking (at PCN-admissible-rate) for both admission control (somewhat inaccurately) and flow termination 
How easy would be to do this with your proposal? or are you basically committed to the third bullet?
 
2. Forward Migration 
The current marking behaviour is written so that:
- if you have only one encoding state you can do both admission control (somewhat inaccurately) and flow termination (or you can just do adm ctrl (accurately) or just do flow termination); 
- but if you later have two encoding states, then you simply mark pkts with both encoding states - no changes needed to the marking behaviour.
With your draft, what happens if you later have two encoding states? do you need to upgrade your routers with new marking behaviour? or can you do something as simple as with the current WG draft?

the other 3 issues definitely need more explanation than is below, just trying to quickly capture them (will leave it to others to write properly about them) 
 
3. worry about admission control accuracy
eg slide 7 of http://www.ietf.org/proceedings/08nov/slides/pcn-8.pdf
the marking rate vs pkt rate seems to make assumptions about the traffic arriving. eg if it was very smooth traffic (CBR flows, or smoothed by nw) then the graph wouldnt look like this. 
 
4. distinguishing admission and termination
although there is only one type of PCN-marking, basically the egress interprets occasional PCN-marks as meaning "adm ctrl" and a series of pkts that are all consecutively marked as "flow termination". an issue might be if the link is actually doing admission marking, ie PCN-marking 1/N pkts, but somehow all the marks happen to the same egress - which therefore interprets them as flow termination. seems like this could happen if the flows are synchronised (eg they're all CBR flows)
 
5. flow termination 
slide 15 shows that you only terminate "y%" at a time, ie at least a round trip time (+measurement intervals) between each batch of "y%" that you terminate. but it's tricky to know what to set "y" to, eg make it big and you can terminate fast, but this also means that you risk over-terminating by a significant amount. 
 
thanks
phil
_______________________________________________
PCN mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcn

---

From: Michael Menth <[email-masked]>
Date: Thu, 20 Nov 2008 09:26:04 +0100

Hi Phil and others,

> although there is only one type of PCN-marking, basically the egress interprets occasional PCN-marks as meaning "adm ctrl" and a series of pkts that are all consecutively marked as "flow terminatio…
The same phenomenon occurs when flow termination is based on excess 
marking based on the admissible rate. See IV.F of
http://www3.informatik.uni-wuerzburg.de/~menth/Publications/papers/Menth08-Sub-9.pdf

> slide 15 shows that you only terminate "y%" at a time, ie at least a round trip time (+measurement intervals) between each batch of "y%" that you terminate. but it's tricky to know what to set "y"…
Terminating y% of the PCN excess traffic rate is rather unproblematic as 
this leads to an exponential decay of the PCN excess traffic rate. 
However, here y% of the overall PCN rate is terminated and, therefore, 
it is basically impossible to avoid overtermination.

Regards,

    Michael

-- 
Dr. Michael Menth, Assistant Professor
University of Wuerzburg, Institute of Computer Science
Am Hubland, D-97074 Wuerzburg, Germany, room B206
phone: (+49)-931/888-6644, fax: (+49)-931/888-6632
mailto:[email-masked]
http://www3.informatik.uni-wuerzburg.de/research/ngn