Subject: Re: [PCN] new version LC-PCN draft + conclusions

From: <[email-masked]>
Date: Wed, 19 Nov 2008 02:07:25 -0000

HI GEOrgios
to answer the first point below.
 
It would seem possible to devise an extension encoding that allowed for PCN affected marking - so i guess that means the option is open as you request.
 
Incidentally, with the marking behaviour defined in the WG draft, if a node is excess traffic marking some pkts, then all the other pkts will be threshold marked. so ThM can be used as a kind of proxy for affected marking. 
it's not perfect (imagine if a different ECMP path in the same ingress egress aggregate is doing ThM but not ExM, then you might terminate a flow that doesnt go through the real problem link. would be interestign to see some realistic analysis /simulations of whether the chances are that this 'unhelpful termination' would happen just once & only very rarely, or whether it could keep happening. ie is it good enough?).
 
phil
 
----------------------------
*	Subject: [PCN] new version LC-PCN draft + conclusions 
*	From: "Georgios Karagiannis" <karagian at cs.utwente.nl <mailto:[email-masked]> > 
*	Date: Tue, 11 Nov 2008 17:16:05 +0000 
 
Dear all

Please note that a new version of the LC-PCN draft has been submitted,
see:

http://www.ietf.org/internet-drafts/draft-westberg-pcn-load-control-05.txt

This version contains among other results also the results that were
presented during the IETF in Dublin.

Section 5.8 contains the following experiment conclusions.

   Based on the results obtained from the experiments presented in
   Sections 5.5, 5.6 and 5.7 this document recommends the following:

   o  Leave open the option to use PCN_Affected_Marking encoding since
      it can solve the ECMP problem and it can provide an efficient
      solution for the HOSE model.  In this document the term HOSE is
      referring to the aggregation of incoming traffic from all ingress
      edges, which is associated with one traffic class, i.e., PHB,
      towards one egress edge.  This type of HOSE model is equivalent to
      the Multiple to Point (MP2P) type of aggregation.

   o  Leave open the option of using random dropping in PCN-interior-
      nodes for PCN_Marking, PCN_Affected_Marking and PCN_unmarked
      encoded packets.

   o  Leave open the option of using the parameter N such that the
      marked excess rate can represent also high level of measured
      excess rate:

   **** Implemented by marking every N-th packet (or byte) instead of
   marking each packet (or byte).

Best regards,
Georgios

_______________________________________________
PCN mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcn

---

From: <[email-masked]>
Date: Wed, 19 Nov 2008 02:16:02 -0000

HI Georgios
response to your third point below.
 
this has already been discussed extensively on the mailing list. there seems no benefit to this, because the same system behaviour can be achieved by doing "1/N" behaviour at the PCN-boundary-node instead of at the PCN-interior-node.
 
pointers to previous discussion:
http://www.ietf.org/mail-archive/web/pcn/current/msg01642.html
http://www.ietf.org/mail-archive/web/pcn/current/msg01091.html
https://datatracker.ietf.org/drafts/draft-menth-pcn-emft/
 
so i am strongly opposed to including this option in the markng draft. 
 
phil

Dear all

Best regards,
Georgios

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Wed, 19 Nov 2008 11:27:00 +0100

Hi Phil

My argument was that doing the "1/N" at the PCN-boundary-node instead of the

PCN-interior-node is not good enough!

However, I would like to propose the following:

* Work-out the option of doing 1/N at the PCN-boundary-node. 
* If this option is not good enough to satisfy the requirements for a PCN
deployment scenario like LC-PCN, 
   then allow to work out an experimental specification that can use the 1/N
proportionality 
  at PCN_interior_nodes.

Best regards,
Georgios

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: woensdag 19 november 2008 3:16
> To: [email-masked]; [email-masked]
> Subject: RE: [PCN] new version LC-PCN draft + conclusions
> 
> HI Georgios
> this has already been discussed extensively on the mailing 
> list. there seems no benefit to this, because the same system 
> behaviour can be achieved by doing "1/N" behaviour at the 
> PCN-boundary-node instead of at the PCN-interior-node.
>  
> This version contains among other results also the results 
> that were presented during the IETF in Dublin.
>

---

From: <[email-masked]>
Date: Wed, 19 Nov 2008 15:57:58 -0000

Georgios,
 
i think you're saying that you're happy for the marking behaviour draft to go ahead as it is ie without any 1/N option in the marking behaviour - thank!
 
yes, the 1/N boundary behaviour can be worked out further by those interested (there seems good evidence it works, but of course more evidence is always good). as to your proposal that if the evidence isnt good enough, then do an experimental specification for marking behaviour - i guess this would have to be considered as part of any re-chartering.
 
best wishes
phil

________________________________

From: Georgios Karagiannis [mailto:[email-masked]]
Sent: Wed 19/11/2008 10:27
To: Eardley,PL,Philip,CXR9 R; [email-masked]
Subject: RE: [PCN] new version LC-PCN draft + conclusions

Hi Phil

Best regards,
Georgios