Subject: Re: [PCN] Editorial note on baseline encoding document

From: <[email-masked]>
Date: Wed, 1 Jul 2009 09:12:05 +0100

Well spotted Tom, Thanks. 

Current sentence reads:
"If an operator it is essential that any operator wishing to allow ECN to exist end-to-end ensures there are no tunnel end-points within the PCN-domain."

Should read:
"If an operator wishes to allow ECN to exist end-to-end they must ensure there are no tunnel end-points within the PCN-domain."

Toby

____________________________________________________________________ 
Toby Moncaster, <[email-masked]> Networks Research Centre, BT 
B54/70 Adastral Park, Ipswich, IP53RE, UK.  +44 7918 901170 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Tom Taylor
> Sent: 01 July 2009 01:33
> To: pcn
> Subject: [PCN] Editorial note on baseline encoding document
> 
> This is a quick editorial note which has been causing me some
> uncertainty. The
> last sentence of section 6 of draft-ietf-pcn-baseline-encoding-04
> is a bit garbled. I'm assuming the sentence was begun then rebegun.
> 
> Tom
> _______________________________________________
> PCN mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcn

---

From: <[email-masked]>
Date: Thu, 2 Jul 2009 17:06:52 +0100

One final quick question about imperatives in this document...

Currently I have the condition: "The 00 codepoint in the ECN field SHALL indicate not-PCN and MUST NOT be changed to any other codepoint within a PCN-domain. Therefore an ingress node wishing to disable PCN marking for a packet within a PCN-compatible Diffserv Codepoint MUST set the ECN field to 00."

Gorry was a little uneasy about mixing SHALLs and MUSTs (both have same level of imperative). My argument was this was sounded clearer than the alternative:

"The 00 codepoint in the ECN field MUST indicate not-PCN and MUST NOT be changed to any other 
codepoint within a PCN-domain. Therefore an ingress node wishing to disable PCN marking for a 
packet within a PCN-compatible Diffserv Codepoint MUST set the ECN field to 00."

However I am now not so sure if this is true... Any thoughts?

Toby

____________________________________________________________________ 
Toby Moncaster, <[email-masked]> Networks Research Centre, BT 
B54/70 Adastral Park, Ipswich, IP53RE, UK.  +44 1206 332805 

> [email-masked]
> Sent: 01 July 2009 09:12
> To: [email-masked]; [email-masked]
> Subject: Re: [PCN] Editorial note on baseline encoding document
> 
> "If an operator it is essential that any operator wishing to allow ECN
> to exist end-to-end ensures there are no tunnel end-points within the
> PCN-domain."
> 
> Should read:
> "If an operator wishes to allow ECN to exist end-to-end they must
> ensure there are no tunnel end-points within the PCN-domain."
> 
> Toby
>

---

From: <[email-masked]>
Date: Thu, 2 Jul 2009 17:11:30 +0100

I'd prefer to stick with the MUSTS (then i don't have to re-boot brain about what a SHALL means). It's standards speak, not prose!

{ -----Original Message-----
{ From: [email-masked] [mailto:[email-masked]] On Behalf Of
{ [email-masked]
{ Sent: 02 July 2009 17:07
{ To: Moncaster,T,Toby,DER3 R; [email-masked]; [email-masked]
{ Subject: Re: [PCN] Editorial note on baseline encoding document
{ 
{ One final quick question about imperatives in this document...
{ 
{ Currently I have the condition: "The 00 codepoint in the ECN field SHALL
{ indicate not-PCN and MUST NOT be changed to any other codepoint within a
{ PCN-domain. Therefore an ingress node wishing to disable PCN marking for a
{ packet within a PCN-compatible Diffserv Codepoint MUST set the ECN field
{ to 00."
{ 
{ Gorry was a little uneasy about mixing SHALLs and MUSTs (both have same
{ level of imperative). My argument was this was sounded clearer than the
{ alternative:
{ 
{ "The 00 codepoint in the ECN field MUST indicate not-PCN and MUST NOT be
{ changed to any other
{ codepoint within a PCN-domain. Therefore an ingress node wishing to
{ disable PCN marking for a
{ packet within a PCN-compatible Diffserv Codepoint MUST set the ECN field
{ to 00."
{ 
{ However I am now not so sure if this is true... Any thoughts?
{ 
{ Toby
{ 
{ 
{ ____________________________________________________________________
{ Toby Moncaster, <[email-masked]> Networks Research Centre, BT
{ B54/70 Adastral Park, Ipswich, IP53RE, UK.  +44 1206 332805
{ 
{ 
{ 
{ > -----Original Message-----
{ > From: [email-masked] [mailto:[email-masked]] On Behalf Of
{ > [email-masked]
{ > Sent: 01 July 2009 09:12
{ > To: [email-masked]; [email-masked]
{ > Subject: Re: [PCN] Editorial note on baseline encoding document
{ >
{ > Well spotted Tom, Thanks.
{ >
{ > Current sentence reads:
{ > "If an operator it is essential that any operator wishing to allow ECN
{ > to exist end-to-end ensures there are no tunnel end-points within the
{ > PCN-domain."
{ >
{ > Should read:
{ > "If an operator wishes to allow ECN to exist end-to-end they must
{ > ensure there are no tunnel end-points within the PCN-domain."
{ >
{ > Toby
{ >
{ > ____________________________________________________________________
{ > Toby Moncaster, <[email-masked]> Networks Research Centre, BT
{ > B54/70 Adastral Park, Ipswich, IP53RE, UK.  +44 7918 901170
{ >
{ >
{ >
{ > > -----Original Message-----
{ > > From: [email-masked] [mailto:[email-masked]] On Behalf Of
{ > > Tom Taylor
{ > > Sent: 01 July 2009 01:33
{ > > To: pcn
{ > > Subject: [PCN] Editorial note on baseline encoding document
{ > >
{ > > This is a quick editorial note which has been causing me some
{ > > uncertainty. The
{ > > last sentence of section 6 of draft-ietf-pcn-baseline-encoding-04
{ > > is a bit garbled. I'm assuming the sentence was begun then rebegun.
{ > >
{ > > Tom
{ > > _______________________________________________
{ > > PCN mailing list
{ > > [email-masked]
{ > > https://www.ietf.org/mailman/listinfo/pcn
{ > _______________________________________________
{ > PCN mailing list
{ > [email-masked]
{ > https://www.ietf.org/mailman/listinfo/pcn
{ _______________________________________________
{ PCN mailing list
{ [email-masked]
{ https://www.ietf.org/mailman/listinfo/pcn

---

From: Tom Taylor <[email-masked]>
Date: Thu, 02 Jul 2009 15:35:59 -0400

I'm a little uneasy about: "The 00 codepoint in the ECN field MUST indicate 
not-PCN." Perhaps the first sentence should say: ""Interior nodes in the PCN 
domain MUST interpret the 00 codepoint in the ECN field as 'not-PCN' and MUST 
NOT change it to another value."

[email-masked] wrote:
> Currently I have the condition: "The 00 codepoint in the ECN field SHALL
> indicate not-PCN and MUST NOT be changed to any other codepoint within a
> PCN-domain. Therefore an ingress node wishing to disable PCN marking for a
> Gorry was a little uneasy about mixing SHALLs and MUSTs (both have same level
> of imperative). My argument was this was sounded clearer than the
> alternative:
> 
> "The 00 codepoint in the ECN field MUST indicate not-PCN and MUST NOT be
> changed to any other codepoint within a PCN-domain. Therefore an ingress node
> wishing to disable PCN marking for a packet within a PCN-compatible Diffserv
> Codepoint MUST set the ECN field to 00."
> 
> ____________________________________________________________________ Toby
> Moncaster, <[email-masked]> Networks Research Centre, BT B54/70
> Adastral Park, Ipswich, IP53RE, UK.  +44 1206 332805
> 
> 
> 
>> -----Original Message----- From: [email-masked]
>> [mailto:[email-masked]] On Behalf Of [email-masked] Sent: 01
>> July 2009 09:12 To: [email-masked]; [email-masked] Subject: Re: [PCN]
>> Editorial note on baseline encoding document
>> 
>> Current sentence reads: "If an operator it is essential that any operator
>> wishing to allow ECN to exist end-to-end ensures there are no tunnel
>> end-points within the PCN-domain."
>> 
>> Should read: "If an operator wishes to allow ECN to exist end-to-end they
>> must ensure there are no tunnel end-points within the PCN-domain."
>> 
>> Toby
>> 
>> ____________________________________________________________________ Toby
>> Moncaster, <[email-masked]> Networks Research Centre, BT B54/70
>> Adastral Park, Ipswich, IP53RE, UK.  +44 7918 901170
>> 
>> 
>> 
>>> -----Original Message----- From: [email-masked]
>>> [mailto:[email-masked]] On Behalf Of Tom Taylor Sent: 01 July 2009
>>> 01:33 To: pcn Subject: [PCN] Editorial note on baseline encoding document
>>> 
>>> 
>>> uncertainty. The last sentence of section 6 of
>>> draft-ietf-pcn-baseline-encoding-04 is a bit garbled. I'm assuming the
>>> sentence was begun then rebegun.
>>> 
>>> Tom _______________________________________________ PCN mailing list 
>>> [email-masked] https://www.ietf.org/mailman/listinfo/pcn
>> _______________________________________________ PCN mailing list 
>> [email-masked] https://www.ietf.org/mailman/listinfo/pcn
>

---

From: <[email-masked]>
Date: Fri, 3 Jul 2009 09:09:59 +0100

I think I am more or less OK with your suggestion with one additional
word:

"All Interior-nodes within a PCN-domain MUST interpret the 00 codepoint
in the ECN field as 'not-PCN' and MUST NOT change it to another value."

> From: Tom Taylor [mailto:[email-masked]]
> Sent: 02 July 2009 20:36
> To: Moncaster,T,Toby,DER3 R
> Cc: [email-masked]
> > packet within a PCN-compatible Diffserv Codepoint MUST set the ECN
> field to
> > 00."
> >
> > "The 00 codepoint in the ECN field MUST indicate not-PCN and MUST
NOT
> be
> >> July 2009 09:12 To: [email-masked]; [email-masked] Subject:
Re:
> [PCN]
> >> Should read: "If an operator wishes to allow ECN to exist
end-to-end
> they
> >>> [mailto:[email-masked]] On Behalf Of Tom Taylor Sent: 01
July
> 2009

---

From: Tom Taylor <[email-masked]>
Date: Fri, 03 Jul 2009 08:25:51 -0400

OK

>> NOT change it to another value."
...