Subject: [PCN] Definition of sustainable aggregate rate (SAR)

From: Tom Taylor <[email-masked]>
Date: Thu, 26 Aug 2010 11:01:25 -0400

I'm adding the following definition to the CL and SM boundary node behaviour 
drafts. Comments?

         Sustainable aggregate rate (SAR)

The estimated maximum rate of PCN-traffic that can be admitted to
a given ingress-egress-aggregate at a given moment without causing
degradation of quality of service for the admitted flows. This value
is derived as part of the flow termination procedure, and is used
to determine how much PCN-traffic must be terminated to bring the
ingress-egress-aggregate back to its intended operating level.
For further details see <xref target="decisTerm"/>.</t>

Tom Taylor

---

From: Michael Menth <[email-masked]>
Date: Thu, 26 Aug 2010 18:18:47 +0200

Hi Tom,

what's possibly missing in this definition is the idea that the SAR is 
the proportional share of the current rate of all IEAs carried over a 
bottleneck link that does not cause pre-congestion.

Regards,

     Michael

Am 26.08.2010 17:01, schrieb Tom Taylor:
> I'm adding the following definition to the CL and SM boundary node 
> behaviour drafts. Comments?
>
> _______________________________________________
> PCN mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcn

-- 
PD Dr. habil. Michael Menth, Assistant Professor
University of Wuerzburg, Institute of Computer Science
Am Hubland, D-97074 Wuerzburg, Germany, room B206
phone: (+49)-931/31-86644 (new), fax: (+49)-931/31-86632 (new)
mailto:[email-masked]
http://www3.informatik.uni-wuerzburg.de/research/ngn

---

From: <[email-masked]>
Date: Thu, 26 Aug 2010 17:52:59 +0100

I guess it should relate somehow to PCN-supportable-rate.

You could tweak your definition as the SAR becomes meaningful (only) when some traffic needs to be terminated - if there's only a little traffic, then there's no estimated maximum rate.

>From RFC5559:
o  PCN-supportable-rate: the rate of PCN-traffic on a link down to
      which PCN flow termination should, if necessary, terminate already
      admitted PCN-flows.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Michael Menth
> Sent: 26 August 2010 17:19
> To: Tom Taylor
> Cc: pcn
> Subject: Re: [PCN] Definition of sustainable aggregate rate (SAR)
>
>
>
>   Hi Tom,
>
> > The estimated maximum rate of PCN-traffic that can be admitted to a
> > given ingress-egress-aggregate at a given moment without causing
> > is derived as part of the flow termination procedure, and
> is used to
> > determine how much PCN-traffic must be terminated to bring the
> > ingress-egress-aggregate back to its intended operating level. For
> > further details see <xref target="decisTerm"/>.</t>
> >
> > Tom Taylor
> phone: (+49)-931/31-86644 (new), fax: (+49)-931/31-86632
> (new) mailto:[email-masked]

---

From: Tom Taylor <[email-masked]>
Date: Thu, 26 Aug 2010 12:59:47 -0400

Too bad that's defined for a link rather than a path. I suppose I could define 
it as the minimum over all links carrying the aggregate.

On 26/08/2010 12:52 PM, [email-masked] wrote:
>>> further details see<xref target="decisTerm"/>.</t>
>>>
>>> Tom Taylor

---

From: Michael Menth <[email-masked]>
Date: Thu, 26 Aug 2010 20:22:03 +0200

Hi Tom,

try this one:

Sustainable-aggregate-rate: estimated rate of an 
ingress-egress-aggregate such that the PCN-rate on any link does no 
longer exceed its PCN-supportable rate when all 
ingress-egress-aggregates reduce their PCN-rates to their 
sustainable-aggregate-rates.

It has a relation to PCN-supportable-rates (Phil's concern) and makes 
clear that termination on multiple ingress-egress-aggregates is needed.

Regards,

     Michael

Am 26.08.2010 18:59, schrieb Tom Taylor:
> Too bad that's defined for a link rather than a path. I suppose I 
> could define it as the minimum over all links carrying the aggregate.
>
>> You could tweak your definition as the SAR becomes meaningful (only) 
>> when some traffic needs to be terminated - if there's only a little 
>> traffic, then there's no estimated maximum rate.
>>
>>> From RFC5559:

---

From: "Toby Moncaster" <[email-masked]>
Date: Thu, 26 Aug 2010 21:09:07 +0100

The trouble about Michael's version is it is a bit circular...

I don't know if it is any better, but how about:

"Sustainable-aggregate-rate: the estimated rate for a particular
ingress-egress-aggregate that ensures that the PCN-rate on any constituent
link does not exceed the PCN-supportable rate for that link. Note that any
other ingress-egress-aggregates sharing that same link will also be reducing
their rates towards their Sustainable-aggregate-rate."

This is a little stilted, but I think it is saying what we actually mean.

Toby

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Michael Menth
> Sent: 26 August 2010 19:22
> To: Tom Taylor
> Cc: [email-masked]
> a