Subject: [pcp] PCP and nested NAPT

From: "Dan Wing" <[email-masked]>
Date: Fri, 7 Jan 2011 09:42:51 -0800

I have prepared a slide deck which suggests two goals for PCP:

  1. Work over one existing NAPT in people's homes
  2. Detect multiple existing NAPTs

and a mechanism to achieve the goal:

  * PCP client speaks UPnP IGDto existing in-home NAPT
  * PCP client speaks PCP to PCP server

(which is similar to what Simon recently discussed in
http://www.ietf.org/mail-archive/web/pcp/current/msg00634.html).

To achieve this, I believe we need three things:

  1. IANA-registered PCP server address
  2. UPnP IGD running on existing NAPT
     - Rumor says ~25% of NAPTsrun UPnP IGD
  3. New PCP Option to indicate source address
     - To detect the 3 NAPT situation

Slides are at:
  ftp://ftp-eng.cisco.com/dwing/pcp/pcp-nested-nat.pdf

Comments welcome.

-d

---

From: Francis Dupont <[email-masked]>
Date: Sat, 08 Jan 2011 02:11:00 +0100

In your previous mail you wrote:

=> I can't see why.

=> in general you need a pcp (lower case) for each NAT on
the path, both to run PCP through them and to build
port forwarding entries from the Internet to hosts.

=> this is NAT detection and IMHO it should be done
by the PCP server with source address and port.
Wild ALG detection too should be fine.

Regards

[email-masked]

---

From: <[email-masked]>
Date: Mon, 10 Jan 2011 08:59:37 +0100

Hi Dan,

We have discussed this point in the past several times; see for instance: http://www.ietf.org/mail-archive/web/pcp/current/msg00168.html. 

I don't want to repeat my self but it would be efficient if you include the points raised in that thread.

Cheers,
Med 

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Dan Wing
Envoyé : vendredi 7 janvier 2011 18:43
À : [email-masked]
Objet : [pcp] PCP and nested NAPT

Slides are at:

Comments welcome.

-d

_______________________________________________
pcp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcp

*********************************
This message and any attachments (the "message") are confidential and intended solely for the addressees. 
Any unauthorised use or dissemination is prohibited.
Messages are susceptible to alteration. 
France Telecom Group shall not be liable for the message if altered, changed or falsified.
If you are not the intended addressee of this message, please cancel it immediately and inform the sender.
********************************

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 11 Jan 2011 09:32:05 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, January 07, 2011 5:11 PM
> To: Dan Wing
> Cc: [email-masked]
> Subject: Re: [pcp] PCP and nested NAPT
> 
> 

You appear to be disagreeing with the two goals I described
in my initial post, which are:

Of course, as we can all agree, existing NAPTs do not implement PCP.  My
goal is to work with those NAPT devices where we can, and detect them and
allow PCP to fail gracefully where we cannot.

Because of that disagreement, it is natural there is disagreement with the
technical solution that I proposed in
ftp://ftp-eng.cisco.com/dwing/pcp/pcp-nested-nat.pdf.

-d