Subject: [pcp] request for a "PEER opcode as extension" tracker ticket

From: Francis Dupont <[email-masked]>
Date: Mon, 28 Mar 2011 21:20:17 +0200

(related to #17 ticket and WG charter)

I read the charter twice and I still can't find where the function
provided by the PEER opcode (according the #17 ticket "using PCP to
reduce application-level keepalive traffic") is a part of the PCP
description in the charter.
So I'd like to open a new tracker ticket about the idea to move
the PEER section 9 from the base spec document to an extension one.

Regards

[email-masked]

PS: I don't know the official procedure to open ticket, perhaps it is
enough to have a IETF tool login?
PPS: of course I'd like to discuss about this, including the place where
it is in the charter (even I never found it :-) and at the Friday session
(if nobody can show it before).

---

From: Dave Thaler <[email-masked]>
Date: Thu, 31 Mar 2011 20:37:07 +0000

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Francis Dupont
> Sent: Monday, March 28, 2011 9:20 PM
> To: [email-masked]
> Subject: [pcp] request for a "PEER opcode as extension" tracker ticket
> 
> I read the charter twice and I still can't find where the function provided by
> the PEER opcode (according the #17 ticket "using PCP to reduce application-
> level keepalive traffic") is a part of the PCP description in the charter.

I believe it falls out of the requirement to support existing APIs so that
apps don't have to change:

 This eases the deployment of PCP in situations where
 applications have already changed to support the APIs necessary for
 communicating with UPnP-IGD or NAT-PMP. Those applications only work
 today when the home gateway gets a public address, but may no longer
 work in situations where the gateway is behind another NAT. Home
 gateways could use PCP to translate and relay those UPnP and NAP-PMP
 messages to the PCP server, thus allowing such applications to continue
 working as they do today.

> So I'd like to open a new tracker ticket about the idea to move the PEER
> section 9 from the base spec document to an extension one.

In a parallel thread you asked the more general question:
>> BTW I can ask the same question about the PEER stuff: 
>> the fact it is in the base document does mean it is mandatory to support?
>> If this is the case be prepared to receive objections...

Hence I am opening the ticket with all of the above info, but will
title it as about whether PEER support is mandatory.

> PS: I don't know the official procedure to open ticket, perhaps it is enough to
> have a IETF tool login?
> PPS: of course I'd like to discuss about this, including the place where it is in
> the charter (even I never found it :-) and at the Friday session (if nobody can
> show it before).

The procedure we're following is to send email to the chairs, which this
email counts as.  Thanks for following the procedure :)

-Dave