Subject: [pcp] Epoch in error responses

From: Simon Perreault <[email-masked]>
Date: Thu, 24 Mar 2011 10:10:45 -0400

Section "6.2. General PCP Server: Processing a Request" says:

   Error responses have the same packet layout as success responses,
   with fields copied from the request copied into the response, and
   other fields assigned by the PCP server MUST be cleared to 0.

Section "6.5. Epoch" says:

   Every PCP response sent by the PCP server includes an Epoch field.

This looks like a contradiction to me.

Do error responses have the Epoch field set to 0 or not?

Thanks,
Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca

---

From: Francis Dupont <[email-masked]>
Date: Thu, 24 Mar 2011 17:58:57 +0100

In your previous mail you wrote:

   

   
   
=> I signaled this to Dan but it seems it is one of
the missing fixes of 07. Of course 6.5 preempts 6.2.

Regards

[email-masked]

---

From: "Dan Wing" <[email-masked]>
Date: Thu, 24 Mar 2011 17:59:22 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Simon Perreault
> Sent: Thursday, March 24, 2011 7:11 AM
> To: [email-masked]
> Subject: [pcp] Epoch in error responses
> 

See top of 
http://tools.ietf.org/html/draft-ietf-pcp-base-07#page-13

where else can it be made clearer?

-d

> _______________________________________________
> pcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcp

---

From: Simon Perreault <[email-masked]>
Date: Fri, 25 Mar 2011 10:31:13 -0400

> http://tools.ietf.org/html/draft-ietf-pcp-base-07#page-13

Thanks, that is very clear indeed.

> where else can it be made clearer?

I think the confusing part is in section 6.2. General PCP Server: 
Processing a Request:

As far as I can tell, there are no such "other fields assigned by the 
PCP server" that need to be cleared to 0. If I'm wrong, then I suggest 
to explicitly list them. Otherwise, the passage can be removed.

Thanks,
Simon

---

From: "Dan Wing" <[email-masked]>
Date: Fri, 25 Mar 2011 08:52:10 -0700

> From: Simon Perreault [mailto:[email-masked]]
> Sent: Friday, March 25, 2011 7:31 AM
> To: Dan Wing
> Cc: [email-masked]
> Subject: Re: [pcp] Epoch in error responses
> 

There had been questions about how errors are formed previously, so
I went with:

        <t>Error responses have the same packet layout as success responses,
        with fields copied from the request copied into the response, and
        fields assigned by the PCP server are set as indicated in <xref
        target="common_response"></xref></t>

where "common_response" is the figure that shows the packet layout and
defines the fields for the PCP common response (which contains the Epoch).

-d