Subject: [pcp] Will PCP do it?

From: Tina TSOU <[email-masked]>
Date: Tue, 08 Mar 2011 07:35:50 -0800

Hi,
NAT has the private IP address, transport protocol and port # on the  
"internal" side and the public IP address, transport protocol and port  
# on the "external" side.  I'm looking for to allow an entity (e.g.,  
not the PCP client who uses PCP to request a port number assignment on  
the "external" side) to know the private IP address on the "internal"  
side for the given public IP address, transport protocol and port # on  
the "external" side.
Will PCP do it?

B. R.
Tina
http://tinatsou.weebly.com

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 9 Mar 2011 11:34:51 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Tina TSOU
> Sent: Tuesday, March 08, 2011 7:36 AM
> To: [email-masked]
> Subject: [pcp] Will PCP do it?
> 
> Hi,

No.

What is the use case?

-d

> _______________________________________________
> pcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcp

---

From: Tina Tsou <[email-masked]>
Date: Wed, 09 Mar 2011 11:52:18 -0800

My understanding about PCP is that it allows the PCP client to instruct the
PCP server to allocate a port number with a transport protocol (pinhole) so
that the PCP client can send the NAT's public IP address, transport protocol
and port number to the application server outside the NAT to allow that
application server to send information to the device with the PCP client.  A
PCP client already has the public IP address, transport port protocol and
port number  What I described does not involve the device behind the NAT but
another entity that is interested in knowing which private IP address is
assigned with a specific port number for a transport protocol and NAT's
public IP address.  Is it in your opinion that PCP can be enhanced to
support this type of inquiry? Just ask. If not, I will go for another
candidate protocol.

In the mobile operator network, two interfaces are needed if mobile GW and
NAT are separate:
1. with NAT: request contains the NAT's public IP address, transport
protocol and port number; response contains the private IP address and the
port number.
2. with mobile GW: request contains the private IP address and response
contains the mobile identities (e.g. IMSI, MSISDN, etc.)

If the mobile GW is integrated with the NAT, one interface is needed.  The
request contains the mobile GW's/NAT's public IP address, transport protocol
and port number, and the response contains the mobile identities.

We keep our promises with one another - no matter what!

Best Regards,
Tina TSOU
http://tinatsou.weebly.com/contact.html

-----Original Message-----
From: Dan Wing [mailto:[email-masked]] 
Sent: Wednesday, March 09, 2011 11:35 AM
To: 'Tina TSOU'; [email-masked]
Subject: RE: [pcp] Will PCP do it?

No.

What is the use case?

-d

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 9 Mar 2011 12:05:54 -0800

> From: Tina Tsou [mailto:[email-masked]]
> Sent: Wednesday, March 09, 2011 11:52 AM
> To: 'Dan Wing'; [email-masked]
> application server to send information to the device with the PCP
> client. 

Yes, that covers two of the use-cases described in draft-ietf-pcp-base,
" Operating a Server" (Section 7.1) and "Operating a Symmetric
Client/Server" (Section 7.3).

> A PCP client already has the public IP address, transport port protocol
> and
> support this type of inquiry? Just ask. 

It could be.  I'm asked "what is the use case" to understand why
you're wanting this functionality.

> If not, I will go for another
> candidate protocol.
>

Sorry, I still don't understand the use case.

Is the use case to allow an external entity to perform user identification,
akin to draft-chen-intarea-v4-uid-header-option or
draft-zhang-v6ops-cgn-source-trace or draft-wing-nat-reveal-option ??

-d

---

From: Tina Tsou <[email-masked]>
Date: Wed, 09 Mar 2011 13:21:47 -0800

It is not related to source-trace.

Best Regards,
Tina TSOU

-----Original Message-----
From: Dan Wing [mailto:[email-masked]] 
Sent: Wednesday, March 09, 2011 12:06 PM
To: 'Tina Tsou'; [email-masked]
Subject: RE: [pcp] Will PCP do it?

-d

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 9 Mar 2011 15:37:46 -0800

> Sent: Wednesday, March 09, 2011 1:22 PM

I am out of guesses.

What is the use case?

-d

> > My understanding about PCP is that it allows the PCP client to
> instruct
> > the
> > In the mobile operator network, two interfaces are needed if mobile
> GW
> > and
> > NAT are separate:
> > protocol and port number; response contains the private IP address
> and
> > the
> > port number.

---

From: Tina Tsou <[email-masked]>
Date: Thu, 10 Mar 2011 12:26:45 -0800

The use case is to allow mobile location to be provided to web portals.

Best Regards,
Tina TSOU

-----Original Message-----
From: Dan Wing [mailto:[email-masked]] 
Sent: Wednesday, March 09, 2011 3:38 PM
To: 'Tina Tsou'; [email-masked]
Subject: RE: [pcp] Will PCP do it?

I am out of guesses.

What is the use case?

-d

---

From: "Dan Wing" <[email-masked]>
Date: Thu, 10 Mar 2011 13:45:27 -0800

> Sent: Thursday, March 10, 2011 12:27 PM

Ok.  And the mobile has a connection (TCP?) that same web portal?  If
so, it sounds like exactly the sort of thing that 
draft-chen-intarea-v4-uid-header-option, draft-zhang-v6ops-cgn-source-trace,
or draft-wing-nat-reveal-option could help with.

Or is this for something like AT&T's existing FamilyMap service,
https://familymap.wireless.att.com/finder-att-family/helpContent.htm?topic=1
,
where the phone does not have a connection to the web portal.  In which
case, there would not be a PCP mapping.

-d

> > > port number  What I described does not involve the device behind
> the
> > > NAT but
> > > another entity that is interested in knowing which private IP
> address
> > > is
> > > If the mobile GW is integrated with the NAT, one interface is
> needed.
> > > The
> > > > From: [email-masked] [mailto:[email-masked]] On
> Behalf
> > Of
> > > > Tina TSOU
> > > > not the PCP client who uses PCP to request a port number
> assignment
> > > on
> > > > side for the given public IP address, transport protocol and port
> #
> > > on
> > > > the "external" side.
> > > > Will PCP do it?
> > >
> > > No.
> > >
> > > What is the use case?
> > >
> > > -d
> > >
> > >
> > > >
> > > > B. R.
> > > > Tina

---

From: Tina Tsou <[email-masked]>
Date: Tue, 29 Mar 2011 12:01:30 +0200

Hi Dan,
Sorry for the late response.  The use cases about real-time query to the NAT
and non-real-time query to the log server have the same need - mapping the
external IP address, transport protocol and port # to the internal/private
IP address and port #.

Best Regards,
Tina TSOU

-----Original Message-----
From: Dan Wing [mailto:[email-masked]] 
Sent: Thursday, March 10, 2011 10:45 PM
To: 'Tina Tsou'; [email-masked]
Subject: RE: [pcp] Will PCP do it?

-d

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 29 Mar 2011 13:52:04 +0200

Nope, PCP doesn't tell an external server the internal IP address + port,
because PCP is only listening on the internal-facing interface (not on the
Internet-facing external interface) and the existing OpCodes can't express
the internal IP address or port.  The GET OpCode is close to what you're
looking for, draft-boucadair-pcp-failure.  However, the security model for
your scenario would be different, too -- it is important to prevent server
"A" from discoverying how many subscribers had a connection to server B;
consider for example the case where two competing content providers queried
a NAT to determine market share of their competitor.

-d

> Sent: Tuesday, March 29, 2011 12:02 PM
> > > > that the PCP client can send the NAT's public IP address,
> transport
> > > > protocol
> > > > and port number to the application server outside the NAT to
> allow
> > > that
> > > > public IP address.  Is it in your opinion that PCP can be
> enhanced
> > to
> > > > request contains the mobile GW's/NAT's public IP address,
> transport
> > > > protocol
> > > > > NAT has the private IP address, transport protocol and port #
> on
> > > the
> > > > > "internal" side and the public IP address, transport protocol
> and
> > > > port

---

From: Francis Dupont <[email-masked]>
Date: Tue, 29 Mar 2011 14:51:57 +0200

In your previous mail you wrote:

=> I agree about the security consequences. BTW the GET/NEXT security
is pretty simple: one is allowed to GET a mapping if and only if it
is allowed to delete it.

Regards

[email-masked]

PS: IMHO the operations Tina asks for are out of the scope of PCP.