Subject: [pcp] Internal address conflicts

From: Simon Perreault <[email-masked]>
Date: Wed, 23 Mar 2011 10:12:27 -0400

Hi,

Suppose a server receives two MAP requests with the same internal
address but different external addresses. The first one succeeds. What
should it do for the second one? How should it respond?

Thanks,
Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 23 Mar 2011 10:37:23 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Simon Perreault
> Sent: Wednesday, March 23, 2011 7:12 AM
> To: [email-masked]
> Subject: [pcp] Internal address conflicts
> 
> Hi,
> 
> address but different external addresses. 

The 'suggested external IP address'?

> The first one succeeds. What

It's a suggestion, which it can't fulfill.  Just like the 'suggested port'
wanting port 80 is unlikely to be fulfilled.

So, it responds positively with the external IP address of the (existing)
mapping, and refreshes (extends) that mapping as appropriate.

-d

> _______________________________________________
> pcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcp

---

From: Simon Perreault <[email-masked]>
Date: Wed, 23 Mar 2011 13:39:53 -0400

> mapping, and refreshes (extends) that mapping as appropriate.

Makes sense. Thanks.

Simon