Subject: [pcp] #43: remove UNABLE_TO_DELETE_ALL error?

From: "pcp issue tracker" <[email-masked]>
Date: Thu, 10 Mar 2011 02:05:58 -0000

#43: remove UNABLE_TO_DELETE_ALL error?

 http://www.ietf.org/mail-archive/web/pcp/current/msg00959.html

 >    On a deletion request, the requested external
 >    port field is ignored by the server.  So, if the PCP client attempts
 > to
 >    delete a static mapping (i.e., a mapping created outside of PCP
 >    itself), the PCP server deletes all of the PCP-created mappings but
 >    MUST respond with UNABLE_TO_DELETE_ALL result code, with the other
 >    fields encoded as described above.
 >
 > This reads weirdly (apparent subject/object quantity disagreement in
 > the second sentence).  Plus, if the PCP client tries to delete ALL
 > mappings, the server should delete the PCP-created mappings and return
 > success; OTOH if the PCP client tries to delete a single mapping
 > created by other means, the server should fail with some other code
 > than UNABLE_TO_DELETE_ALL, like NOT_AUTHORIZED.  In fact, I'm
 > not sure there's a real use case for UNABLE_TO_DELETE_ALL.

-- 
------------------------------+---------------------------------------------
 Reporter:  pselkirk@…        |       Owner:     
     Type:  defect            |      Status:  new
 Priority:  minor             |   Milestone:     
Component:  base              |     Version:     
 Severity:  -                 |    Keywords:     
------------------------------+---------------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/pcp/trac/ticket/43>
pcp <http://tools.ietf.org/pcp/>

---

From: "pcp issue tracker" <[email-masked]>
Date: Thu, 10 Mar 2011 07:48:45 -0000

Comment(by dwing@…):

 I have looked this over more, and see no reason to keep this
 error.  The PCP client can't do anything other than perhaps
 a popup with "gosh, there are other mappings, made by
 something else".

 I'm going to remove this error code, and associated text.

 Speak up if you feel otherwise.

Ticket URL: <http://trac.tools.ietf.org/wg/pcp/trac/ticket/43#comment:1>
pcp <http://tools.ietf.org/pcp/>

---

From: "pcp issue tracker" <[email-masked]>
Date: Wed, 23 Mar 2011 18:21:14 -0000

Changes (by dwing@…):

  * status:  new => closed
  * resolution:  => fixed

Comment:

 the error code was removed in draft-ietf-pcp-base-07.

-- 
------------------------------+---------------------------------------------
 Reporter:  pselkirk@…        |        Owner:        
     Type:  defect            |       Status:  closed
 Priority:  minor             |    Milestone:        
Component:  base              |      Version:        
 Severity:  -                 |   Resolution:  fixed 
 Keywords:                    |  
------------------------------+---------------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/pcp/trac/ticket/43#comment:2>
pcp <http://tools.ietf.org/pcp/>