Subject: [pcp] Performance issues for GET/GET NEXT in draft-boucadair-pcp-failure-01

From: Tina Tsou <[email-masked]>
Date: Fri, 20 May 2011 17:41:19 -0700

Hi Med et al,
There may be some performance issues for GET/GET NEXT in
draft-boucadair-pcp-failure-01.
The client can get NAT entries from server based on some of all of the
parameters of internal IP/external IP/internal port/external port/protocol.
This kind of parameter combination may cause going through the whole NAT
entries at server side, to match one by one. If there are tens of millions
entries in CGN, that will bring a lot of computing effort.

We keep our promises with one another - no matter what!

Best Regards,
Tina TSOU
http://tinatsou.weebly.com/contact.html

---

From: <[email-masked]>
Date: Tue, 24 May 2011 07:55:28 +0200

Hi Tina,

GET/NEXT procedure aims to retrieve the PCP-instructed mappings from a PCP Server and not all the NAT entries. The amount of explicit mappings is likely to be less than implicit ones. 

We have tested a previous version of the GET procedure with a vendor and no performance issues have been reported. Note, the "tens of millions" entries case has not been tested in our side because this is not our targeted configuration. 

Cheers,
Med 

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Tina Tsou
Envoyé : samedi 21 mai 2011 02:41
À : [email-masked]
Objet : [pcp] Performance issues for GET/GET NEXT in draft-boucadair-pcp-failure-01

Hi Med et al,

Best Regards,
Tina TSOU

_______________________________________________
pcp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcp