Subject: [pcp] about the PCP recovery I-D

From: Francis Dupont <[email-masked]>
Date: Mon, 08 Aug 2011 15:17:01 +0200

I have two proposals about the draft-cheshire-pcp-recovery I-D:
 - first use a site local (in place of link-local) multicast address
  so it will work in the whole site even it is a graph with a deep > 1.

 - second to add the external address, the idea is to warn quicky
  about external address change. As usual the external address should
  not be undefined only when there is (only) one available.

Regards

[email-masked]

---

From: Reinaldo Penno <[email-masked]>
Date: Tue, 9 Aug 2011 12:32:02 -0400

>   not be undefined only when there is (only) one available.

The external address as in the NAT pool addresses?

> _______________________________________________
> pcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcp

---

From: Francis Dupont <[email-masked]>
Date: Tue, 09 Aug 2011 23:08:40 +0200

=> yes, the best should be to use the same wording than in the
(next version of) base draft.

Regards

---

From: Reinaldo Penno <[email-masked]>
Date: Tue, 9 Aug 2011 22:51:45 -0400

In a large CGN there can be quite a lot of NAT pool prefixes/ranges. Do we
wording about having to fit in a single UDP packet?

---

From: Francis Dupont <[email-masked]>
Date: Wed, 10 Aug 2011 09:26:55 +0200

=> the receovery packet is local so this should not happen and
BTW my proposal has the *one* in it so the needed room is for
128 bits, no more.
   
Regards

---

From: Reinaldo Penno <[email-masked]>
Date: Wed, 10 Aug 2011 07:16:23 -0400

> BTW my proposal has the *one* in it so the needed room is for

But different hosts in the same site can be bound to different public IPs.
Do we now have to send different messages?

---

From: Francis Dupont <[email-masked]>
Date: Wed, 10 Aug 2011 13:25:53 +0200

=> no, in this case there is not *one* external address so
it should be set to undefined/zero (*).

Thanks

PS (*): exactly as if a delete all (empty third party option) request
was sent. BTW the base spec doesn't say if it is zero (::) or
undefined (:: for IPv6, ::ffff:0.0.0.0 for IPv4). The two are not
really equivalent as the undefined address includes the IP version
(so is less undefined than zero :-).
And this question is for MAP and PEER opcodes too!

---

From: Reinaldo Penno <[email-masked]>
Date: Wed, 10 Aug 2011 10:47:16 -0400

> it should be set to undefined/zero (*).

Isn't it better than to just keep the message as it is today?

---

From: Francis Dupont <[email-masked]>
Date: Wed, 10 Aug 2011 17:10:00 +0200

=> no because in the use of of the recovery message it will
be very likely one external address.

Thanks

---

From: Tina TSOU <[email-masked]>
Date: Fri, 12 Aug 2011 01:58:35 +0000

Francis and Stuart,
Compared to -00, in the new method of draft-cheshire-pcp-recovery-01, it says that if the external IP address pool of CGN changes, it can reply response packet to user, and ask user to update the local PCP entries.
I understand that it needs application's support. For example, one P2P application has already issue the applied public address and port, if it receives the update information, it needs to update local listening port, and issue the info to tracker again. Is it difficult for application to support?

Best Regards,
Tina TSOU
http://tinatsou.weebly.com/contact.html

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Francis Dupont
Sent: Wednesday, August 10, 2011 8:10 AM
To: Reinaldo Penno
Cc: Stuart Cheshire; [email-masked]
Subject: Re: [pcp] about the PCP recovery I-D

   

Thanks