Subject: [pcp] two users request same address and port

From: Tina TSOU <[email-masked]>
Date: Tue, 16 Aug 2011 17:39:43 +0000

Hi guys,
http://portforward.com/cports.htm

If two end users using XBox request same IPv4 public external address on CGN, and same port, what will happen? The CGN still works with these applications listed above in the website link.

Best Regards,
Tina TSOU
http://tinatsou.weebly.com/contact.html

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 16 Aug 2011 11:04:58 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Tina TSOU
> Sent: Tuesday, August 16, 2011 10:40 AM
> To: [email-masked]; [email-masked]
> Subject: [pcp] two users request same address and port
> 
> Hi guys,
> If two end users using XBox request same IPv4 public external address
> on CGN, and same port, what will happen?

If the address and port is available for assignment to that user,
the user will get it.  Otherwise, the user won't.  So in the case
above, the first user will probably get the address and port and
the second user won't.

-d

> The CGN still works with these
> applications listed above in the website link.
> 
> 
> 
> Best Regards,
> Tina TSOU
> _______________________________________________
> pcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcp

---

From: Francis Dupont <[email-masked]>
Date: Tue, 16 Aug 2011 20:13:00 +0200

In your previous mail you wrote:

   If two end users using XBox request same IPv4 public external address on CGN, and
   same port, what will happen?

=> if the question is about two subscribers at most one of the two gets the
external address and port. If it is about two users but one subscriber the
problem should get the same result but is solved locally.
BTW by definition on a CGN nobody can expect to get a particular external port
with a chance >> 0, so perhaps I haven't understood the question?
   
Regards

[email-masked]