Subject: [pcp] #59: DHCP option: name and/or IP address

From: "pcp issue tracker" <[email-masked]>
Date: Mon, 02 Apr 2012 19:59:07 -0000

#59: DHCP option: name and/or IP address

 Should the option contain a name or IP address?

 Consensus was that it can contain a string that can be passed to APIs like
 getaddrinfo.  Which means a name or IP address literal string.

 Recent email exchanges are consistent with that, so entering this one as a
 closed issue.

 > From: [email-masked] [mailto:[email-masked]] On Behalf Of
 Sam
 > Hartman
 > Sent: Monday, April 02, 2012 4:26 AM
 > To: Margaret Wasserman
 > Cc: [email-masked]
 > Subject: Re: [pcp] RE : WG last call on draft-ietf-pcp-dhcp-02

 >>>>> "Margaret" == Margaret Wasserman <[email-masked]> writes:

     Margaret> On Apr 2, 2012, at 6:24 AM, Sam Hartman wrote:
     >> So, I'll note that recently a working group I chaired tried to
     >> represent a server as a name not an IP address.  The DHCP working
     >> group objected strongly enough that we had to revert to IP
     >> address based specification.  I'd expect the same issue to happen
     >> here.

     Margaret> Recent, widely-used DHCP Server options I'm aware of, like
     Margaret> the NTP Server Option, allow you to send either a FQDN or
     Margaret> an IP address in the same option format.  I think that's
     Margaret> still the best choice, as it allows maximum flexibility
     Margaret> for the administrator at little cost in terms of option
     Margaret> complexity/length.

 I agree it's the best choice.
 I wish Kerberos had not gotten pushback to trying to do this and
 definitely think we should move forward with FQDN/IP address if we are
 permitted to do so.
 _______________________________________________
 pcp mailing list
 [email-masked]
 https://www.ietf.org/mailman/listinfo/pcp

-- 
---------------------+-----------------------------------
 Reporter:  various  |      Owner:  draft-ietf-pcp-dhcp@…
     Type:  defect   |     Status:  new
 Priority:  major    |  Milestone:
Component:  dhcp     |    Version:
 Severity:  -        |   Keywords:
---------------------+-----------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/pcp/trac/ticket/59>
pcp <http://tools.ietf.org/pcp/>

---

From: "pcp issue tracker" <[email-masked]>
Date: Mon, 02 Apr 2012 19:59:40 -0000

Changes (by dthaler@…):

 * status:  new => closed
 * resolution:   => fixed

-- 
---------------------+------------------------------------
 Reporter:  various  |       Owner:  draft-ietf-pcp-dhcp@…
     Type:  defect   |      Status:  closed
 Priority:  major    |   Milestone:
Component:  dhcp     |     Version:
 Severity:  -        |  Resolution:  fixed
 Keywords:           |
---------------------+------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/pcp/trac/ticket/59#comment:1>
pcp <http://tools.ietf.org/pcp/>

---

From: Margaret Wasserman <[email-masked]>
Date: Mon, 2 Apr 2012 17:49:07 -0400

I don't understand how this can be a closed issue for two reasons:

(1) The document goes to some length to claim that the option contains a FQDN and not an IP Address.  It then talks about resolving the string using a resolver, not interpreting it as it would be by getaddrinfo().

(2) A string that could be passed to getaddrinfo() is not the way a server that could be identified by an FQDN or an IP Address is usually represented in a DHCP option.

Has this option been reviewed by the DHC WG?   Or has it been sent to the DHC WG for parallel review with WGLC?

Thanks,
Margaret