Subject: Re: [pcp] draft-ietf-pcp-proxy-01

From: <[email-masked]>
Date: Wed, 16 Jan 2013 14:55:48 +0100

Dear Cathy,

Apologies for the delay to answer this message. 

I wonder whether your case isn't covered in this text (Section 9); especially the last sentence:

   Upon receipt of an unsolicited ANNOUNCE response from a PCP Server,
   the PCP Proxy proceeds to renewing the mappings and checks whether
   there are changes compared to a local cache if it is maintained by
   the PCP Proxy.  If no change is detected, no unsolicited ANNOUNCE is
   generated towards PCP Clients.  If a change is detected, the PCP
   Proxy MUST generate unsolicited ANNOUNCE message(s) to appropriate
   PCP Clients.  If the PCP Proxy does not maintain a local cache for
   the mappings, unsolicited ANNOUNCE messages are relayed to PCP
   Clients.

If not, please let me know what change you want to see added to that text. Thanks.

Cheers,
Med 

>-----Message d'origine-----
>De : Zhouqian (Cathy) [mailto:[email-masked]] 
>Envoyé : jeudi 20 décembre 2012 09:28
>À : BOUCADAIR Mohamed OLNC/OLN; [email-masked]
>Objet : RE: draft-ietf-pcp-proxy-01
>
>Dear Med and all,
>When looking over section 10 of this document, there is one 
>more advanced feature in my mind that may be added for PCP proxy. 
>In [I-D.ietf-pcp-base], the PCP server could send the ANNOUNCE 
>response to both multicast and unicast addresses. For 
>multicast address case, it only applies when the network is 
>layer2 network and there is a multicast link between PCP 
>client and PCP server. If there is no multicast link between 
>PCP client and PCP server, one access router (e.g., PCP proxy) 
>may perform the multicast address/unicast address conversion 
>function. When the PCP proxy receives the ANNOUNCE message 
>from the PCP server, it replaces the unicast address of itself 
>with the PCP client's multicast address and sends ANNOUNCE 
>message to the multicast address. It is required that the 
>network between the PCP proxy and the PCP client is layer2. 
>Any comments?
>
>Best Regards,
>Cathy
>
>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On Behalf Of
>> [email-masked]
>> Sent: Friday, August 17, 2012 5:33 PM
>> To: [email-masked]
>> Subject: [pcp] draft-ietf-pcp-proxy-01
>> 
>> Dear all,
>> 
>> A new version is now available online:
>> http://tools.ietf.org/html/draft-ietf-pcp-proxy-01
>> 
>> The main changes in -01 are as follows:
>> 
>> * The reference architecture is updated: the PCP proxy is 
>not restricted to
>> the CP router deployment case.
>> * Add a new section to specify the behaviour when the PCP 
>Proxy is not
>> co-located with a NAT function
>> * Add a new section for mappings repair
>> * More discussion for the multiple PCP Servers scenario
>> * Text is cleanup
>> 
>> A detailed diff is available here:
>> 
>>  http://www.ietf.org/rfcdiff?url2=draft-ietf-pcp-proxy-01
>> 
>> Please review this new version and provide input.
>> 
>> Cheers,
>> Med
>> _______________________________________________
>> pcp mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/pcp
>

---

From: "Zhouqian (Cathy)" <[email-masked]>
Date: Thu, 17 Jan 2013 07:48:15 +0000

Dear Med,
Thanks for your reply.
In my understanding, the unsolicited ANNOUNCE message sent from the PCP server could be unicast or multicast. But if the PCP Proxy does not maintain a local cache for the mappings, the PCP proxy need to send the multicast unsolicited ANNOUNCE message to the PCP client. So my proposed modification to the last sentence is as below:
"If the PCP Proxy does not maintain a local cache for the mappings, unsolicited ANNOUNCE messages are relayed to PCP Clients using the multicast address."

Best Regards,
Cathy

> From: [email-masked]
> [mailto:[email-masked]]
> Sent: Wednesday, January 16, 2013 9:56 PM
> To: Zhouqian (Cathy); [email-masked]
> Subject: RE: draft-ietf-pcp-proxy-01
> 
> Dear Cathy,
>