Subject: [pcp] TR: I-D Action: draft-boucadair-pcp-sip-ipv6-00.txt

From: <[email-masked]>
Date: Wed, 26 Jun 2013 17:04:52 +0200

Dear all,

I submitted this short I-D to explain how PCP can be used in IPv6 SIP deployments (with a focus on the managed networks case).

Cheers,
Med

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de [email-masked]
Envoyé : mercredi 26 juin 2013 15:40
À : [email-masked]
Objet : I-D Action: draft-boucadair-pcp-sip-ipv6-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title           : PCP for IPv6-enabled SIP Deployments
	Author(s)       : Mohamed Boucadair
	Filename        : draft-boucadair-pcp-sip-ipv6-00.txt
	Pages           : 7
	Date            : 2013-06-26

Abstract:
   This document discusses how PCP can be used in IPv6-enabled SIP
   deployments.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-boucadair-pcp-sip-ipv6

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-boucadair-pcp-sip-ipv6-00

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "Muthu Arul Mozhi Perumal (mperumal)" <[email-masked]>
Date: Wed, 26 Jun 2013 15:58:10 +0000

Hi Med,

This looks interesting. Comparing with ICE, what is missing are the connectivity checks that are particularly important when the IPv6/IPv4 path is broken. So, using PCP for retrieving the external media transport addresses and using ICE for concluding on them might work, I think.

Muthu  

|-----Original Message-----
|From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
|Sent: Wednesday, June 26, 2013 8:35 PM
|To: [email-masked]; [email-masked]; [email-masked]
|Subject: [MMUSIC] TR: I-D Action: draft-boucadair-pcp-sip-ipv6-00.txt
|
|Dear all,
|
|I submitted this short I-D to explain how PCP can be used in IPv6 SIP deployments (with a focus on the
|managed networks case).
|
|Cheers,
|Med
|
|-----Message d'origine-----
|De : [email-masked] [mailto:[email-masked]] De la part de internet-
[email-masked]
|Envoyé : mercredi 26 juin 2013 15:40
|À : [email-masked]
|Objet : I-D Action: draft-boucadair-pcp-sip-ipv6-00.txt
|
|
|A New Internet-Draft is available from the on-line Internet-Drafts directories.
|
|
|	Title           : PCP for IPv6-enabled SIP Deployments
|	Author(s)       : Mohamed Boucadair
|	Filename        : draft-boucadair-pcp-sip-ipv6-00.txt
|	Pages           : 7
|	Date            : 2013-06-26
|
|Abstract:
|   This document discusses how PCP can be used in IPv6-enabled SIP
|   deployments.
|
|
|The IETF datatracker status page for this draft is:
|https://datatracker.ietf.org/doc/draft-boucadair-pcp-sip-ipv6
|
|There's also a htmlized version available at:
|http://tools.ietf.org/html/draft-boucadair-pcp-sip-ipv6-00
|
|
|Internet-Drafts are also available by anonymous FTP at:
|ftp://ftp.ietf.org/internet-drafts/
|
|_______________________________________________
|I-D-Announce mailing list
[email-masked]
|https://www.ietf.org/mailman/listinfo/i-d-announce
|Internet-Draft directories: http://www.ietf.org/shadow.html
|or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
|_______________________________________________
|mmusic mailing list
[email-masked]
|https://www.ietf.org/mailman/listinfo/mmusic

---

From: <[email-masked]>
Date: Thu, 27 Jun 2013 07:48:58 +0200

Dear Muthu,

Thank you for the feedback. 

For managed networks, there is no need to do connectivity checks. For the general case, yes PCP can co-exist with ICE as discussed in draft-penno-rtcweb-pcp. Various reasons are identified in that document.

You may notice this text in the draft which captures this discussion:

"   Even in deployments where ICE [RFC5245] is required, PCP can be of
   great help as discussed in [I-D.penno-rtcweb-pcp].

   The document is targeting SIP deployments in managed networks."

Cheers,
Med

>De : Muthu Arul Mozhi Perumal (mperumal) [mailto:[email-masked]]
>Envoyé : mercredi 26 juin 2013 17:58
>À : BOUCADAIR Mohamed OLNC/OLN; [email-masked]; [email-masked];
>[email-masked]
>Objet : RE: I-D Action: draft-boucadair-pcp-sip-ipv6-00.txt
>
>Hi Med,
>
>This looks interesting. Comparing with ICE, what is missing are the
>connectivity checks that are particularly important when the IPv6/IPv4 path
>is broken. So, using PCP for retrieving the external media transport
>addresses and using ICE for concluding on them might work, I think.
>
>Muthu
>