Subject: Re: [pcp] WG Call for Adoption: Optimizing NAT and Firewall Keepalives Using Port Control Protocol (PCP)

From: Gang Chen <[email-masked]>
Date: Fri, 2 Aug 2013 22:35:07 +0200

I believe that is the right direction we should work. I support the adoption.

Best regards

Gang

On 2013-7-29, at 12:22, "Reinaldo Penno (repenno)" <[email-masked]> wrote:

> Hello,
> 
> This email starts a 2-week consensus call on adopting "Optimizing NAT and
> Firewall Keepalives Using Port Control Protocol (PCP)" as a WG item.
> 
>     Title     : Optimizing NAT and Firewall Keepalives Using Port Control
> Protocol (PCP)
>     Author(s) : T. Reddy et al
>     Filename  : draft-reddy-pcp-optimize-keepalives-01
>     URL       :
> http://tools.ietf.org/html/draft-reddy-pcp-optimize-keepalives-01
> 
> Please read the current revision and state you opinion either for or
> against adoption in the mailing list.
> 
> The call for adoption ends 12th August 2013.
> 
> Thanks,
> 
> Chairs
> 
> _______________________________________________
> pcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcp

---

From: <[email-masked]>
Date: Mon, 5 Aug 2013 08:41:22 +0200

Hi all,

I support this work. 

I have one comment for the authors: consider adding some text to highlight PCP benefits to reduce keepalive messages when deployed in managed networks (i.e., both the underlying network and the service are managed by the same administrative entity). A typical example is SIP-based deployments: optimize the load on access service nodes (SBC, SBE, P-CSCF, etc.) because the lifetime of the mapping is known to the SIP UA and as such there is no need to issue frequent register messages to maintain the mapping alive, etc. 

Cheers,
Med

>-----Message d'origine-----
>De : [email-masked] [mailto:[email-masked]] De la part de
>Reinaldo Penno (repenno)
>Envoyé : lundi 29 juillet 2013 12:22
>À : [email-masked]
>Objet : [pcp] WG Call for Adoption: Optimizing NAT and Firewall Keepalives
>Using Port Control Protocol (PCP)
>
>Hello,
>

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Tue, 6 Aug 2013 07:35:16 +0000

I support adoption of this I-D as a WG document (as a co-author).

Regards,
--Tiru.

> -----Original Message-----
> From: Reinaldo Penno (repenno)
> Sent: Monday, July 29, 2013 3:52 PM
> To: [email-masked]
> Subject: [pcp] WG Call for Adoption: Optimizing NAT and Firewall Keepalives

---

From: <[email-masked]>
Date: Tue, 6 Aug 2013 12:39:34 +0000

Same here. ;-)

Markus

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> ext Tirumaleswar Reddy (tireddy)
> Sent: 06 August, 2013 10:35
> To: Reinaldo Penno (repenno); [email-masked]
> Subject: Re: [pcp] WG Call for Adoption: Optimizing NAT and Firewall
> Keepalives Using Port Control Protocol (PCP)
> 
> > Subject: [pcp] WG Call for Adoption: Optimizing NAT and Firewall
> > Keepalives Using Port Control Protocol (PCP)
> >
> > Hello,
> >
> > This email starts a 2-week consensus call on adopting "Optimizing NAT
> > and Firewall Keepalives Using Port Control Protocol (PCP)" as a WG item.
> >

---

From: <[email-masked]>
Date: Tue, 6 Aug 2013 13:15:05 +0000

Hi,

[email-masked] wrote:
> 
> I have one comment for the authors: consider adding some text to highlight
> PCP benefits to reduce keepalive messages when deployed in managed
> networks (i.e., both the underlying network and the service are managed by
> the same administrative entity). A typical example is SIP-based deployments:
> optimize the load on access service nodes (SBC, SBE, P-CSCF, etc.) because
> the lifetime of the mapping is known to the SIP UA and as such there is no
> need to issue frequent register messages to maintain the mapping alive, etc.
> 

Thanks for the comment. 

I have a question, though: If the same entity operates the network and the service such as SIP, do they need an explicit protocol like PCP to control or learn about the mapping lifetimes, or can they just configure them? I mean, since the service provider is able to configure the NAT/FW mapping lifetimes in the way they like, can't they just set the keep-alives in their SIP clients accordingly? As an example, the Firewall in a mobile network can be configured to set the lifetime for TCP connections destined to the SIP proxy (SBC, P-CSCF) to 1 hour, and via Device Management the operator could also turn off or set the IMS client keep-alives to match that. PCP would not be needed for that particular case.

It would seem to me that PCP would have more utility in "unmanaged" or "unrelated" cases where the client app basically has no a priori knowledge about the network, and neither does the application service provider. Or similarly, the NATs or Firewalls would have no idea what the TCP connections would be used for. 

Markus

---

From: <[email-masked]>
Date: Tue, 6 Aug 2013 15:27:32 +0200

Hi Markus,

Please see inline.

Cheers,
Med

>De : [email-masked] [mailto:[email-masked]]
>Envoyé : mardi 6 août 2013 15:15
>À : BOUCADAIR Mohamed OLNC/OLN; [email-masked]; [email-masked]
>Objet : RE: [pcp] WG Call for Adoption: Optimizing NAT and Firewall
>I have a question, though: If the same entity operates the network and the
[Med] This is indeed the same entity but distinct operational teams. 

>service such as SIP, do they need an explicit protocol like PCP to control
>or learn about the mapping lifetimes, or can they just configure them?
[Med] Configure (dedicated) longer timer is indeed an approach but the use of PCP is superior since the user agent can discover the configured lifetime and therefore react accordingly. 

 I
>mean, since the service provider is able to configure the NAT/FW mapping
>lifetimes in the way they like, can't they just set the keep-alives in
>their SIP clients accordingly?
[Med] As I said above, this is doable but it is static and needs off-line coordination to tweak the midbox and the user agent. 

 As an example, the Firewall in a mobile
>network can be configured to set the lifetime for TCP connections destined
>to the SIP proxy (SBC, P-CSCF) to 1 hour, and via Device Management the
>operator could also turn off or set the IMS client keep-alives to match
>that.
[Med] Agree; that's doable. 

 PCP would not be needed for that particular case.
[Med] PCP can be avoided but still there is a need for coordination between distinct operational teams (those operating the network and those operating the service). If for any reason the timers is to be updater because of some observed failures (synchronization issues), having PCP is superior sine the timers is hinted by the user agent and the user agent is aware of the timer without requiring an additional management interface. Note, pcp is not supposed to be activated only for SIP but for other purposes: one single solution for a variety of usages. 

>
>It would seem to me that PCP would have more utility in "unmanaged" or
>"unrelated" cases where the client app basically has no a priori knowledge
>about the network, and neither does the application service provider. Or
>similarly, the NATs or Firewalls would have no idea what the TCP
>connections would be used for.
>
>Markus

---

From: "Anca Zamfir (ancaz)" <[email-masked]>
Date: Tue, 6 Aug 2013 17:52:53 +0000

I support adoption as a WG document.

thanks,
-anca

---

From: "Prashanth Patil (praspati)" <[email-masked]>
Date: Thu, 8 Aug 2013 10:29:45 +0000

I support adoption of this draft (as a co-author).

-Prashanth

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Fri, 23 Aug 2013 09:55:51 +0000

This WG Call of adoption has finished. The conclusion is that there is
consensus and support to adopt this document as a WG item.