Subject: [pcp] Question about THIRD_PARTY option in DS-Lite PCP Client (not Proxy)

From: Tassos Chatzithomaoglou <[email-masked]>
Date: Wed, 28 Aug 2013 14:50:21 +0300

I'm reading draft-ietf-pcp-dslite-00:

   In the plain mode the B4, the customer end-point of the DS-Lite IPv6
   tunnel, implements a PCP proxy ([I-D.ietf-pcp-proxy <http://tools.ietf.org/html/draft-ietf-pcp-dslite-00#ref-I-D.ietf-pcp-proxy>]) function and
   uses UDP over IPv6 with the AFTR to send PCP requests and receive PCP
   responses.

   The B4 MUST source PCP requests with the IPv6 address of its DS-Lite
   tunnel end-point and MUST use a THIRD PARTY option either empty or
   carrying the IPv4 internal address of the mappings.

I'm testing a DS-Lite CPE running a PCP client (PCP Proxy is disabled) and i'm trying to create some manual/static mappings through its port-forwarding GUI.
What i'm seeing inside the MAP request is the THIRD PARTY option using as "Internal IP address" the local host ip address i define in the port forwarding setup (i.e 192.168.1.2).
This ip address belongs just to a dummy host (running a web server), without any PCP/NAT-PMP/UPnP/etc. functionality.

Is this expected?

-- 
Tassos

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Wed, 28 Aug 2013 14:44:12 +0000

Seems right - as assuming your DS-Lite CPE does not apply NAT as well.

The PCP request created by the CPE will allocated a public IP:port in the
AFTR. When external/incoming packets match this external public IP:port
they will be translated to this internal IP (192.168.1.2) and tunneled
over v6 to the CPE. The CPE will decap the v6 and forward the regular IPv4
packet to its destination.

If you DS-Lite CPE also does NAT that's another story. The internal IP
should be the WAN facing IPv4.

On 8/28/13 8:50 AM, "Tassos Chatzithomaoglou" <[email-masked]>
wrote:

>   tunnel, implements a PCP proxy ([I-D.ietf-pcp-proxy
><http://tools.ietf.org/html/draft-ietf-pcp-dslite-00#ref-I-D.ietf-pcp-prox
>y>]) function and
>I'm testing a DS-Lite CPE running a PCP client (PCP Proxy is disabled)
>and i'm trying to create some manual/static mappings through its
>port-forwarding GUI.
>What i'm seeing inside the MAP request is the THIRD PARTY option using as
>"Internal IP address" the local host ip address i define in the port
>forwarding setup (i.e 192.168.1.2).
>This ip address belongs just to a dummy host (running a web server),
>without any PCP/NAT-PMP/UPnP/etc. functionality.
>
>Is this expected?
>
>-- 
>Tassos
>
>_______________________________________________
>pcp mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/pcp

---

From: Tassos Chatzithomaoglou <[email-masked]>
Date: Wed, 28 Aug 2013 18:03:54 +0300

Thanks Reinaldo.
That's my understanding too, after reading the case "HTTP-Triggered PCP Client Model" in draft-boucadair-pcp-deployment-cases.

Question to draft-ietf-pcp-dslite authors:
Although i had asked this in the past, are there any plans to add PCP Client in draft-ietf-pcp-dslite?
We surely gonna use this functionality.

--
Tassos