Subject: Re: [pcp] WGLC: draft-ietf-pcp-port-set-03.txt comments due by NOV 5

From: Dave Thaler <[email-masked]>
Date: Tue, 5 Nov 2013 02:39:54 +0000

Reminder that the WGLC deadline is tomorrow.
I've only seen two responses so far.
We need more reviews, so consider this a prod.

-Dave

> -----Original Message-----
> From: Dave Thaler
> Sent: Monday, October 21, 2013 4:52 PM
> To: [email-masked]
> Subject: WGLC: draft-ietf-pcp-port-set-03.txt comments due by NOV 5
> 
> This email initiates a two-week Working Group Last Call on
> draft-ietf-pcp-port-set-03 to conclude on Tuesday, November 5th.
> 
> Please send comments to the list.
> 
> -Dave
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On Behalf Of
> > Simon Perreault
> > Sent: Monday, October 21, 2013 5:33 AM
> > To: [email-masked]
> > Subject: Re: [pcp] I-D Action: draft-ietf-pcp-port-set-03.txt
> >
> > WG,
> >
> > This revision addresses comments received at IETF 87 in Berlin, namely:
> >
> > - The "Port Set Offset" field has been replaced by a filed named
> > "First Internal Port".
> >
> > - A new section "Examples" shows various usage examples.
> >
> > To this editor's knowledge there are no open issues left.
> >
> > Simon
> >
> > Le 2013-10-21 12:56, [email-masked] a écrit :
> > >
> > > A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> > >  This draft is a work item of the Port Control Protocol Working
> > > Group of the
> > IETF.
> > >
> > > 	Title           : Port Control Protocol (PCP) Extension for Port Set
> > Allocation
> > > 	Author(s)       : Qiong Sun
> > >                           Mohamed Boucadair
> > >                           Senthil Sivakumar
> > >                           Cathy Zhou
> > >                           Tina Tsou
> > >                           Simon Perreault
> > > 	Filename        : draft-ietf-pcp-port-set-03.txt
> > > 	Pages           : 15
> > > 	Date            : 2013-10-21
> > >
> > > Abstract:
> > >    This document defines an extension to PCP allowing clients to
> > >    manipulate sets of ports as a whole.  This is accomplished by a new
> > >    MAP option: PORT_SET.
> > >
> > >
> > > The IETF datatracker status page for this draft is:
> > > https://datatracker.ietf.org/doc/draft-ietf-pcp-port-set
> > >
> > > There's also a htmlized version available at:
> > > http://tools.ietf.org/html/draft-ietf-pcp-port-set-03
> > >
> > > A diff from the previous version is available at:
> > > http://www.ietf.org/rfcdiff?url2=draft-ietf-pcp-port-set-03
> > >
> > >
> > > Please note that it may take a couple of minutes from the time of
> > > submission until the htmlized version and diff are available at
> tools.ietf.org.
> > >
> > > Internet-Drafts are also available by anonymous FTP at:
> > > ftp://ftp.ietf.org/internet-drafts/
> > >
> > > _______________________________________________
> > > pcp mailing list
> > > [email-masked]
> > > https://www.ietf.org/mailman/listinfo/pcp

---

From: Ted Lemon <[email-masked]>
Date: Tue, 5 Nov 2013 05:07:17 +0000

In figure 1, I think it's intended that the Reserved field be 7 bits, combining with P to fill a single octet.   However, the chart actually shows it as 8 bits, with the P bit out in the next octet.

Also in section 4:

      NOTE: In its current form, PORT_SET does not support allocating
      discontinuous port sets.  That feature could be added in the
      future depending on input from the working group.

The second sentence doesn't really make sense.  The working group can add features, of course, but given that the document doesn't talk about how to do this, why mention it?   It seems to me that it would be a new, relatively distinct extension.

Aside from these observations, I don't see any obvious problems with the document, and it does solve at least one problem that I think is important to solve.   I didn't notice anything that I think wouldn't work.   So (AD hat off, of course) I do not object to publication.

---

From: Simon Perreault <[email-masked]>
Date: Mon, 04 Nov 2013 22:54:22 -0800

Ted,

Thanks a lot for your review!

> In figure 1, I think it's intended that the Reserved field be 7 bits, combining with P to fill a single octet.   However, the chart actually shows it as 8 bits, with the P bit out in the next octet.

Am I looking at the same figure as you are?

     0                   1                   2                   3
     0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
    | Option Code=? |   Reserved    |        Option Length=5        |
    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
    |        Port Set Size          |      First Internal Port      |
    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
    |  Reserved   |P|
    +-+-+-+-+-+-+-+-+

                          Figure 1: PORT_SET Option

It looks correct to me...

> The second sentence doesn't really make sense.  The working group can add features, of course, but given that the document doesn't talk about how to do this, why mention it?   It seems to me that i…

Agreed. By "in the future" we meant "in future revisions of this draft". 
Now that we're in WGLC it doesn't make sense anymore. I'll just remove 
the note entirely.

> Aside from these observations, I don't see any obvious problems with the document, and it does solve at least one problem that I think is important to solve.   I didn't notice anything that I think…

Great!

Thanks,
Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca

---

From: Qi Sun <[email-masked]>
Date: Mon, 4 Nov 2013 23:15:51 -0800

Dear all,

I support this document to move forward.

Best Regards,
Qi

On Mon, Oct 21, 2013 at 4:52 PM, Dave Thaler <[email-masked]> wrote:

> > - The "Port Set Offset" field has been replaced by a filed named "First
> Internal
> > Port".
> >
> > >  This draft is a work item of the Port Control Protocol Working Group
> of the
> > IETF.
> > >

---

From: "Fuyu (Eleven)" <[email-masked]>
Date: Tue, 5 Nov 2013 07:22:28 +0000

Hi all,

I support to move forward this document. It is useful for managing a set of ports.

Cheers
Yu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Dave Thaler
Sent: Tuesday, October 22, 2013 7:52 AM
To: [email-masked]
Subject: [pcp] WGLC: draft-ietf-pcp-port-set-03.txt comments due by NOV 5

-Dave

> - The "Port Set Offset" field has been replaced by a filed named "First Internal
> Port".
> 
> > A New Internet-Draft is available from the on-line Internet-Drafts directories.
> >  This draft is a work item of the Port Control Protocol Working Group of the
> IETF.
> >
> > submission until the htmlized version and diff are available at tools.ietf.org.
> >

---

From: Cong Liu <[email-masked]>
Date: Mon, 4 Nov 2013 23:26:02 -0800

Dear all,

I've read this document and I think it's a very useful work. I support
advancing this document.

A small problem: in section 3, is "Length: 3 bytes" a mistake?

Best Regards,
Cong

---

From: "Yuchi Chen" <[email-masked]>
Date: Tue, 5 Nov 2013 15:58:30 +0800

Hi all,

I support moving forward this document. 

Best regards!

Yuchi Chen

From: Dave Thaler
Date: 2013-10-22 07:52
To: [email-masked]

-Dave

---

From: Ted Lemon <[email-masked]>
Date: Tue, 5 Nov 2013 14:20:03 +0000

> Am I looking at the same figure as you are?

No.   I apparently reviewed the -01 version, which probably reflects poorly on my ability to detect problems in the document.   The new version has several improvements that I like, including that the chart is fixed.   Sorry for the confusion.

---

From: Simon Perreault <[email-masked]>
Date: Tue, 05 Nov 2013 06:44:22 -0800

Great!

> A small problem: in section 3, is "Length: 3 bytes" a mistake?

Yes! To be fixed in the next revision.

Thanks for the review!

Simon

---

From: Dave Thaler <[email-masked]>
Date: Tue, 5 Nov 2013 15:42:27 +0000

When responding to WGLC, what we chairs are looking for is a statement 
of document quality (not really about whether the mechanism should move
forward).  That is, state whether you think the document is ready as is,
or if not, what issues you see.

Thanks for those who have sent reviews, and I hope to see more today.

-Dave

> Dave Thaler
> Sent: Monday, November 4, 2013 6:40 PM
> To: [email-masked]
> Subject: Re: [pcp] WGLC: draft-ietf-pcp-port-set-03.txt comments due by
> NOV 5
> 
> > > From: [email-masked] [mailto:[email-masked]] On Behalf
> > > Of Simon Perreault