Subject: [pcp] IETF 88 notes for draft-ietf-pcp-port-set-04

From: Dave Thaler <[email-masked]>
Date: Tue, 25 Feb 2014 02:00:07 +0000

>From the IETF 88 meeting notes (http://www.ietf.org/proceedings/88/minutes/minutes-88-pcp)

[...]
> Dave Thaler suggested that if port-set capability is added (or removed),
> the PCP server can reset its Epoch to zero, which causes PCP client to 
> re-try using PORT_SET. New text is needed in the document for those things.
> [See also discussion in the Jabber log.]

I don't see this in draft -04.

[...]
> Simon: Possible to get multiple responses to a single request.
> Dan: Add to Security Considerations.
> Dan: If I'm missing one response out of the set, have to re-send request.
> Dave: Need to know nonce, so this can still be an on-path attack.

I don't see this in draft -04.

[...]
> Dan: Server can be upgraded/changed to support/not support PORT_SET.
>     Is there any harm to always request PORT_SET?
> Dave: If I get an indication that the server doesn't currently support
>      PORT_SET, I'll send multiple requests in parallel.

This is related to the issue in the other thread (the follow-up to -03).
The text to address that should just keep the above in mind.

-Dave

---

From: Simon Perreault <[email-masked]>
Date: Tue, 25 Feb 2014 09:50:46 -0500

You're right. I wonder how I missed those. I'll bake a new revision.

Simon

Le 2014-02-24 21:00, Dave Thaler a écrit :
> _______________________________________________
> pcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcp
> 

-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca