Subject: Re: [pcp] New Version Notification for draft-ripke-pcp-tunnel-id-option-00.txt

From: <[email-masked]>
Date: Thu, 27 Mar 2014 10:43:19 +0100

Dera Andreas,

FWIW, you may add a reference to the deployment scenarios document that discusses the case you are covering in your I-D: 
http://tools.ietf.org/html/draft-boucadair-pcp-deployment-cases-01#section-5.2 

Cheers,
Med

>-----Message d'origine-----
>De : pcp [mailto:[email-masked]] De la part de Andreas Ripke
>Envoyé : vendredi 14 février 2014 10:07
>À : [email-masked]
>Objet : [pcp] FW: New Version Notification for draft-ripke-pcp-tunnel-id-
>option-00.txt
>
>Hi,
>
>The below draft describes a scenario in that
>  (1) the subscribers behind a CGN can freely choose their internal IP
>addresses
>       (which potentially leads to overlapping IP address spaces)
>  (2) a central PCP client is used for port mapping requests.
>The CGN, acting as PCP server, cannot identify the subscriber just by the
>internal IP address provided with the THIRD_PARTY option.
>Therefore, an additional identifier (the subscriber’s tunnel ID) to the PCP
>mapping request is needed.
>
>If you have any comments on this draft please let us know. Thanks.
>
>Best,
>
>Andreas
>
>
>NEC Europe Ltd | Registered Office: Athene, Odyssey Business Park, West End
>Road, London, HA4 6QE, GB | Registered in England 2832014
>
>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]]
>> Sent: Thursday, February 13, 2014 4:51 PM
>> To: Andreas Ripke; Rafael Lopez da Silva; Rafael Lopez da Silva; Thomas
>Dietz;
>> Juergen Quittek; Juergen Quittek; Thomas Dietz; Andreas Ripke
>> Subject: New Version Notification for draft-ripke-pcp-tunnel-id-option-
>00.txt
>>
>>
>> A new version of I-D, draft-ripke-pcp-tunnel-id-option-00.txt
>> has been successfully submitted by Andreas Ripke and posted to the IETF
>> repository.
>>
>> Name:		draft-ripke-pcp-tunnel-id-option
>> Revision:	00
>> Title:		PCP Tunnel-ID Option
>> Document date:	2014-02-13
>> Group:		Individual Submission
>> Pages:		8
>> URL:            http://www.ietf.org/internet-drafts/draft-ripke-pcp-
>tunnel-id-
>> option-00.txt
>> Status:         https://datatracker.ietf.org/doc/draft-ripke-pcp-tunnel-
>id-option/
>> Htmlized:       http://tools.ietf.org/html/draft-ripke-pcp-tunnel-id-
>option-00
>>
>>
>> Abstract:
>>    This document describes a new Port Control Protocol (PCP) option
>>    called TUNNEL_ID.  It serves for identifying a Third Party in
>>    addition to the means that PCP's THIRD_PARTY option already provides
>>    for that purpose.
>>
>>
>>
>>
>> Please note that it may take a couple of minutes from the time of
>submission
>> until the htmlized version and diff are available at tools.ietf.org.
>>
>> The IETF Secretariat
>
>_______________________________________________
>pcp mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/pcp

---

From: Andreas Ripke <[email-masked]>
Date: Thu, 27 Mar 2014 20:09:45 +0000

Dear Med,

Thanks for the pointer.
We will add the reference in the next draft.

Back then when you submitted your deployment draft did this particular use case cause any concerns?

Best,

Andreas

> From: [email-masked]
> [mailto:[email-masked]]
> Sent: Thursday, March 27, 2014 10:43 AM
> To: Andreas Ripke; [email-masked]
> Subject: RE: New Version Notification for draft-ripke-pcp-tunnel-id-option-00.txt
> 
> Dera Andreas,
> 
> FWIW, you may add a reference to the deployment scenarios document that
> discusses the case you are covering in your I-D:
> >Envoyé : vendredi 14 février 2014 10:07 À : [email-masked] Objet : [pcp]
> >FW: New Version Notification for draft-ripke-pcp-tunnel-id-
> >option-00.txt
> >
> >Hi,
> >
> >The CGN, acting as PCP server, cannot identify the subscriber just by
> >the internal IP address provided with the THIRD_PARTY option.
> >Therefore, an additional identifier (the subscriber’s tunnel ID) to the
> >PCP mapping request is needed.
> >
> >NEC Europe Ltd | Registered Office: Athene, Odyssey Business Park, West
> >End Road, London, HA4 6QE, GB | Registered in England 2832014
> >
> >
> >> has been successfully submitted by Andreas Ripke and posted to the
> >> IETF repository.
> >>

---

From: <[email-masked]>
Date: Fri, 28 Mar 2014 10:41:27 +0100

Dear Andreas,

As mentioned in the draft, the use case can be addressed by the use of THIRD_PARTY option. An issue can be encountered if the internal IP address to identify a subscriber is not an IP address but something else (e.g., L2-aware NAT case). 

Cheers,
Med

>De : Andreas Ripke [mailto:[email-masked]]
>Envoyé : jeudi 27 mars 2014 21:10
>À : BOUCADAIR Mohamed IMT/OLN; [email-masked]
>Cc : Thomas Dietz; Juergen Quittek; Rolf Winter
>Objet : RE: New Version Notification for draft-ripke-pcp-tunnel-id-option-
>00.txt
>
>Dear Med,
>
>Thanks for the pointer.