Subject: Re: [pcp] [Spud] PCP vs. SPUD

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Thu, 26 Mar 2015 04:34:22 +0000

Yes, PCP can be used to communicate with middle boxes to open and close pinholes; PCP also handles attacks like attacker closing the pinholes opened by the victim or attacker opening pinholes on behalf of victim to launch DDOS attacks, allow only authorized endpoints to open/close pinholes etc.

-Tiru

From: Spud [mailto:[email-masked]] On Behalf Of Aaron Falk
Sent: Thursday, March 26, 2015 3:08 AM
To: [email-masked]
Subject: [Spud] PCP vs. SPUD

If we take SPUD's goals at their most minimal, as expressed by Ted, of enabling passage of encrypted traffic through middleboxes, can someone explain why PCP is not sufficient?

--aaron

---

From: <[email-masked]>
Date: Thu, 26 Mar 2015 14:06:51 +0000

Hi Tiru, all,

I would like to add that PCP solves another problem that we recorded in https://tools.ietf.org/html/draft-boucadair-transport-protocols-01

      Even if protocols encapsulated over UDP can make use of NAT
      traversal techniques, these protocols are still suffering from
      issues related to the presence of NATs and firewalls.  For
      example, there is no mechanism to notify endpoints that an entry
      is no more active in the NAT/Firewall.  Immediate notification and
      state recovery can be solved by activating specific Port Control
      Protocol (PCP) feature: (PCP ANNOUNCE OPCODE, [RFC6887<https://tools.ietf.org/html/rfc6887>]).

Cheers,
Med

De : pcp [mailto:[email-masked]] De la part de Tirumaleswar Reddy (tireddy)
Envoyé : mercredi 25 mars 2015 23:34
À : Aaron Falk; [email-masked]
Cc : [email-masked]
Objet : Re: [pcp] [Spud] PCP vs. SPUD

-Tiru

From: Spud [mailto:[email-masked]] On Behalf Of Aaron Falk
Sent: Thursday, March 26, 2015 3:08 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Spud] PCP vs. SPUD

--aaron