Subject: [pcp] A question: How can an internal client get the external IP and port of the inner NAT

From: Chenguohai <[email-masked]>
Date: Fri, 23 Oct 2015 03:24:35 +0000

Hi all,
I am new to PCP and reading RFC6887.I have a question about section 8.1. On the upper part of page 22 writing following,
the PCP-controlled NAT creating pointless non-functional mappings.
   When such an intervening non-PCP-aware inner NAT is detected,
   mappings must first be created by some other means in the inner NAT,
   before mappings can be usefully created in the outer PCP-controlled
   NAT.  Having created mappings in the inner NAT by some other means,
   the PCP client should then use the inner NAT’s external address as
   the client IP address, to signal to the outer PCP-controlled NAT that
   the client is aware of the inner NAT, and has taken steps to create
   mappings in it by some other means, so that mappings created in the
   outer NAT will not be a pointless waste of resources.

My question is that how an interal client could get the external IP and port of the inner NAT.
Should there be server between the inner NAT and the external one? How could it be assured that the inner NAT does not change external port?

BR
G.Robert  Chen
-------------------------------------------------------------------------------------------------------------------------------------
G.Robert  Chen (Chen Guohai  陈国海). Network Research Department, Huawei Technologies Co., Ltd. Telephone: 0086-25-56624606;   http://www.huawei.com
-------------------------------------------------------------------------------------------------------------------------------------
This e-mail and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the  information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!
----------------------------------------------------------------------------------------------------------------------------------------

---

From: 🔓Dan Wing <[email-masked]>
Date: Fri, 23 Oct 2015 10:44:15 -0700

> My question is that how an interal client could get the external IP and port of the inner NAT.

PCP, UPnP IGD, STUN, manual configuration.

> Should there be server between the inner NAT and the external one? How could it be assured that the inner NAT does not change external port?

Hopefully whatever mechanism the client used (PCP, UPnP IGD, STUN, manual configuration) would tell the client of such a change.

-d

> G.Robert  Chen (Chen Guohai  陈国海). Network Research Department, Huawei Technologies Co., Ltd. Telephone: 0086-25-56624606;   http://www.huawei.com <http://www.huawei.com/>
> _______________________________________________
> pcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcp

---

From: 🔓Dan Wing <[email-masked]>
Date: Sat, 24 Oct 2015 08:54:16 -0700

On 23-Oct-2015 06:04 pm, ChenGuohai <[email-masked]> wrote: 
> Hi Dan,
>  
> Many thanks for your explaination.
>  
> Inner NATs are mostly used in residents and external NATs are CGNs is the most common nested NAT case.
>  
> Using PCP means that the CPE(inner NAT) must embed a PCP server.  The PCP client should communicats with two PCP servers.

Right.

> Using STUN means a STUN server need to be deployed between inner NAT and external NAT. Shall this be common?

Not that I have seen.

-d

>  
> Manual configuration is very cost.
>  
>  
> BR
> G.Robert  Chen
>  
> Subject: Re: [pcp] A question: How can an internal client get the external IP and port of the inner NAT
> From: [email-masked]
> Date: Fri, 23 Oct 2015 10:44:15 -0700
> CC: [email-masked]; [email-masked]
> To: [email-masked]
> 
> 
> On 22-Oct-2015 08:24 pm, Chenguohai <[email-masked] <mailto:[email-masked]>> wrote: 
>  
>  
> Hi all,
> [email-masked] <mailto:[email-masked]>