Subject: Re: [PEPPERMINT] Data model for "reachability data" and naming/terminology for group of addresses

From: "Jean-Francois Mule" <[email-masked]>
Date: Tue, 8 Jul 2008 15:13:53 -0600

Ray,

   Thank you for the comments and sorry for the delay in responding.
More inline.

Jean-Francois.

Ray wrote:
> Can you elaborate on what a "Service Area" / "Address Group"
> actually is?
It is basically a way to logically group user addresses that can be
   - reached via a given Signaling path Border Element (SBE),
   - reached via a domain from which SIP servers can be located (a la
rfc3263)
Folks often picture this by saying it is a group of users reachable via
a common (SIP) 'route'.

> In the UK for our Central Numbering Database we've developed a
> concept of
> a "Destination Group" - that being all those numbers (or
> destinations)
> which are supposed to be routed identically.  Is that the same
> thing?
I believe so.  Would folks prefer Destination Group then?

> Note however that this does not mean that every originating carrier
> has to
> route them to the same place as every other carrier.
> 
> For example if Carrier A (a terminating carrier) has:
> 
>   DG1 = (a, b)
>   DG2 = (c, d)
> 
> then originating Carrier B routes destinations in DG1 to a
> particular
> interconnect, and routes DG2 to some other interconnect.  However
> Carrier
> C might have completely different interconnects with Carrier A.
> 
> In the UK model the actual interconnect addresses are private
> information
> bilaterally agreed between carriers.
> 
> kind regards,
> 
> Ray

_______________________________________________
PEPPERMINT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/peppermint

---

From: "Jean-Francois Mule" <[email-masked]>
Date: Tue, 8 Jul 2008 16:38:31 -0600

Ted wrote:
> As a relative neophyte, it's more obvious to me what "Destination
> Group" means than what "Service Area" means.   So I think it's
> somewhat preferable, although there's nothing fundamentally wrong
> with "Service Area."   I think it's because "Destination Group"
> implies logical locality, whereas "Service Area" implies physical
> locality.

Yes. 
I would also note that this "Destination Group" is close to what Debbie
Guyton in draft-guyton-drinks-registry-data-00.txt calls a "Dial Code to
Destinations" for logical groupings of dial codes.
 
Jean-Francois.

---

From: Ted Lemon <[email-masked]>
Date: Tue, 8 Jul 2008 14:18:09 -0700

> I believe so.  Would folks prefer Destination Group then?

As a relative neophyte, it's more obvious to me what "Destination Group" means than what "Service Area" means.   So I think it's somewhat preferable, although there's nothing fundamentally wrong with "Service Area."   I think it's because "Destination Group" implies logical locality, whereas "Service Area" implies physical locality.