Subject: [Pidloc] draft-kjsun-ipwave-id-loc-separation

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 3 Apr 2019 10:56:38 -0500

Hello Gomjae,

Today, we had a Webex session with Dirk and discussed about your draft

draft-kjsun-ipwave-id-loc-separation

in this draft you introduced architectures for the use of IDLOC protocols in

vehicular networks.

We consider this one of the significant use cases in our pidloc activity.

We know you attended pidloc side meeting in Prague last week, thanks for that.

We would appreciate if you could introduce your draft to the list shortly in

your reply?

Also any ideas on the privacy issues that arise in the vehicular networking

from the use IDLOC protocols?

Regards,

Behcet & Dirk

---

From: "KJ SUN" <[email-masked]>
Date: Fri, 05 Apr 2019 15:01:00 +0900

Hello Behcet, 

Thanks for giving me opportunity to introduce my draft "Considerations for ID/Location Separation Protocols in IP-based Vehicular Networks"
https://datatracker.ietf.org/doc/draft-kjsun-ipwave-id-loc-separation/

Purpose of this draft is to analyze applicability of ID/LOC protocols into vehicular network discussed in IPWAVE WG.

I considered LISP and ILNP as candidates protocols, and make use case based on vehicular network architecture described in IPWAVE PS doc (draft-ietf-ipwave-vehicular-networking)

In the Gap Analysis, I tried to follow issues described in PS doc, for each issue I referred d related ietf docs as possible solution.

Privacy issues in IPWAVE environment are well-described in PS doc. In that draft, they mentioned that tracking prevention should be supported with not only E2E continuity but also confidentiality. In my opinion, ID/LOC protocol may solve this problem easier since that ID information is not strongly bound to its location. 

Honestly, I still have no idea for that and privacy issues were out of my interests. So, pidloc work could be helpful to analyze privacy issue and make solution for that.

I will more read related privacy documents and try to figure out for vehicular network use case. All comments and co-operations are welcome.

Regards,

KJ

Kyoungjae Sun / K. J. SUN (Ph. D. Student)
Distributed Computing Network laboratory (DCN Lab)
School of Electronic Engineering, Soongsil Univ.
369 Sangdo-ro, Dongjak-gu, Seoul.
Tel. +82-2-814-0151
Mobile +82-10-3643-5627
Email [email-masked]
On 2019-04-04 오전 12:56:50, Behcet Sarikaya <[email-masked]> wrote:
Hello Gomjae,

Regards,

Behcet & Dirk

---
이 이메일은 Avast 안티바이러스 소프트웨어로 바이러스 검사를 완료했습니다.
https://www.avast.com/antivirus

---

From: <[email-masked]>
Date: Tue, 16 Apr 2019 14:09:12 +0000

Hi KJ,
thanks for your detailed information – and sorry for my delayed reply!
I agree that in the vehicular case it is not so much the (static) location privacy which could be exhibited, but a movement tracking privacy as mentioned also in Eriks draft https://www.ietf.org/archive/id/draft-nordmark-id-loc-privacy-00.txt.
Especially on highways with kind of predictable movement also a simple change of ID could  allow for derivation of a prior ID and mapping of all the modified ones – which may in the end even resolve the modification mechanism.
Do you think this is worth including in the planned use case based requirements analysis?
Thanks!
Kind regards
Dirk

From: KJ SUN <[email-masked]>
Sent: Freitag, 5. April 2019 08:01
To: [email-masked]; [email-masked]
Cc: von Hugo, Dirk <[email-masked]>
Subject: Re: draft-kjsun-ipwave-id-loc-separation

Hello Behcet,

Regards,

KJ

Tel. +82-2-814-0151

Mobile +82-10-3643-5627

vehicular networks.

your reply?

Regards,

Behcet & Dirk

________________________________
[Image removed by sender. Avast logo]<https://www.avast.com/antivirus>

이 이메일은 Avast 안티바이러스 소프트웨어로 바이러스 검사를 완료했습니다.
www.avast.com<https://www.avast.com/antivirus>

---

From: "KJ SUN" <[email-masked]>
Date: Thu, 18 Apr 2019 11:01:56 +0900

Dirk,

In my opinion, in vehicular network, there may be some trade-offs. Even changing ID is good to prevent its movement privacy, but at the same time locator also will change very frequently when vehicle moves in very high speed, ID/Loc mapping change occurs many times, and finally it can impacts their communication performance. So we need to cosider this when we allow ID/Loc modificatio mechanism.

>From other point of view, I think that permanent ID is not needed for vehicular network since that its communication characteristics. When V2I case, we can use other identifiers transparent from packet header to authenticated by its vendor application. And between third-party or V2V, it is enough to use temporary identifier. It may also help to enhance privacy.

I think it will be good to include use case but we need to more clarifications.

Thanks.

Regards,

KJ.
On 2019-04-16 오후 11:09:14, [email-masked] <[email-masked]> wrote:
I agree that in the vehicular case it is not so much the (static) location privacy which could be exhibited, but a movement tracking privacy as mentioned also in Eriks draft https://www.ietf.org/archive/id/draft-nordmark-id-loc-privacy-00.txt [https://www.ietf.org/archive/id/draft-nordmark-id-loc-privacy-00.txt].

Hello Behcet, 

 

 

Regards,
 
KJ

 

 
Regards,
 
Behcet & Dirk

[Image removed by sender. Avast logo] [https://www.avast.com/antivirus]
이 이메일은 Avast 안티바이러스 소프트웨어로 바이러스 검사를 완료했습니다.
www.avast.com [https://www.avast.com/antivirus]

---

---

From: <[email-masked]>
Date: Thu, 18 Apr 2019 14:51:45 +0000

Dear KJ,

Thanks for further elaboration. I agree that here multiple communication parameters play a role and the typical short-term session between vehicles only temporary in reach of each other (except for specific use cases as e.g. platooning etc.) helps to leverage impact of ID change rate (per session) on performance.
It would be great to describe the plentitude of privacy aspects in vehicular communication as one of the interesting use cases in a separate draft. I hope we can ask you for support and contribution when we start such a document.
Thanks again!
Kind regards
Dirk

From: KJ SUN <[email-masked]>
Sent: Donnerstag, 18. April 2019 04:02
To: von Hugo, Dirk <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: draft-kjsun-ipwave-id-loc-separation

Dirk,

Thanks.

Regards,

KJ.

Tel. +82-2-814-0151

Mobile +82-10-3643-5627

Email [email-masked]<mailto:[email-masked]>

On 2019-04-16 오후 11:09:14, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>> wrote:
Hi KJ,

From: KJ SUN <[email-masked]<mailto:[email-masked]>>
Sent: Freitag, 5. April 2019 08:01
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: von Hugo, Dirk <[email-masked]<mailto:[email-masked]>>
Subject: Re: draft-kjsun-ipwave-id-loc-separation

Hello Behcet,

Regards,

KJ

Tel. +82-2-814-0151

Mobile +82-10-3643-5627

Email [email-masked]<mailto:[email-masked]>

On 2019-04-04 오전 12:56:50, Behcet Sarikaya <[email-masked]<mailto:[email-masked]>> wrote:
Hello Gomjae,

vehicular networks.

your reply?

Regards,

Behcet & Dirk