Subject: Re: [Pidloc] Pidloc in IETF Prague #104

From: <[email-masked]>
Date: Tue, 16 Apr 2019 13:53:15 +0000

Dear all,
sorry for delayed reply:
I agree that data plane will also be in scope of privacy issues for Id-Loc protocols – if I understood correctly the use case on ‘Location exposure of nearest User Plane Function to local (non-3GPP) Data Networks’ described by Marco and Umberto in https://datatracker.ietf.org/doc/draft-fattore-dmm-n6-cpdp-trafficsteering/ addresses data plane issues.
@Marco and Umberto: ‘Traffic Identifier’ and ‘UPF/DPN N6 endpoint’ here serve as Id and Loc, right?
Thanks!
Kind regards
Dirk

From: Behcet Sarikaya <[email-masked]>
Sent: Freitag, 29. März 2019 17:10
To: von Hugo, Dirk <[email-masked]>
Cc: [email-masked]
Subject: Re: [Pidloc] Pidloc in IETF Prague #104

Hi Dirk,

Thanks for the minutes.

Let me add that there was some discussion on whether we should concentrate the privacy work on the control or data plane.
I thought the conclusion was control plane. However, thinking a little bit more on this, I came to the conclusion that we also need to work on the data plane.
The reason being as some previous work has shown, changing identifiers/locators that the UE uses from one session to another  improves a lot the privacy issues.

What do you think?

Regards,
Behcet

On Fri, Mar 29, 2019 at 10:52 AM <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,
as announced before we actually had our side meeting here in Prague and some fruitful discussions.
I’d like to share with you some notes of the 1-hour session where seven people attended on site and about four more on the phone/webex. Sorry for the inconvenience of a sub-optimum audio connection.
I will also attach the slides shown and the link provided by Marco.

Dirk presented chairs slides - focus was more on the open questions (gaps and problems) to be solved than on solutions.
Erik commented on use cases as edge computing in IoT (location is an issue here) and consumers sharing voluntarily Id and Location on application layer – which of course also should not be leaked beyond intended recipients.
VPN like closed groups pose less problem than rather consumer scale device numbers (walled garden or separate domains).

Shunsuke presented 5G use case attempting to include Id-Loc compatible with 3GPP architecture.
Location exposure of nearest UPF to local (non-3GPP) Data Networks (maybe untrusted) may raise privacy issues on related location information (from UPF to derive that of UE).

Next steps might be a more complete collection and classification of use cases and thereof identification of a requirements set to be demanded from potential solutions.

Marco and Umberto promised and meanwhile did to provide a link to related slides in DMM (draft at https://www.ietf.org/id/draft-fattore-dmm-n6-trafficsteering-01.txt) pointing to the LDN problem:

ID-LOC applies to the data network’s DPN and the user’s current (edge) UPF (serving as session anchor).

https://datatracker.ietf.org/meeting/104/materials/slides-104-dmm-control-data-plane-for-n6-traffic-steering-00

A question was whether slicing shall be provided via Id-Loc? Rather than that a low latency service on DP/UP would be the goal.
Somebody mentioned that also tunneling between two endpoints could be seen as Id-Loc approach.
Thanks for comments and updates/corrections by all participants.
Let’s continue discussion on the list.

Kind regards
Dirk

--
Pidloc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pidloc

---

From: Marco Liebsch <[email-masked]>
Date: Tue, 16 Apr 2019 15:46:00 +0000

Hi Dirk,

Traffic Identifier can be also something broader and more aggregate, e.g. all data traffic associated with a single user
or a group of users. Depends on how fine granular treatment policies should apply. This can be for example a PDU session
identifier or the associated UE IP address. UPF/DPN as N6 endpoint, yes, that is the data plane anchor where downlink
traffic should be transported to. Dependent on its deployment, it can reveal more or less accurate location information.

Best regards,
marco

From: [email-masked] [mailto:[email-masked]]
Sent: Dienstag, 16. April 2019 15:53
To: [email-masked]
Cc: [email-masked]; [email-masked]; Umberto Fattore
Subject: RE: [Pidloc] Pidloc in IETF Prague #104

Dear all,
sorry for delayed reply:

Hi Dirk,

Thanks for the minutes.

What do you think?

Regards,
Behcet

Kind regards
Dirk

---

From: <[email-masked]>
Date: Thu, 18 Apr 2019 14:42:51 +0000

Thanks Marco and Umberto,
for quick clarification!
Two issues came to my mind:

1)      In your security considerations an association between the DPN and the cellular system could be mentioned (or do you assume this being not use case specific should already be considered in general - elsewhere?)

2)      Maybe there could a section on ‘privacy issues’ added in the draft to describe the implications for requiring additional measures for UE location obfuscation here?

What do you think?
Thanks again and happy holidays!
Kind regards
Dirk

From: Marco Liebsch <[email-masked]>
Sent: Dienstag, 16. April 2019 17:46
To: von Hugo, Dirk <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; Umberto Fattore <[email-masked]>
Subject: RE: [Pidloc] Pidloc in IETF Prague #104

Hi Dirk,

Best regards,
marco

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Dienstag, 16. April 2019 15:53
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Umberto Fattore
Subject: RE: [Pidloc] Pidloc in IETF Prague #104

Dear all,
sorry for delayed reply:

From: Behcet Sarikaya <[email-masked]<mailto:[email-masked]>>
Sent: Freitag, 29. März 2019 17:10
To: von Hugo, Dirk <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Pidloc] Pidloc in IETF Prague #104

Hi Dirk,

Thanks for the minutes.

What do you think?

Regards,
Behcet

Kind regards
Dirk