Subject: Re: Draft on Advice for Internet Subnetwork Designers

From: Grenville Armitage <[email-masked]>
Date: Thu, 09 Mar 2000 09:51:01 -0800

okay. i see the adaptation as part of the router, so perhaps
we're in agreement.

gja

Marie-Jose Montpetit wrote:
> 
> Agreed it is not the "link" as we could understand it in the case of
> wireless for example but surely the "transport" in the subnet. What I meant
> is the router should not (minimally?) be impacted. The adaptation should.
> 
> Marie-Jose
> 
> -----Original Message-----
> From: Grenville Armitage [mailto:[email-masked]]
> Sent: Thursday, March 09, 2000 9:41 AM
> To: Marie-Jose Montpetit
> Cc: [email-masked]'; [email-masked]
> Subject: Re: Draft on Advice for Internet Subnetwork Designers
> 
> marie-jose,
> 
> not in this case. it is a design decision for the router, not
> the link. think ISSLL, IP-ATM, etc, etc.... the IP to link layer
> driver is where we implement particular rules for mapping certain
> types of (marked) IP packets onto links, subsets of links, or
> /dev/null.
> 
> cheers,
> gja
> 
> Marie-Jose Montpetit wrote:
> >
> > If we start from the premise that the equipment that is connected to the
> > subnetwork is unaware of the particularities of the subnetwork, which I
> > think is usually the case, then it is an issue for the designer.
> >
> > Marie-Jose
> >
> > > -----Original Message-----
> > > From: Phil Karn [SMTP:[email-masked]]
> > > Sent: Thursday, March 09, 2000 12:18 AM
> > > To:   [email-masked]
> > > Cc:   [email-masked]; [email-masked]; [email-masked]
> > > Subject:      Re: Draft on Advice for Internet Subnetwork Designers
> > >
> > > >On the topic of packet discard especially on those subnet where
> capacity
> > > is
> > > >expensive or limited I would add that when possible packets marked form
> > > >another subnet should be discarded before transmission on the link.
> > >
> > > Is this an issue for the subnetwork designer, or for the router that
> > > drives the subnetwork?
> > >
> > > Phil
> 
> --
> ________________________________________________________________________
> Grenville Armitage                            http://mh005.infi.net/~gja
> Bell Labs Research Silicon Valley

-- 
________________________________________________________________________
Grenville Armitage                            http://mh005.infi.net/~gja
Bell Labs Research Silicon Valley

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Thu, 9 Mar 2000 09:35:06 -0800

Marie-Jose

-----Original Message-----
From: Grenville Armitage [mailto:[email-masked]]
Sent: Thursday, March 09, 2000 9:41 AM
To: Marie-Jose Montpetit
Cc: [email-masked]'; [email-masked]
Subject: Re: Draft on Advice for Internet Subnetwork Designers

marie-jose,

cheers,
gja

capacity