Subject: Re: LINK discussion of RED

From: Marie-Jose Montpetit <[email-masked]>
Date: Sat, 7 Jul 2001 11:39:21 -0500

Are we implying that we actually recommend RED? I think the priciples of RED are good but in actual implementations you cannot use RED for many reasons I supose the most common one being that exponentials are hard to implement in hardware... Hence the variants. I think the draft should state that RED-like is way more appropriate than queue drop when you consider that more than one flow are sharing a queue in terms of fairness. You can explain the "classical RED" though as an example.

Marie-Jose
> 
> From: Phil Karn <[email-masked]>
> Date: Fri, 6 Jul 2001 19:03:10 -0700 (PDT)
> To: [email-masked]
> Subject: LINK discussion of RED
> 
> LINK currently has this text:
> 
>    One well known example of an active queue management the Random Early
>    Detection (RED) algorithm [RED93].  RED maintains an exponential
>    weighted moving average of the queue depth.  When this average queue
>    depth is between a maximum threshold max_th, and a minimum threshold
>    min_th, packets are dropped with a probability which is proportional
>    to the amount by which the average queue depth exceeds min_th.  When
>    this average queue depth is equal to max_th, the drop probability is
>    equal to a configurable parameter max_p.  When this average queue
>    depth is greater than max_th, packets are always dropped.  Numerous
>    variants on RED appear in the literature, and there are other active
>    queue management algorithms which claim advantages over RED in
>    various dimensions.
> 
> This implies that the packet dropping probability has a discontinuity
> at an average queue depth of max_th, where it jumps from max_p just
> below max_th to unity just above. Is this correct?
> 
> Phil
> 
>

---

From: Dan Grossman <[email-masked]>
Date: Mon, 09 Jul 2001 14:16:22 -0400

> Are we implying that we actually recommend RED? 
No, the recommendation (three paragraphs below) is that 
   "it may be advisable for
   subnets  that perform queuing and discarding to consider implementing
   some form of active queue management".  

Could be RED, could be some variant, could be BLUE, could be something 
completely different.  In fact, I agree that there are more implementation 
friendly ways to do active queue management, and this is a fertile field for 
research.  Thus, the permissive wording.