Subject: RE: [pilc] RE: Link-layer Triggers Protocol draft

From: Ali Mohammed-MALI1 <[email-masked]>
Date: Fri, 5 Jul 2002 12:34:15 -0500

Hi Alper, 
                Thanks for the explanation. Just another query.

 > It's not different, really. A L2-triggers server always provides the L2 address
 > of the remote end point when a link goes up or down. That means, the mobile
 > host will learn the L2 address of the access point (i.e., the remote end of mobile
 > host's wireless link), and the access router will learn the L2 address of the
 > access device of the mobile node (i.e., the remote end of the access point's
 > wireless link) when the wireless link goes down. 

 > In this above scenario, host will be notified about MAC2,
 > as this is the remote end point's L2 address from access
 > device's perspective. Access router will be notified about MAC1, 
 > as this is the remote end point's L2 address from 
 > access point's perspective.

I understand this protocol. I guess i am a little confused because i am trying to relate this to the RAN.  I understand that there is one-one correspondance with access point ( bridge) and access router. I can see how this setup can work in a wireless LAN network but coming back to the RAN, the access point bridge equivalent  would probably be RNC or some central controller servicing multiple access routers so the one to one relationship between access router, access point(bridge) is not valid anymore. In this case if several client access routers are registered with the same access point server the triggers will be notified to all the client access routers. Wouldn't this lead to confusion? How would the protocol address this issue. For eg, the server receives a link-up trigger for a access device but this information would be sent to multiple access router cleints, so which access router actually should consume the trigger?

Thanks,
 
Mohammed 

 
> 
> 
> Mohammed 
> 
> **********************Confidentiality Note**********************
> Privileged/Confidential Information may be contained in this e-mail and any
> attachment to it and may be covered by existing non-disclosure or
> confidentiality agreements.
> If you are not the addressee (or authorized to receive for the addressee),
> you may not use, copy or disclose to anyone any information contained in
> this e-mail.  If you have received this e-mail in error, please notify the
> sender immediately by reply e-mail and delete it from your system.
> Thank you very much.
>

---

From: "Alper E. YEGIN" <[email-masked]>
Date: Fri, 5 Jul 2002 13:39:02 -0700

Actually this protocol handles many-to-many relation.
A client (e.g., access router) can register with several servers
(e.g., access points). And similarly a server can have
several clients registered at the same time.

When a L2 event takes place, all the registered clients
are notified by the server. What happens if more than
one client gets notified about the same L2 event really
depends on the choice of actions... 

I can give one example. If a link-up trigger is used to
send an unsolicited router advertisement on the access
routers, all of the receivers of the same link-up event
can send their own router advertisements. This is akin
to all of them receiving a multicast router solicitation and
responding...

But if the action is different, such as something that requires
only one access router to handle, then either only one access
router should register with a given access point, or there should
be some other component to sort this out (i.e., to arbitrate)... 
But this is outside the scope of this work... The consumer of
this protocol needs to decide on how to use it...

alper

  ----- Original Message ----- 
  From: Ali Mohammed-MALI1 
  To: 'Alper E. YEGIN' ; [email-masked] 
  Sent: Friday, July 05, 2002 10:34 AM
  Subject: RE: [pilc] RE: Link-layer Triggers Protocol draft

  Hi Alper, 

    Thanks,
     
    Mohammed