Subject: RE: [pilc] Real time applications on LTNs or 2.5/3G networks

From: Ali Mohammed-MALI1 <[email-masked]>
Date: Fri, 12 Jul 2002 12:30:59 -0500

Hello Ruud,

 I will only speak for SCTP. It is available for Linux and FreeBSD platform. I am pretty sure there is a version for Solaris. Also, i agree that there can be signifcant improvement in application performance by notification from lower layers. The SCTP stack should provide you better hints about the state of the link, delay etc also you could have direct notifications from Layer2 to the application ( callbacks) to take proactive measures.

Mohammed  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, July 12, 2002 9:24 AM
To: [email-masked]; [email-masked]
Subject: RE: [pilc] Real time applications on LTNs or 2.5/3G networks

Hello Phil,

Thanks for the pointer to sctp. At first glance it looks interesting so I
should take some look at it as well.

However for the intend I have with a paper it is probably not the most
usefull now.

My intend with the paper is first to support application developers in
creating applications that work well over GPRS (KPN is a mobile operator and
we would love a lot of fine applications ), second some of the conclusions
may be important for adding additional hooks between the application and the
TCP stack (e.g. ioctl for reading current delay estimates and cwindows to
adjust application layer times), third actualy write some possibilities on
tailering for example Nagle or Limited Transmit to be even more aggressive.

The problem with sctp is that on the short term it is not widely available
for most platforms (or will it?). This makes it not an option for my primary
goal.

As you will know IT Economics is a bit down at the moment, so my time effort
in investigating realy new things will be rather low. My knowledge is mostly
built on practical experience doing measurements on GPRS and RT
Applications.

Best regards,

Ruud Schramp

> -----Original Message-----
> From: Phil Neumiller [mailto:[email-masked]]
> Sent: vrijdag 12 juli 2002 16:02
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [pilc] Real time applications on LTNs or 2.5/3G networks
> 
> 
> Hello Ruud,
> 
> I have one request for your study.  Please also investigate 
> SCTP's use in wireless.  SCTP is 
> defined in RFC2960 also see http://www.sctp.org/.  There is 
> not much (if anything) published
> on this currently, and if you are conducting some 
> experiments, it would be very interesting to
> compare SCTP with TCP in your experiments.
> 
> SCTP originated at Motorola and was subsequently heavily 
> modified and improved in the 
> IETF transport area.  In our lab work at Mot we found it to 
> be quite useful for wireless links 
> as well, although that aspect has not been widely publicized. 
>  In particular, the multi-homing
> feature can be used for path/route diversity in cellular and 
> ad hoc networks.
> 
> Also, w/respect to TCP and wireless, there are several 
> excellent papers that describe the
> downfalls.  Randy Katz's work at U.C. Berkley is particularly 
> interesting.
> 
> Best regards,
> 
> Phil Neumiller

_______________________________________________
pilc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pilc
http://www.ietf.org/html.charters/pilc-charter.html
http://pilc.grc.nasa.gov/

_______________________________________________
pilc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pilc
http://www.ietf.org/html.charters/pilc-charter.html
http://pilc.grc.nasa.gov/

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 12 Jul 2002 14:56:05 -0700 (PDT)

Hello Mohammed,
  Direct notifications from layer 2 for SCTP is kind
of layer violation. 
  My question is this a feature defined in SCTP RFC or
something that SCTP implementations you cited have?

Regards,
--- Ali Mohammed-MALI1 <[email-masked]> wrote:
> Hello Ruud,
> 
>  I will only speak for SCTP. It is available for
> Linux and FreeBSD platform. I am pretty sure there
> is a version for Solaris. Also, i agree that there
> can be signifcant improvement in application
> performance by notification from lower layers. The
> SCTP stack should provide you better hints about the
> state of the link, delay etc also you could have
> direct notifications from Layer2 to the application
> ( callbacks) to take proactive measures.
> 
> Mohammed  
>  
> 
> 
--behcet

__________________________________________________
Do You Yahoo!?
Sign up for SBC Yahoo! Dial - First Month Free
http://sbc.yahoo.com