Subject: Re: parallel p2p links

From: Liming Wei <[email-masked]>
Date: Mon, 2 Nov 1998 18:05:07 -0800 (PST)

Yes, it is in section 5.2.2:

  Prunes  may  be  rate-limited  on  point-to-point  interfaces  when  a
  multicast datagram is received for a negative cache entry, or if the
  incoming point-to-point interface is not the RPF interface toward the
  source.

-Liming

> At 12:44 PM -0800 10/19/98, Tom Pusateri wrote:
> > By the way, I'm thinking of PIM dense mode here.
> > Sparse mode should be able to handle this ok.
> >
> > Thanks,
> > Tom
> >
> > In message <[email-masked]> you write:
> > >If a router has parallel p2p links to another router, the upstream
> > >router will forward multicast data over both links. The downstream
> > >interface will do an RPF check and only one path will be selected.
> > >This path can be pruned but the other path will fail the RPF
> > >check. Sending a prune here doesn't make sense since it isn't
> > >upstream. And sending an assert doesn't make sense either. Therefore,
> > >you can never prune back the source.
> > >
> > >1. Is there any option aside from the obvious one of not allowing
> > >   parallel p2p links.
> > >
> > >2. Can this be addressed in the spec, please? It may be there but
> > >   I couldn't find it.
> > >
> > >Thanks,
> > >Tom
> 
> 
> 
>

---

From: [email-masked] (Ravi Shekhar)
Date: Tue, 3 Nov 1998 11:19:47 -0500 (EST)

Hi Liming,

>  incoming point-to-point interface is not the RPF interface toward the

    Is there a new draft out? 

    The latest one I could find is
        draft-ietf-pim-v2-dm-00.txt 
    and I couldnt find the the last part of the last line in it.

    Thanks
     - Ravi Shekhar.

---

From: Liming Wei <[email-masked]>
Date: Tue, 3 Nov 1998 17:27:34 -0800 (PST)

> From: [email-masked] (Ravi Shekhar)
> 
> Hi Liming,
> 
> 

You are right. I'm looking at a revised draft. I expect to clear
up issues with other co-authors and submit it soon. All minor
fixes/updates.

-Liming

---

From: Tom Pusateri <[email-masked]>
Date: Wed, 04 Nov 1998 01:03:29 -0500

You shouldn't be sending prunes if the incoming p2p interface
is not the RPF interface.

Tom