Subject: RE: Using Asserts to remove redundant P2P links in PIM-DM

From: vishwas <[email-masked]>
Date: Wed, 18 Nov 98 15:21:00 PST

> 1) Use Prune messages to remove links from the RPF DAG to build the
> broadcast tree.  Since Prune messages aren't sufficient on multi-access
> LANs, design the ugly Assert mechanism to handle multi-access LANs.
> Use Prune messages to remove links from the broadcast tree.
>
> Advantages:
> - Prune messages are shorter
> - This is what's currently implemented
>
> Disadvantages:
> - Prune messages have two purposes, one of which duplicates the purpose
>   of Assert messages

Not sure what two purposes you are referring to.

The current spec clearly specifies that assert messages are only sent
on multi access LANs and not on point-to-point links.

[vishu]

Back to Basics, I think we had a recent discussion with the thread,   
"Prune Assert Winner", that there may be cases where it will "TRIGGER" an   
assert to be sent on P2P interface. I even said that, Assert Looser has   
to send a prune to the assert Winner in a special case of P2P links.   
Otherwise there is now way we can block unwanted traffic on a P2P link.

I'll TRY TO EXPLAIN THE PROBLEM ONCE AGAIN, with the good old figure...!!

                                O S
                  ________ |____________
                      |                   |
                R1 O                  O R2
                      |               __ |______
                    P2P                      |
                      |______________O R3
                                          ___ |_______
                                                      |
                                               O H
R2-R3 Subnet
 --------------------
R2 - 10.0.0.3
R3 - 10.0.0.4

R1-R3 Subnet
 -------------------
R1 - 10.0.0.1
R3 - 10.0.0.2

Consider initially, R1 is down and P2P link is also down. So, for R3, R2   
is the upstream.
Now, when R1 comes UP, R1, R2 and R3 will discover each other and R1 and   
R3 will have P2P link as their outgoing interfaces.
R1 will now start forwarding duplicate traffic on P2P link which has to   
be blocked by R3.
BUT ACCORDING TO THE PROTOCOL (SEE ABOVE and section 5.5 2nd pyra, 1st   
line)
We cant send an assert on an outgoing interface if it is a P2P link,   
though, an Assert gets TRIGGERED here.

BUT HOW DO U STOP THIS GUY R1 from sending traffic on to P2P link..?
So, I said  Asserts are required on P2P links, and......"PRUNE SHOULD or   
MAY be sent by the the Assert looser to the assert Winner", which was   
argued by Helmy, "As there may be lots of loosers and one winner, this   
may not scale" Which I agree..

BUT I DONT AGREE TO THE STATEMENT ABOVE.

Pl. Cross check once again..!!

 -vishu

---

From: Bill Fenner <[email-masked]>
Date: Wed, 18 Nov 1998 08:54:07 PST

>BUT HOW DO U STOP THIS GUY R1 from sending traffic on to P2P link..?

Section 5.2 says that you may send prunes when receiving a datagram
on a P2P interface which is not the RPF interface.  So R3 may send
a prune to R1.  R1 may also have to send a prune to R3.

(Hmm, there's another minor advantage of using Asserts: may only
require one message to resolve when 2 prunes may be required.)

  Bill

---

From: [email-masked] (Ravi Shekhar)
Date: Wed, 18 Nov 1998 13:43:33 -0500 (EST)

>require one message to resolve when 2 prunes may be required.)

        I thought so too. But then backed off becuase current draft requires 
        winner to send another assert after winning. So it is at least 2
        messages...

        - Ravi Shekhar.