Subject: IGMPv2 and PIM-SM

From: "Sudhir Cheruathur" <[email-masked]>
Date: Wed, 28 Jul 1999 01:42:48 -0000

Hi,

A few questions on the interaction between IGMP and PIM-SM.

When a (*,G) state is created upon receiving an IGMP member report the oif timer is set
to the default Join-Prune holdtime of the interface. Is this correct ?

Another related question, Section 3.2.1.2 Triggered Join/Prune Messages.
1. Receipt of an indication from IGMP......
      .....................
      .....................
    When IGMP indicates that there are no longer directly connected members, the oif is
     removed from the oif list if the oif timer is not running.

     Why do we have check if the timer is running? Is it to cater to the IGMPV2 process of 
      group-specific queries when a leave has been sent ?  
     
Also when  IGMP membership expires shouldn't the oif be removed from all the (S,G) entries as well ?

Thank you,

Regds
Sudhir

---

From: Desikan Saravanan <[email-masked]>
Date: Wed, 28 Jul 1999 10:05:39 -0700

-----Original Message-----
From: Sudhir Cheruathur [mailto:[email-masked]]
Sent: Tuesday, July 27, 1999 6:43 PM
To: [email-masked]
Subject: IGMPv2 and PIM-SM

Hi,

When a (*,G) state is created upon receiving an IGMP member report the oif
timer is set
to the default Join-Prune holdtime of the interface. Is this correct ?
[Des >] I dont think so. Then what to do when the oif timer expires - check
the IGMP
membership everytime the oif timer expires. I guess this can be avoided
without associating oif timer
running for a IGMP join report.
 
Another related question, Section 3.2.1.2 Triggered Join/Prune Messages.
1. Receipt of an indication from IGMP......
      .....................
      .....................
    When IGMP indicates that there are no longer directly connected members,
the oif is
     removed from the oif list if the oif timer is not running.
 
     Why do we have check if the timer is running? Is it to cater to the
IGMPV2 process of 
      group-specific queries when a leave has been sent ?  
[Des >] This means if there are other any other join messages causing the
oif timer to run, 
the oif should not be removed since it is required by downstreams.  
     
Also when  IGMP membership expires shouldn't the oif be removed from all the
(S,G) entries as well ?
[Des >] Yes. 

Thank you,
 
Regds
Sudhir

---

From: Bill Fenner <[email-masked]>
Date: Wed, 28 Jul 1999 10:45:00 -0700

You have to consider both downstream neighbors and group members for which
you're the DR.  If you're too aggressive about removing an oif because
IGMP says there are no more group members, then you can cause blackholes
downstream if the link was also being used as transit.  This is why you
also check the oif timer, to see if there was a join from downstream.

So, my reading is that the oif timer is used to track downstream Joins
and so must not be set based upon reception of a membership notification
from IGMP.

  Bill