Subject: Re: PIM DR Priority & PIM packet size

From: [email-masked] (Billy Ng)
Date: Fri, 20 Aug 1999 16:30:29 -0400

> From [email-masked] Fri Aug 20 13:40:12 1999
> 
> "Mohit Talwar (Exchange)" writes:
> 
> | Hi All,
> | 
> | 1. I have seen the DR Priority option being mentioned.
> |    Has it been discussed in any document?
> 
> It was mentioned in draft-ietf-idmr-pimv2-dr-priority-00.txt. But
> the draft is expired. I don't know the latest status. Dino or Liming
> can comment about it.
> 
> | 2. Is the maximum size of a PIM packet limited only by
> |    the IP packet size or are there any other restrictions 
> |    too?
> 
> I don't think there are any other restrictions.
> 
> Ravi
> 

I see one possible problem with big PIM join/prune packets across a single
group.

Basically the problem is that if there is a large number of sources
for one group and the join/prune message cannot fit in one packet,
the packet needs to be splitted.  The problem came with the second
refresh of these fragmented packets because the first packet will
graft any (s,g)s that are not yet received with this first fragment
having a (*,g) entry.  The spec should spell out the steps to avoid
this problem.

A fragment tag on the join/prune packet might help.

--Billy

---

From: [email-masked] (Billy Ng)
Date: Fri, 20 Aug 1999 16:30:29 -0400

> From [email-masked] Fri Aug 20 13:40:12 1999
snip, snip... 

--Billy

----- End Included Message -----