Subject: creating of (*,G) entry on SP-tree

From: Masaaki Tsukioka <[email-masked]>
Date: Thu, 20 Jan 2000 17:54:42 +0900

Hello,

I am studying and have a basic question about the specificaton 
of PIM-SM.

Suppose a router (say router A) exist in the path upstream 
from the RP to the sender and it has (S,G) entry only, because 
the RP has joined to the sender and there is no receiver 
downstream from router A. The (S,G) entry at router A has been
set SPT-bit flag already.

If a new receiver joins to router A for the multicast group G, 
(*,G) entry will be created at router A. I am wondering, which
state will exceed at this moment on router A, (*,G) or (S,G) ?
If I am incorrect, How the entries will be set?

I read RFC2362, but I couldn't find how it works.

Thanks.
--Masaaki

---

From: Renu Agarwal <[email-masked]>
Date: Thu, 20 Jan 2000 15:36:43 +0530

Hello Masaaki,

As I understand, the topology is like this:

	 S----DR----B----A---RP

And RP has joined the to S directly because of which a (S,G) gets
created in the router A. The router A has no other downstream receivers
except RP. Now there can be two cases at A:

1. A local host on A joins the group
2. Another downstream router say C sends a (*,G) join prune message to
A.

Case 1: In this case, the router A shall receive the IGMP join trigger.
The router shall add the (*,G) entry in its routing table with outgoing
interface as the new interface on which IGMP request was received.

In addition, it shall also add the new interface as the oif into the
existing (S,G) entry.

The router A shall use the (S,G) entry to forward the data from S while
the (*,G) entry shall be used to forward data from any other sources
except S.

The router shall also send the join-prune message to RP with (*,G) and
Prune source as S.
   
Case 2: In this case also, the processing shall be same except that the
input trigger received will be a join-prune message.

Hope I am able to clear your doubt,

Regards,
Renu

---

From: Masaaki Tsukioka <[email-masked]>
Date: Fri, 21 Jan 2000 09:33:40 +0900

Hi Renu

Thanks for the answer :)

I asked the question because I was not sure how a router would 
create (*,G) state after (S,G) state. But now I figure it works 
normally.

Thanks,
--Masaaki

> Hope I am able to clear your doubt,

-- -- -- -- -- -- -- -- -- --
(株)日本ネットシステム              外線 TEL: (03)5476-1071
    月岡 正明(つきおか まさあき)    内線 TEL: 8-20-24879
                                    E-Mail: [email-masked]