Subject: Sparse mode

From: Desikan Saravanan <[email-masked]>
Date: Fri, 4 Feb 2000 14:59:04 -0800

Hi

I have a question about the SM behavior.

Conside the following topology.

                          Sender
                              |
Receiver --- A -------- B -------- C -------- RP
                  |                                    |
                   ------------------------------------

At first A sends (*,g) join to RP and RP sends decapsulated packets to A.
RP first decides to join SPT and sends join upstream.
So C has only an (s,g) entry.

After sometime,  A decides to join SPT and does.
Since A joins SPT, A then sends (s,g) rpt prune to RP.
so, RP prunes the interface towards A from its (s,g) entry.
so, its (s,g) has no outgoing interfaces and it now sends (s,g) prune
upstream.

C has now an (s, g) entry with one interface in pruned list and no interface
in outgoing interface list.
As no data packets come from B to C because of (s, g) prune,
C's (s,g) entry timer will not refreshed by anything and eventually goes
off.

I was wondering is it a correct behaviour for C?
If so, how come a new member joins from another interface to C gets the data
packets?
ie.
                          Sender    new member
                              |           |
Receiver --- A -------- B -------- C -------- RP
                  |                                    |
                   ------------------------------------ 

I would appreciate your help in understanding the protocol behaviour.

Thanks
Des

---

From: Isidor Kouvelas <[email-masked]>
Date: Fri, 04 Feb 2000 16:07:06 -0800

Desikan,

The current version of the PIM spec does not describe the turnaround
rules which are necessary to make RP-on-a-stick scenarios (like the one
you describe) work. For a list of problems with the current spec please
look at http://www.aciri.org/fenner/mcast/pim/sm/issues.html

thanks
Isidor