Subject: Selection of Incoming Interface in PIM DM.

From: "Jayaraman, Rajagopal" <[email-masked]>
Date: Fri, 22 Sep 2000 14:03:22 -0400

Hi all,

We have the following question.  When selecting the incoming interface for
recording the (S G o i) entry on receiving
a mcast data packet, the spec says to use RPF on the unicast routing table
to figure out the incoming interface for S.  However
what if we have two paths between the two multicast routers R1 and R2 and
the shortest path does not support multicast?
In this case the incoming interface that we record in our table will not be
multicast enabled. How is this situation supposed to
be handled?  Apologies if this has been thrashed out before....:-)

Thanks,

Raj ([email-masked])
Subuddh ([email-masked])

---

From: "Parekh, Subuddh" <[email-masked]>
Date: Fri, 22 Sep 2000 21:17:10 -0400

> -----Original Message-----
> From: Jayaraman, Rajagopal [mailto:[email-masked]]
> Sent: Friday, September 22, 2000 2:03 PM
> To: [email-masked]'
> Subject: Selection of Incoming Interface in PIM DM.
> 
> 
> 
> Hi all,
> 

Seems like there are a bunch of ways to solve the problem.  Is the solution
of creating
a multicast view of the routing table something very standard?  The
unicast routing protocol would have to be modified to maintain two trees and
update two tables, one unicast topology and one multicast one. 
Is there any move to address this issue in the spec and specify a particular

behavior?

Thanks,

Subuddh
([email-masked])

---------------------------------------------------------------------------
As long as you can guarantee that chosing the "multicast capable"
next-hops wont form a loop, you should be fine. That is to say
that you should have a "multicast view" of your unicast (or rpf-check)
routing table which is built by considering only the multicast running 
interfaces/links of the routers and do not create a loop.

---

From: "Jayaraman, Rajagopal" <[email-masked]>
Date: Tue, 26 Sep 2000 14:28:25 -0400

In my case, I am running OSPF over
two interfaces, one being the shortest
path to the source and other being the
secondary path.

Now my UCAST route table contains one
route (shortest) to the source, but
this is over a non-mcast iface.

Secondary path is an mcast iface with
PIM running over it.

I don't have DVMRP/MOSPF/MBGP protocols present.

What could be the solution for this scenario?

Raj Jayaram.

-----Original Message-----
From: Hal Sandick [mailto:[email-masked]]
Sent: Tuesday, September 26, 2000 7:10 AM
To: Bill Fenner
Cc: Jayaraman, Rajagopal; [email-masked]
Subject: Re: Selection of Incoming Interface in PIM DM.

Bill,

It' been a while since I worked with MOSPF, but I as I remebmer it allows
links and routers to be marked multicast capable and this is considered
during tree calculation.

Regards,

Hal

Bill Fenner wrote:

> If you have incongruent unicast and multicast topologies, you have to run
> an IGP for each and use only the routes learned by the multicast-aware
> IGP.  For example, Cisco IOS allows you to run DVMRP to learn the
> multicast topology.  (I think that IGPs that support multiple metrics
> could support carrying both a unicast and multicast table in one IGP,
> similar to MBGP, but as far as I know this has never been developed.)
>
>   Bill