Subject: Questions about draft-ietf-pim-sm-v2-new-02

From: Masaaki Tsukioka <[email-masked]>
Date: Mon, 26 Mar 2001 09:32:22 +0900

Hello.

My colleague read draft-ietf-pim-sm-v2-new-02.ps and found some 
inconsistencies in explanation of state-machies.

Would anyone mind answering her questions?

--
1)
In Upstream (*,G) state-machine in section 4.4.6, 
"RPF'(*,G) changes" event from Joind state is not in Figure 7, 
which is in the table and text.  Is this event valid? 

2)
In Upstream (S,G) state-machine in section 4.4.7,
"RPF'(S,G) changes" event from Joined state is not in Figure 8 and the table,
which is in text.  Is this event valid? 

The text says "The current net(next?) hop towards the RP changes 
due an Assert(S,G)on the RPF_interface(S)." but
RPF'(S,G) is the current next hop toward the S, isn't it?

3)
In (S,G) Assert state-machine in section 4.5.1,
there is "Receive Inferior Assert with RPTbit cleared and 
CouldAssert (S,G,I) == TRUE" event from NoInfo state, but the condition 
"and CouldAssert (S,G,I) == TRUE" is missing in text.  
Is this condition needed? 

4)
In (S,G) Assert state-machine in section 4.5.1 again,
"Receive Assert from Current Winner" event from Looser state is not in text,
which is in Figure 10 and the table.  Is this event valid? 

5)
In (*,G) Assert state-machine in section 4.5.2,
there is "Receive Inferior Assert with RPTbit set and 
CouldAssert (*,G,I) == TRUE" event from NoInfo state, but the condition 
"and CouldAssert (*,G,I) == TRUE" is missing in the table.  
Is this condition needed? 

6)
In (*,G) Assert state-machine in section 4.5.2 again,
"Receive Assert from Current Winner with RPT bit set" event from Looser
state is not in the table and text, which is in Figure 11.
Is this event valid? 

Thanks in advance.

--
Masaaki Tsukioka

---

From: Isidor Kouvelas <[email-masked]>
Date: Tue, 27 Mar 2001 10:15:33 -0800

Thank you for your comments. We will go through them and incoroporate
them on our next revision of the spec.

I