Subject: RE: Encapsulation of packets from non-directly connected hosts in PIM-SM

From: Jung Cyndi-ACJ099 <[email-masked]>
Date: Thu, 17 May 2001 18:22:43 -0500

I have the same question, though in the context that
the non-PIM domain is an IGMP-only environment with
multicst supported using IGMP Proxy methods.  There is 
a new IDMR draft specifying the behavior of an IGMP proxy 
(draft-ietf-idmr-igmp-proxy-00.txt), and it says that
the IGMP-proxy environment is assumed to be connected to
a larger multicast infrastructure.  Receivers in this 
IGMP-only section of the network can receive the multicast
with no problem, but a sender's data would not make it
past the first PIM router, since the source address of the
packet would not be from a directly connected subnet. Is it
expected that the proxy modify the source address in the 
IP header?  If the IGMP-only environment is deep, each proxy
must replace the source IP with it's own when forwarding 
"upstream" - I think this would not be a good solution,
though it would work for simple data.  Is it the PIM router 
that makes special accomodations for interfaces it knows 
are attaching these IGMP-only environments?

Cyndi

-----Original Message-----
From: Narayanan Vidya-CVN065
[mailto:[email-masked]]
Sent: Thursday, May 17, 2001 11:33 PM
To: 'pim'
Subject: Encapsulation of packets from non-directly connected hosts in
PIM-SM

All,
I was trying to better understand the motivation behind only allowing encapsulation of packets from directly connected hosts. Are there reasons other than security concerns for making this restriction? The new revised draft seem to state this in section 4.3.1. Is this the correct interpretation, or am I mis-reading the draft? 

I guess my point is that if there is a non-PIM capable router directly connected to the sender, and if the packets are being sent into a PIM domain, does it (the first router running PIM in the path of the multicast flow) now not have to encapsulate the packets? Specifying that register state must only be maintained for directly connected hosts makes it seem like restricting such a design. 

Comments? 

Thanks,
Vidya

---

From: muthireddy ramakoteswararao <[email-masked]>
Date: Thu, 17 May 2001 16:37:14 -0700 (PDT)

The IGMP-Proxy should change the IP address to it's
interface address, because it may have to represent
many interfaces fro the same group. 

Thanks,
-Ramko. 
--- Jung Cyndi-ACJ099 <[email-masked]> wrote:
> I was trying to better understand the motivation
> behind only allowing encapsulation of packets from
> directly connected hosts. Are there reasons other
> than security concerns for making this restriction?
> The new revised draft seem to state this in section
> 4.3.1. Is this the correct interpretation, or am I
> mis-reading the draft? 
> 
> I guess my point is that if there is a non-PIM
> capable router directly connected to the sender, and
> if the packets are being sent into a PIM domain,
> does it (the first router running PIM in the path of
> the multicast flow) now not have to encapsulate the
> packets? Specifying that register state must only be
> maintained for directly connected hosts makes it
> seem like restricting such a design. 
> 
> Comments? 
> 
> Thanks,
> Vidya

__________________________________________________
Do You Yahoo!?
Yahoo! Auctions - buy the things you want at great prices
http://auctions.yahoo.com/