Subject: Encapsulation of packets from non-directly connected hosts in PIM -SM

From: Narayanan Vidya-CVN065 <[email-masked]>
Date: Thu, 17 May 2001 17:33:23 -0500

All,
I was trying to better understand the motivation behind only allowing encapsulation of packets from directly connected hosts. Are there reasons other than security concerns for making this restriction? The new revised draft seem to state this in section 4.3.1. Is this the correct interpretation, or am I mis-reading the draft? 

I guess my point is that if there is a non-PIM capable router directly connected to the sender, and if the packets are being sent into a PIM domain, does it (the first router running PIM in the path of the multicast flow) now not have to encapsulate the packets? Specifying that register state must only be maintained for directly connected hosts makes it seem like restricting such a design. 

Comments? 

Thanks,
Vidya

---

From: muthireddy ramakoteswararao <[email-masked]>
Date: Thu, 17 May 2001 16:08:09 -0700 (PDT)

Hi,
 At present the non-PIM capable router must use a IGMP
proxy mechanism, by which it requests the groups on
the interface, which is connected to the PIM router. 
Once the data packet comes to proxy, it again forwards
the packet depending on the Forwarding table it
maintains internally.

 Thanks,
 -Ramko.    
--- Narayanan Vidya-CVN065 <[email-masked]>
wrote:
> All,
> I was trying to better understand the motivation
> behind only allowing encapsulation of packets from
> directly connected hosts. Are there reasons other
> than security concerns for making this restriction?
> The new revised draft seem to state this in section
> 4.3.1. Is this the correct interpretation, or am I
> mis-reading the draft? 
> 
> I guess my point is that if there is a non-PIM
> capable router directly connected to the sender, and
> if the packets are being sent into a PIM domain,
> does it (the first router running PIM in the path of
> the multicast flow) now not have to encapsulate the
> packets? Specifying that register state must only be
> maintained for directly connected hosts makes it
> seem like restricting such a design. 
> 
> Comments? 
> 
> Thanks,
> Vidya

__________________________________________________
Do You Yahoo!?
Yahoo! Auctions - buy the things you want at great prices
http://auctions.yahoo.com/