Subject: Re: PIM-SM assert macros

From: chennu krishna <[email-masked]>
Date: Sat, 19 May 2001 10:49:10 -0700 (PDT)

Will this be included in the next revision of the
draft?

         Thanks,
         chennu

The default value of "AssertWinner(*,G,I )" should be
"me" inorder to make the inheritedlist non-null. We
can check this when only one PIM router present in the
LAN. I feel using "lost_assert(*,G,I)" instead of
"AssertWinner(*,G,I )" would be appropriate. Clarify
me if i am wrong.

 Krishna.  

__________________________________________________
Do You Yahoo!?
Yahoo! Auctions - buy the things you want at great prices
http://auctions.yahoo.com/

---

From: Isidor Kouvelas <[email-masked]>
Date: Sat, 19 May 2001 11:45:53 -0700

We fixed this by making the default value empty and fixing the macro
below:

  bool lost_assert(S,G,I) {
    if ( RPF_interface(S) == I ) {
       return FALSE
    } else {
       return ( AssertWinner(S,G,I) != NULL AND 
                AssertWinner(S,G,I) != me  AND 
                (AssertWinnerMetric(S,G,I) is better 
                   than spt_assert_metric(S,G,I) )
    }
  }

thanks
I

---

From: krishna bellamkonda <[email-masked]>
Date: Sat, 19 May 2001 12:03:14 -0700 (PDT)

Hi,
 Actually have mentioned about "lost_assert(*,G,I)",
in my previous mail. Can you give me corrected
"lost_assert(*,G,I)", as default values are not
specified for this macro.

  Krishna.

---

From: Isidor Kouvelas <[email-masked]>
Date: Sat, 19 May 2001 13:44:03 -0700

bool lost_assert(*,G,I) {
    if ( RPF_interface(RP) == I ) {
       return FALSE
    } else {
       return ( AssertWinner(*,G,I) != NULL AND 
                AssertWinner(*,G,I) != me )
    }
}

---

From: chennu krishna <[email-masked]>
Date: Sat, 19 May 2001 16:15:41 -0700 (PDT)

Thanks for yourclarification. I hope, similarly
"lost_assert(S,G,rpt,I)" has been fixed to 

  bool lost_assert(S,G,rpt,I) {
    if ( RPF_interface(RP) == I  OR
         ( RPF_interface(S) == I AND
          SPTbit(S,G) == TRUE ) ) {
       return FALSE 
    } else {    
      return (AssertWinner(S,G,I) != NULL AND
              AssertWinner(S,G,I) != me) 
    }           
  }                                                   

          Thanks,
          chennu.
--- Isidor Kouvelas <[email-masked]> wrote:
> >> We fixed this by making the default value empty
> and
> >> fixing the macro
> >> below:
> >> 
> >> >The default value of "AssertWinner(*,G,I )"
> should
> >> be
> >> >can check this when only one PIM router present
> in
> >> the
> >> >Yahoo! Auctions - buy the things you want at
> great
> >> prices