Subject: RE: Encapsulation of packets from non-directly connected hosts in PIM-SM

From: Jung Cyndi-ACJ099 <[email-masked]>
Date: Thu, 17 May 2001 20:04:26 -0500

It certainly changes the source IP address of the IGMP
packet to it's own, but it seems there could be
application level problems (similar to NAT) if it
changes the source IP of the multicast data packets.

Cyndi

-----Original Message-----
From: muthireddy ramakoteswararao [mailto:[email-masked]]
Sent: Friday, May 18, 2001 12:37 AM
To: Jung Cyndi-ACJ099; Narayanan Vidya-CVN065; 'pim'
Subject: RE: Encapsulation of packets from non-directly connected hosts
in PIM-SM

The IGMP-Proxy should change the IP address to it's
interface address, because it may have to represent
many interfaces fro the same group. 

Thanks,
-Ramko. 
--- Jung Cyndi-ACJ099 <[email-masked]> wrote:
> I have the same question, though in the context that
> the non-PIM domain is an IGMP-only environment with
> multicst supported using IGMP Proxy methods.  There
> is 
> a new IDMR draft specifying the behavior of an IGMP
> proxy 
> (draft-ietf-idmr-igmp-proxy-00.txt), and it says
> that
> the IGMP-proxy environment is assumed to be
> connected to
> a larger multicast infrastructure.  Receivers in
> this 
> IGMP-only section of the network can receive the
> multicast
> with no problem, but a sender's data would not make
> it
> past the first PIM router, since the source address
> of the
> packet would not be from a directly connected
> subnet. Is it
> expected that the proxy modify the source address in
> the 
> IP header?  If the IGMP-only environment is deep,
> each proxy
> must replace the source IP with it's own when
> forwarding 
> "upstream" - I think this would not be a good
> solution,
> though it would work for simple data.  Is it the PIM
> router 
> that makes special accomodations for interfaces it
> knows 
> are attaching these IGMP-only environments?
> 
> Cyndi
> 
> -----Original Message-----
> From: Narayanan Vidya-CVN065
> [mailto:[email-masked]]
> Sent: Thursday, May 17, 2001 11:33 PM
> To: 'pim'
> Subject: Encapsulation of packets from non-directly
> connected hosts in
> PIM-SM
> 
> 
> All,
> I was trying to better understand the motivation
> behind only allowing encapsulation of packets from
> directly connected hosts. Are there reasons other
> than security concerns for making this restriction?
> The new revised draft seem to state this in section
> 4.3.1. Is this the correct interpretation, or am I
> mis-reading the draft? 
> 
> I guess my point is that if there is a non-PIM
> capable router directly connected to the sender, and
> if the packets are being sent into a PIM domain,
> does it (the first router running PIM in the path of
> the multicast flow) now not have to encapsulate the
> packets? Specifying that register state must only be
> maintained for directly connected hosts makes it
> seem like restricting such a design. 
> 
> Comments? 
> 
> Thanks,
> Vidya

__________________________________________________
Do You Yahoo!?
Yahoo! Auctions - buy the things you want at great prices
http://auctions.yahoo.com/

---

From: Narayanan Vidya-CVN065 <[email-masked]>
Date: Fri, 18 May 2001 11:00:19 -0500

I agree with Cyndi in the case of IGMP Proxy. But, if a router is simply doing IGMP Forwarding, it is not changing any address - it is simply forwarding both the IGMP messages and the multicast data packets. For example, Cisco's implementation of IGMP Forwarding (what they refer to as "stub multicast") does exactly this. However, their PIM routers do encapsulate the packets. From what the standard says now, it might be a violation of the standard. But, that seems like what is needed to allow PIM to interoperate with other non-PIM capable multicast routers. 

-Vidya

> From: Jung Cyndi-ACJ099 [mailto:[email-masked]]
> Sent: Thursday, May 17, 2001 8:04 PM
> To: 'muthireddy ramakoteswararao'; 'pim'