Subject: priority based DR election

From: "K.P.Ramamurthy" <[email-masked]>
Date: Thu, 17 May 2001 10:33:37 +0530

Hi,
     According to the draft  “priority based DR election” is  *only *
enabled when all
neighbors on an interface advertise that they are capable of using the DR
election priority option.
The hello message option type (type 19) is for DR priority, and there is no
exclusive option type
to indicate that the router is capable of priority based DR election (i.e.
dr_priority_present flag ).
Since the default DR priority is 1 (one) does that mean if the DR priority
is set to 0, it would
indicate that the router is not capable of  priority based DR election,
resulting in the election
being based on the IP addresses ?.
                       Is it OK for a neighbor to send a hello message with
DR priority set to ZERO,
if the neighbor wants to indicate that it is not capable of priority based
DR election ?.

                    thanks and best regards
             K.P.Ramamurthy

---

From: Rahul Bahadur <[email-masked]>
Date: Wed, 16 May 2001 23:46:23 -0700 (PDT)

DR priority 0 (zero) is a valid value for the DR priority option. 
The absence of this option in the hello message identifies
PIM neighbors incapable of priority-based DR election. The 
presence of even one such PIM neighbor causes all routers on the LAN
to use IP address as the basis for DR election.

Rahul

---

From: "K.P.Ramamurthy" <[email-masked]>
Date: Thu, 17 May 2001 12:36:32 +0530

Hi Rahul,
         In section 4.6.1 ( Designated routers and hello messages) of the
draft
the following sentence makes me think that the DR priority should be
included
in every hello message, even if no DR priority is explicitly configured for
that
interface. below is the sentence from the draft.

" The DR Election priority option *SHOULD* be included in every hello
message,
 even if no DR election priority is explicitly configured on that interface"

            regards and thanks
                    Ramamurthy

-----Original Message-----
From: Rahul Bahadur [mailto:[email-masked]]
Sent: Thursday, May 17, 2001 12:16 PM
To: K.P.Ramamurthy
Cc: [email-masked]
Subject: Re: priority based DR election

Rahul

On Thu, 17 May 2001, K.P.Ramamurthy wrote:

> Hi,
>      According to the draft  priority based DR election is  *only *
> enabled when all

---

From: Rahul Bahadur <[email-masked]>
Date: Thu, 17 May 2001 00:19:47 -0700 (PDT)

Ramamurthy,

Yes, the DR priority should be included (even if it is not explicitly
configured in which case the value would be the default) if the 
pim implementation is capable of priority-based DR election. 
The absence of this option and subsequent switch to IP address-based DR
election is  important for interoperability with implementations that are 
following an older specification (e.g.draft-ietf-idmr-PIM-SM-spec-11.txt;
09/97).

Rahul

---

From: Sridhar Vallepalli <[email-masked]>
Date: Thu, 17 May 2001 00:34:14 -0700

If it is able to communicate a zero DR priority in hello message, then
it is 
understood that the router is capable of DR priority. The reason for
having
the flag is to be backward compatible with the older implementations of
PIM V2

Thanks
S