Subject: RE: Encapsulation of packets from non-directly connected hosts in PIM -SM

From: "Sridhar Vallepalli" <[email-masked]>
Date: Thu, 17 May 2001 17:19:24 -0700

If it is not restricted to directly connected hosts alone, I don't think
there 
is a way for the PIM router to distinguish between the transit packets and
locally
originated traffic. 

Thanks
S

-----Original Message-----
From: Narayanan Vidya-CVN065 [mailto:[email-masked]]
Sent: Thursday, May 17, 2001 3:33 PM
To: 'pim'
Subject: Encapsulation of packets from non-directly connected hosts in
PIM -SM

All,
I was trying to better understand the motivation behind only allowing
encapsulation of packets from directly connected hosts. Are there reasons
other than security concerns for making this restriction? The new revised
draft seem to state this in section 4.3.1. Is this the correct
interpretation, or am I mis-reading the draft? 

I guess my point is that if there is a non-PIM capable router directly
connected to the sender, and if the packets are being sent into a PIM
domain, does it (the first router running PIM in the path of the multicast
flow) now not have to encapsulate the packets? Specifying that register
state must only be maintained for directly connected hosts makes it seem
like restricting such a design. 

Comments? 

Thanks,
Vidya

---

From: Bill Fenner <[email-masked]>
Date: Thu, 17 May 2001 18:11:20 -0700

"Directly connected" may be too strong a term.  You (and others) are
right that on a border to another domain, a DR may need to do the
"directly connected" behavior for sources that are not actually
directly connected.

  Bill

---

From: Narayanan Vidya-CVN065 <[email-masked]>
Date: Fri, 18 May 2001 11:01:14 -0500

Bill,
Would you then agree that the draft must be revised to state this? 

-Vidya

> From: Bill Fenner [mailto:[email-masked]]
> Sent: Thursday, May 17, 2001 8:11 PM
> To: vidyan
> Cc: [email-masked]
> Subject: Re: Encapsulation of packets from non-directly 
> connected hosts
> in PIM -SM
> 
> 
>

---

From: Bill Fenner <[email-masked]>
Date: Fri, 18 May 2001 09:23:33 -0700

The PMBR behavior (which will be in the next spec draft) should work
for this case.  

  Bill

---

From: Narayanan Vidya-CVN065 <[email-masked]>
Date: Fri, 18 May 2001 11:04:48 -0500

I don't see why it needs to make this distinction in this case. The router always knows if it has a PIM neighbor or not. When it receives a multicast data packet from a non-PIM neighbor, it needs to perform the functionality of a PIM DR. I don't see how else this would work with non-PIM multicast-capable routers. 
 
-Vidya

-----Original Message-----
From: Sridhar Vallepalli [mailto:[email-masked]]
Sent: Thursday, May 17, 2001 7:19 PM
To: 'Narayanan Vidya-CVN065'; 'pim'
Subject: RE: Encapsulation of packets from non-directly connected hosts in PIM -SM

If it is not restricted to directly connected hosts alone, I don't think there 
is a way for the PIM router to distinguish between the transit packets and locally 
originated traffic. 

Thanks 
S 

-----Original Message----- 
From: Narayanan Vidya-CVN065 [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Thursday, May 17, 2001 3:33 PM 
To: 'pim' 
Subject: Encapsulation of packets from non-directly connected hosts in 
PIM -SM 

All, 
I was trying to better understand the motivation behind only allowing encapsulation of packets from directly connected hosts. Are there reasons other than security concerns for making this restriction? The new revised draft seem to state this in section 4.3.1. Is this the correct interpretation, or am I mis-reading the draft? 

I guess my point is that if there is a non-PIM capable router directly connected to the sender, and if the packets are being sent into a PIM domain, does it (the first router running PIM in the path of the multicast flow) now not have to encapsulate the packets? Specifying that register state must only be maintained for directly connected hosts makes it seem like restricting such a design. 

Comments? 

Thanks, 
Vidya

---

From: Narayanan Vidya-CVN065 <[email-masked]>
Date: Fri, 18 May 2001 11:04:48 -0500

-Vidya

-----Original Message-----
From: Sridhar Vallepalli [mailto:[email-masked]]
Sent: Thursday, May 17, 2001 7:19 PM
To: 'Narayanan Vidya-CVN065'; 'pim'
Subject: RE: Encapsulation of packets from non-directly connected hosts in PIM -SM

Thanks 
S 

-----Original Message----- 
From: Narayanan Vidya-CVN065 [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Thursday, May 17, 2001 3:33 PM 
To: 'pim' 
Subject: Encapsulation of packets from non-directly connected hosts in 
PIM -SM 

All, 

Comments? 

Thanks, 
Vidya