Subject: RE: A small doubt on PIM DM

From: "Nicholas, Jonathan" <[email-masked]>
Date: Mon, 16 Jul 2001 06:22:44 -0500

A Graft gets acknowledged, a Join doesn't.  That's the short answer.
 
Grafts are intended to be used when a Prune is already in force.  Since the
current action is to not forward, a positive acknowledgement is desired to
ensure a change of action.
 
Joins are intended to be used when the current action is to forward.
Inaction will maintain the desired forwarding so a
positive acknowledgement is not needed.
 
Jonathan Nicholas
Network System Engineer

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, July 16, 2001 1:44 AM
To: [email-masked]
Subject: A small doubt on PIM DM

Hi, 

  May I know the difference between a join message and a graft message in
reference with PIM DM protocol. 

Thanks in Advance 
Arvind 

" Attitude not the Aptitude , that makes your Altitude. " 
"Strength is life, weekness is death" 

Arvind Mollin Kubendran 
Software Engg , Huawei Technologies 
Leela Palace, Airport Rd, Bangalore . 
Ph :5216824,26,27 Fax:5278248

---

From: [email-masked]
Date: Mon, 16 Jul 2001 18:03:17 +0500

Mani ,
 
 Pls read inline,

-----Original Message-----
From: Mani Manoharan Balaraman [mailto:[email-masked]]
Sent: Monday, July 16, 2001 5:25 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: A small doubt on PIM DM

Just remember what your mother always told you:
 "When you open windows you let in bugs".

----- Original Message ----- 
From: [email-masked] <mailto:[email-masked]>  
To: [email-masked] <mailto:[email-masked]>  ; [email-masked]
<mailto:[email-masked]>  
Cc: [email-masked] <mailto:[email-masked]>  
Sent: Monday, July 16, 2001 5:06 PM
Subject: RE: A small doubt on PIM DM

Thanks Andrew, 
But still I am not clear about certain things, let me put my understanding
first, 

1. When a host wants to join a group, then it sends a join message to the
router. Also join messages could be sent on the LAN if a host which still
wants to get the data from a group gets a prune message from the router. But
at which state this could happen?

********* If a host wants to join a group, the only way is to send a IGMP
JOIN,

*********if there are two downstream dependent routers, A and B on the same
interface, both of which have IGMP members, now from router B if every
member leaves, he sends a prune to upstream router, but actually here A
still contains IGMP members, so A now sends a PIM JOIN message to avoid
being cut from the tree.

2. When a host wants to delete itself from a group, it sends a prune message
to the router to which it is attached.

********* A host cannot Send Prune messages , it can only send IGMP Leaves (
That too in IGMPv2 only) 
[Arvind Mollin Kubendran] There was no mention about IGMP leaves in PIMDM or
PIMSM drafts that I have referred, then how can I host can leave a group (
assuming that there is no such thing like leave as far as PIM is concerned
), If I am wrong pls correct me otherwise, pls clarfiy my doubt.

All other replies are good and clarified my doubts, Thanks a lot Mani

3. When the router gets the last prune for a particular group, it sends a
prune upstream to the upstream neighbour, suppose at this moment, if the
same router recieves a join from some host for the same group, then the
router will send a graft to cancel the prune right ??.

********** Perfectly correct, But the PIM Join which it receives should be
within a particular Time Interval, till which this router maintains the
Prune List Entries

Hope my questions are okay to understand, pls let me know if you are not
clear with my questions, 
Onceagain, thanks for your valuable time. 

Topology :- 
  
  Host --------Router ----------Router -----------Source 
  
Arvind 

-----Original Message----- 
From: Andrew Adams [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Monday, July 16, 2001 3:23 PM 
To: [email-masked] 
Cc: [email-masked] 
Subject: Re: A small doubt on PIM DM 

Join messages are used to override prune messages sent from another 
router on the lan. Graft messages are used to re-join to an upstream 
neighbor to which a Prune was previously sent. Unlike Join messages, 
Graft messages are expected to be acknowledged. 

Hope this helps. 

-Andy 

> [email-masked] wrote: 
> 
> Hi, 
> 
>   May I know the difference between a join message and a graft message 
> in reference with PIM DM protocol. 
> 
> Thanks in Advance 
> Arvind 
>

---

From: Rajiv Raghunarayan <[email-masked]>
Date: Mon, 16 Jul 2001 21:10:25 +0530

Arvind,

     IGMP is used for host-router communication, while PIM messages
     are used
     for inter-router communication.

     An IGMP leave from a host is translated to a PIM Prune message
     by a
     router (depending on presence/absence of other hosts
     interested in the group). Detailed description of the IGMP
     protocol is
     available in RFC 2236.

     HTH..

     -Rajiv.

          ----- Original Message -----
          From: [email-masked]
          To: [email-masked] ; [email-masked]
          Cc: [email-masked]
          Sent: Monday, July 16, 2001 5:06 PM
          Subject: RE: A small doubt on PIM DM
           Thanks Andrew,
          But still I am not clear about certain things, let
          me put my understanding first,

          1. When a host wants to join a group, then it sends
          a join message to the router. Also join messages
          could be sent on the LAN if a host which still wants
          to get the data from a group gets a prune message
          from the router. But at which state this could
          happen?

          ********* If a host wants to join a group, the only
          way is to send a IGMP JOIN,

          *********if there are two downstream dependent
          routers, A and B on the same interface, both of
          which have IGMP members, now from router B if every
          member leaves, he sends a prune to upstream router,
          but actually here A still contains IGMP members, so
          A now sends a PIM JOIN message to avoid being cut
          from the tree.

          2. When a host wants to delete itself from a group,
          it sends a prune message to the router to which it
          is attached.

          ********* A host cannot Send Prune messages , it can
          only send IGMP Leaves ( That too in IGMPv2 only)
          [Arvind Mollin Kubendran] There was no mention about
          IGMP leaves in PIMDM or PIMSM drafts that I have
          referred, then how can I host can leave a group (
          assuming that there is no such thing like leave as
          far as PIM is concerned ), If I am wrong pls correct
          me otherwise, pls clarfiy my doubt.

          All other replies are good and clarified my doubts,
          Thanks a lot Mani

          3. When the router gets the last prune for a
          particular group, it sends a prune upstream to the
          upstream neighbour, suppose at this moment, if the
          same router recieves a join from some host for the
          same group, then the router will send a graft to
          cancel the prune right ??.

          ********** Perfectly correct, But the PIM Join which
          it receives should be within a particular Time
          Interval, till which this router maintains the Prune
          List Entries

          Hope my questions are okay to understand, pls let me
          know if you are not clear with my questions,
          Onceagain, thanks for your valuable time.

          Topology :-

            Host --------Router ----------Router
          -----------Source

          Arvind

          -----Original Message-----
          From: Andrew Adams [mailto:[email-masked]]
          Sent: Monday, July 16, 2001 3:23 PM
          To: [email-masked]
          Cc: [email-masked]
          Subject: Re: A small doubt on PIM DM

          Join messages are used to override prune messages
          sent from another
          router on the lan. Graft messages are used to
          re-join to an upstream
          neighbor to which a Prune was previously sent.
          Unlike Join messages,
          Graft messages are expected to be acknowledged.

          Hope this helps.

          -Andy

---

From: "Nicholas, Jonathan" <[email-masked]>
Date: Mon, 16 Jul 2001 07:52:28 -0500

Normally, if a host wishes to join a group, it would use IGMP.
 
Hypothetically, a host could run PIM-DM.  If a host ran PIM-DM it would get
messages for all groups, and would not need to send a Join message to join a
group.  A Join message could be used to cancel a Prune message if it
appeared on the LAN.
 
Normally, a host would delete itself from a group via IGMP mechanisms.  
 
If it were running PIM-DM, it would send a Prune message to its upstream
router.  The upstream router would send a Prune message to its upstream
router if all of its downstream interfaces have no local members and (no PIM
routers or received valid Prune messages), ad inifinitum.
 
Jonathan Nicholas
Network Systems Engineer
ITT A/CD

Thanks Andrew, 

Topology :- 

Arvind