Subject: Re: RPT bit in Assert Messages.

From: "Jyotheeswara Rao Kurma" <[email-masked]>
Date: Fri, 06 Jul 2001 09:23:35 +0500

> I have a question regarding "rpt" bit in Assert
> message. Is this bit set when we are receiving packets
> from SPT or only if we received (S,G) Join/(S,
> G)IGMPv3 reports on that interface?.

    No, if the packet that caused the assert is routed using SPT then
this will be cleared.( not set)

Update me if I am wrong,
Jyotheesh

---

From: krishna bellamkonda <[email-masked]>
Date: Fri, 6 Jul 2001 10:03:28 -0700 (PDT)

I agree with your comment. But, my question still
stands.

If a Router received only (*, G) join and lost the (*,
G) assert on interface1. But this Router has won the
(S, G) assert on interface1 because it has received a
(S,G) Join on another interface2 and established SPT
tree.

 According to the new PIM-SM draft interface1 will not
be present in the inherited_olist(S, G). Because we
have supresses the other router from forwarding for
this (S, G) entry it should be included in the
outgoing interface list. 

Thanks
Krishna.

--- Jyotheeswara Rao Kurma
> this will be cleared.( not set)

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail
http://personal.mail.yahoo.com/

---

From: chennu krishna <[email-masked]>
Date: Fri, 6 Jul 2001 10:55:02 -0700 (PDT)

This problem effects (S, G) inherited list. But, the
(S, G, Rpt) inherited list doesn't change. At the same
time immediate list of (S, G) also remains the same.

chennu.
  
--- krishna bellamkonda <[email-masked]>

---

From: Ardas Cilingiroglu <[email-masked]>
Date: Fri, 06 Jul 2001 15:17:18 -0400

> (S,G) Join on another interface2 and established SPT

Krishna,

The router cannot win (S,G) assert on interface1, since
CouldAssert(S,G,I) is false because of interface1 being
in lost_assert(*,G).

-Ardas