Subject: RE: A small doubt on PIM DM

From: [email-masked]
Date: Mon, 16 Jul 2001 16:36:25 +0500

Thanks Andrew,
But still I am not clear about certain things, let me put my understanding
first,

1. When a host wants to join a group, then it sends a join message to the
router. Also join messages could be sent on the LAN if a host which still
wants to get the data from a group gets a prune message from the router. But
at which state this could happen?

2. When a host wants to delete itself from a group, it sends a prune message
to the router to which it is attached.

3. When the router gets the last prune for a particular group, it sends a
prune upstream to the upstream neighbour, suppose at this moment, if the
same router recieves a join from some host for the same group, then the
router will send a graft to cancel the prune right ??.

Hope my questions are okay to understand, pls let me know if you are not
clear with my questions,
Onceagain, thanks for your valuable time.

Topology :-
  
  Host --------Router ----------Router -----------Source
  
Arvind

-----Original Message-----
From: Andrew Adams [mailto:[email-masked]]
Sent: Monday, July 16, 2001 3:23 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: A small doubt on PIM DM

Join messages are used to override prune messages sent from another
router on the lan. Graft messages are used to re-join to an upstream 
neighbor to which a Prune was previously sent. Unlike Join messages,
Graft messages are expected to be acknowledged.

Hope this helps.

-Andy

> [email-masked] wrote:
> 
> Hi,
> 
>   May I know the difference between a join message and a graft message
> in reference with PIM DM protocol.
> 
> Thanks in Advance
> Arvind
> 
> " Attitude not the Aptitude , that makes your Altitude. "
> "Strength is life, weekness is death"
> 
> Arvind Mollin Kubendran
> Software Engg , Huawei Technologies
> Leela Palace, Airport Rd, Bangalore .
> Ph :5216824,26,27 Fax:5278248

---

From: "Mani Manoharan Balaraman" <[email-masked]>
Date: Mon, 16 Jul 2001 17:54:52 +0530

RE: A small doubt on PIM DM
Just remember what your mother always told you:
 "When you open windows you let in bugs".

  ----- Original Message ----- 
  From: [email-masked] 
  To: [email-masked] ; [email-masked] 
  Cc: [email-masked] 
  Sent: Monday, July 16, 2001 5:06 PM
  Subject: RE: A small doubt on PIM DM

  Thanks Andrew, 
  But still I am not clear about certain things, let me put my understanding first, 

  1. When a host wants to join a group, then it sends a join message to the router. Also join messages could be sent on the LAN if a host which still wants to get the data from a group gets a prune message from the router. But at which state this could happen?

  ********* If a host wants to join a group, the only way is to send a IGMP JOIN,

  *********if there are two downstream dependent routers, A and B on the same interface, both of which have IGMP members, now from router B if every member leaves, he sends a prune to upstream router, but actually here A still contains IGMP members, so A now sends a PIM JOIN message to avoid being cut from the tree.

  2. When a host wants to delete itself from a group, it sends a prune message to the router to which it is attached.

  ********* A host cannot Send Prune messages , it can only send IGMP Leaves ( That too in IGMPv2 only) 

  3. When the router gets the last prune for a particular group, it sends a prune upstream to the upstream neighbour, suppose at this moment, if the same router recieves a join from some host for the same group, then the router will send a graft to cancel the prune right ??.

  ********** Perfectly correct, But the PIM Join which it receives should be within a particular Time Interval, till which this router maintains the Prune List Entries

  Hope my questions are okay to understand, pls let me know if you are not clear with my questions, 
  Onceagain, thanks for your valuable time. 

  Topology :- 

  Arvind 

  -----Original Message----- 
  From: Andrew Adams [mailto:[email-masked]] 
  Sent: Monday, July 16, 2001 3:23 PM 
  To: [email-masked] 
  Cc: [email-masked] 
  Subject: Re: A small doubt on PIM DM 

  Hope this helps. 

  -Andy