Subject: pim-sm and igmp-routing

From: juan <[email-masked]>
Date: Wed, 26 Sep 2001 10:36:22 -0700 (PDT)

Hi,

I'm coming up with some scenarios to test pim-sm.  There are a couple
of test cases where I ran into unexpected results.

The test below is one of them.  It shows a shared network with 2 PIM routers 
(R1 and R2) and an IGMP host receiver.  In this case R1 is the PIM-DR but for
whatever reason it does not support IGMP-routing.  Therefore, R2 is used to 
handle the hosts' IGMP membership reports.  

I understand that if we make either R1 or R2, both the DR and the router
handling IGMP requests, then things will work.  I am just wondering if
it's a pre-requisite that a DR interface _has_ to support IGMP routing, 
and cannot delegate the IGMP routing functionality to another router.

- test 3.5.2: shared net + igmp host + multiple PIM routers
  * setup
       DR = R1                         RP
       IGMP support = R2               | 
                                       R1     host(igmp-join(*,g1))
                                       |      |
                                   ----+-+----+----- 
                                         |
                                         R2
                                         |
                                         sender(s1->g1)
  * test summary
    - host sends igmp join(*,g1)
      * R2 receives the igmp membership packet
        - downstram-state for if-north : no-info
        - inh_olist(s,g,rpt): null !!  //pim_include(*,G)=null - we're not the DR
        - us-state if-north:  ni   !!  //no pim join sent to the rp
    - sender sends (s1->g1) mcast packet
      * R2
        - drops ?! since oil=null

Thanks
Juan

__________________________________________________
Do You Yahoo!?
Get email alerts & NEW webcam video instant messaging with Yahoo! Messenger. http://im.yahoo.com

---

From: "Jyotheeswara Rao Kurma" <[email-masked]>
Date: Thu, 27 Sep 2001 08:51:23 +0500

Wipro's Implementation uses, exactly the same concept. Pim Routers will 
be passively listening to IGMP messages,( It won't send any IGMP 
messages,) The only requirement is that there should be a machine on 
this sub-network, that is running IGMP querier ( IGMP router part )..

PIM daemon will be listening IGMP membership reports, and leave 
messages, and do some PIM protocol specific actions, upon receiving 
them.

With this approach, there is no requirement like DR should be IGMP 
Querier, or some thing else. They two are independent and can be on any 
machine . PIM modules will only listen IGMP messages .

Thanks,
Jyotheesh

---

From: [email-masked]
Date: Thu, 27 Sep 2001 10:09:17 -0400

see inline ( >>> )  for my reply

swami

                    "Jyotheeswara Rao                                                      
                    Kurma"                    To:     John Zwiebel                         
                    <jyotheeswara.rao@        <[email-masked]>,                  
                    wipro.com>                [email-masked], [email-masked]   
                    Sent by:                  cc:                                          
                    owner-pim@catarina        Subject:     Re: pim-sm and igmp-routing     
                    .usc.edu                                                               

                    09/26/01 11:51 PM                                                      

>>>A PIM rtr need NOT to be IGMP Querier.But there is only way of
communicating PIM, to convey the group membership, is IGMP.There is no
other standard. As John said, you should have atleast IGMP Cache.

>>> PIM daemon listens to IGMP membership reports ? . Is it GateD
implementation?

Thanks,
Jyotheesh

(See attached file: Wipro_Disclaimer.txt)

---

From: "Jyotheeswara Rao Kurma" <[email-masked]>
Date: Fri, 28 Sep 2001 08:49:47 +0500

I didn't get What do you mean by having IGMP cache ? ?  No one 
  expressed the idea that PIM rtr must be IGMP querier .
  I said there should be a machine running IGMP router part (Querier)
  on this sub-network ...That's it. 

  In Linux environment , we dont' have a way to access IGMP 
state/cache ), So PIM also listens to IGMP 
messages, (Only listening ) ,and will do some actions . That's it.

If you find a beetter way of doing it , Please let me know.
This is how USC, Gated works on Linux ..

Thanks,
Jyotheesh