Subject: ReplyToYour:: Assert state of upstream interface

From: "O.L.N.Rao" <[email-masked]>
Date: Thu, 13 Sep 2001 00:18:06 -0700 (PDT)

Hi Subrata and Friends,
 
  Take a Situation like,

   R1            R2
    |             |
    ---------------
       |       | 
       R3      R4

 URP - Unicast Routing Protocol
 Let us suppose that,
 R4's URP says to PIM on it that R2 is Upstream 
 Router. R3's URP says that R1 is Upstream Router.

 Now Let us say Assert Mech. happened and R1 is 
 Elected as ASSERT WINNER.

 If R4 dont note down its upstream Assert Winner, It
  still sends Join/Prunes to R2 - A BIG CLASH.  The
  very use of Assert Vanished there itself.

 I hope you understand.

Regards - O.L.N.Rao

Hi friends,

This is regarding per-interface (S,G)/ (*,G) Assert
state (Section
- 4.5, draft-ietf-pim-sm-v2-new-03). 

The draft says that a router must keep track of Assert
information 
on upstream interfaces in order to send joins and
prunes to the proper 
neighbor. I understand this reason behind tracking
Assert on upstream
interface.

The Assert state machines also show state transitions
(NI/ L/ W) on 
upstream
interface if AssertTrackingDesired is true. I do not
understand why it
is necessary to maintain such a state for an upstream
interface! After 
all
router is not going to forward multicast data packets
to RPF interface.

Let me know the benefits (if any).

Thanks!

-Subrata

__________________________________________________
Terrorist Attacks on U.S. - How can you help?
Donate cash, emergency relief information
http://dailynews.yahoo.com/fc/US/Emergency_Information/

---

From: "Subrata Sa" <[email-masked]>
Date: Thu, 13 Sep 2001 01:20:34 -0800

Hi,

Well that's fine !! R4 has to
know which router is the next hop
to source/ RP in order to send Join or
Prune.

My question was something different. 

o Why does R3/ R4 maintain Assert states for
upstream interfaces?

o What difference do we see in PIM behaviour depending
on what is router's (R3/ R4) upstream Assert state 
(NoInfo/ L/ W)?

Thanks

-Subrata

_____________________________________________________________
Tired of limited space on Yahoo and Hotmail?
Free 100 Meg email account available at http://www.dacafe.com

---

From: "Jyotheeswara Rao Kurma" <[email-masked]>
Date: Thu, 13 Sep 2001 14:18:51 +0500

> o Why does R3/ R4 maintain Assert states for

  Strictly speaking you need to store. if you don't store, you don't 
know, whether assert has hapend or not ( No-INFO, or assert LOOSER),
If you are in NO-Info, you need to get next hop address from Unicast 
table, otherwise (If you are assert looser .., it is the Asert winner).
modify\ied rpf neighbor macros will do this for you. but you should 
update your upstream interface assert state.

Please remember you won't win the assert race on up stream interface.
storing assert info ( and your state as well as assert winner ip 
address) will give you the correct up stream neighbor.

Jyotheesh

---

From: "Jyotheeswara Rao Kurma" <[email-masked]>
Date: Thu, 13 Sep 2001 13:03:55 +0500

>  very use of Assert Vanished there itself.

 R4 will store the assert winner info, but why my state ( it's always
be in Looser/no ifo )

Jyotheesh