Subject: What is Whold Packet? in Helmy's draft

From: "O.L.N.Rao" <[email-masked]>
Date: Wed, 5 Sep 2001 03:38:53 -0700 (PDT)

Hello friends,
  
  In Helmy draft it is given that a data packet is
sent
  to PIM only if
  1) Cache miss
  2) Cache Hit but Wrong IIF
  3) Whole Packet.
  I could get first two.  But i did not understand
  the case 3 and where it arises.

Thank You All.
O.L.N.Rao

__________________________________________________
Do You Yahoo!?
Get email alerts & NEW webcam video instant messaging with Yahoo! Messenger
http://im.yahoo.com

---

From: Pavlin Radoslavov <[email-masked]>
Date: Wed, 05 Sep 2001 10:27:20 -0700

>   the case 3 and where it arises.

WHOLEPKT is sent from the kernel to the routing daemon when the
PIM-SM router needs to encapsulate the mcast data packets in PIM
Register messages and send them to the RP. If the PIM Register
encapsulation is performed in the kernel instead of the user-level
daemon, then there is no need for this message, but this is not the
case with the current UNIX kernel support.

Pavlin