Subject: MRIB implementation

From: Jiang Pet <[email-masked]>
Date: Fri, 21 Sep 2001 04:45:00 -0700 (PDT)

Hi all,

I have am question about implementation of MRIB. I
have read PIM-SM draft. It details on MRIB concept at
the begining, but don't explan how to implement it.
When I tried to find the answer through pimd source,
but found it is too hard to find the answer by this
method. And I think if pimd can work without other
unicsst routing protocol and MGBP it should solve
routing problem, but how?

Is there any guy can explain this clearly to me?
Thanks in advance.

Pet

__________________________________________________
Terrorist Attacks on U.S. - How can you help?
Donate cash, emergency relief information
http://dailynews.yahoo.com/fc/US/Emergency_Information/

---

From: Hitoshi Asaeda <[email-masked]>
Date: Fri, 21 Sep 2001 16:10:23 +0200 (MEST)

> routing problem, but how?

There is no MRIB implementation on pimd (yet?).
And if you'd plan to use the function, also your kernel must support
it to handle multiple routing tables. (I don't get another solution.)
I'm not sure (because I'm not a Linux user:) but I heard Linux can
maintain multiple routing tables.
And there is some experimental MRIB code and its API provided by
WIDE/KAME for NetBSD, but it's not included in its release tree now.
--
Hitoshi Asaeda