Subject: multicast deployment

From: "hitesh rupare;" <[email-masked]>
Date: Sun, 16 Sep 2001 19:54:06 -0500

hi,

i was thinking of doing a small project to understand multicast deployment 
in its entirety...

i have a small private network of 3 routers with a lan each....now i have 
turned on multicasting  on these routers( have used pim )...i know this is 
working fine because i see advertisements i make on one host ( with sdr ) 
appears on other hosts on other lans  ( in sdr )...

i want to extend this to something like " places all over the world "
i have a web - cam....how can i associate this stream ( from my webcam )to a 
group address  so that when i click on my advertisement in sdr i want it to 
invoke vic and show me this feed from the host on the other lan...

right now i am on a private network ...but if i were extend this to mbone 
what precautions would i have to take...ie how can i send my stream to " 
places all over the world "..

rgds,
hitesh

>From: "Marshall Eubanks" <[email-masked]>
>Reply-To: [email-masked]
>To: "hitesh ruparel" <[email-masked]>, [email-masked],   
>[email-masked]
>Subject: Re: SSM
>Date: Fri, 14 Sep 2001 09:57:28 -0400
>
> >
>Dear Hitesh;
>
>(I deleted the inappropriate msdp cc.)
>
>SSM could be a separate tranport protocol. However,
>it was implemented as a subset of PIM-SM. SSM as
>implemented is basically PIM-SM with
>
>- IGMP v3 support at the edges
>- filtering out or ignoring of (*,G) and (S,G,RPT)
>joins, leaves in the core.
>
>The new PIM-SMv2 draft makes this clear - see
>
>http://www.ietf.org/internet-drafts/draft-ietf-pim-sm-v2-new-03.ps or
>http://www.ietf.org/internet-drafts/draft-ietf-pim-sm-v2-new-03.txt
>
>in fact, to the extent that there IS no separate SSM transport
>protocol draft.
>
>Regards
>Marshall
>
> >hi,
> >
> >ssm makes use of source based trees and so is fundamentally closer to 
>dense
>
> >mode protocols...why then is it said to be closer to pim-sm which makes 
>use
>
> >of shared trees..some even call it a subset of pim-sm (ism )..
> >
> >rgds
> >hitesh
> >
> >>From: Bill Fenner <[email-masked]>
> >>To: [email-masked]
> >>CC: [email-masked], [email-masked]
> >>Subject: Re: directly connected sources
> >>Date: Wed, 5 Sep 2001 12:35:06 -0700
> >>
> >>
> >>Tom,
> >>
> >>The current wording is:
> >>
> >>    When an RP in a PIM-SM domain first learns of a new sender, e.g. via
> >>    PIM register messages, it constructs a "Source-Active" (SA) message
> >>    and sends it to its MSDP peers.
> >>
> >>Would it be sufficient to add "or if it is the DR for a directly 
>connected
>
> >>source" to the "e.g."?
> >>
> >>   Bill
> >
> >
> >_________________________________________________________________
> >Get your FREE download of MSN Explorer at 
>http://explorer.msn.com/intl.asp
>
> >
> >
>
>Marshall Eubanks
>
>[email-masked]

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp

---

From: "Marshall Eubanks" <[email-masked]>
Date: Sun, 16 Sep 2001 22:18:41 -0400

>places all over the world "..

Hitesh;

   If you have PIM neighbors and MSDP peering with routers
in other domains, then all you have to do is to send
packets to the appropriate Class D multicast address.
(RTP / RTCP is a little more complicated.) You don't even
have to run IGMP (but if you don't you cannot receive).

   It's up to a receiver to join. MSDP lets receivers in other
domains know about the source so they can do this.

                  Marshall