Subject: SSM

From: "hitesh rupare;" <[email-masked]>
Date: Fri, 14 Sep 2001 08:22:22 -0500

hi,

ssm makes use of source based trees and so is fundamentally closer to dense 
mode protocols...why then is it said to be closer to pim-sm which makes use 
of shared trees..some even call it a subset of pim-sm (ism )..

rgds
hitesh

>From: Bill Fenner <[email-masked]>
>To: [email-masked]
>CC: [email-masked], [email-masked]
>Subject: Re: directly connected sources
>Date: Wed, 5 Sep 2001 12:35:06 -0700
>
>
>Tom,
>
>The current wording is:
>
>    When an RP in a PIM-SM domain first learns of a new sender, e.g. via
>    PIM register messages, it constructs a "Source-Active" (SA) message
>    and sends it to its MSDP peers.
>
>Would it be sufficient to add "or if it is the DR for a directly connected
>source" to the "e.g."?
>
>   Bill

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp

---

From: Bryan Mclaughlin <[email-masked]>
Date: Fri, 14 Sep 2001 14:33:14 +0100

Hitesh

My understanding is that:

DM push's data from the source. There may be no receivers
SM pulls data to the receiver. Tree are thus created only at the request of 
a reciever.

Bryan

At 08:22 14/09/2001 -0500, hitesh rupare; wrote:

>hi,
>
>ssm makes use of source based trees and so is fundamentally closer to 
>dense mode protocols...why then is it said to be closer to pim-sm which 
>makes use of shared trees..some even call it a subset of pim-sm (ism )..
>
>rgds
>hitesh
>

Bryan Mclaughlin
Technical Marketing Engineer	            Telephone :+44 (0)20 8756 8811
IOS Technology Division 		Email        :[email-masked]
Cisco Systems			Mobile       :+44 (0)7710 164487

---

From: Leonard Giuliano <[email-masked]>
Date: Fri, 14 Sep 2001 07:33:09 -0700 (PDT)

Hitesh,

PIM-SM makes use of both shared and source-based trees.  It's ability to
support SSM centers around source-based tree formation.

-Lenny

On Fri, 14 Sep 2001, hitesh rupare; wrote:

*>
*>hi,
*>
*>ssm makes use of source based trees and so is fundamentally closer to dense
*>mode protocols...why then is it said to be closer to pim-sm which makes use
*>of shared trees..some even call it a subset of pim-sm (ism )..
*>
*>rgds
*>hitesh
*>
*>>From: Bill Fenner <[email-masked]>
*>>To: [email-masked]
*>>CC: [email-masked], [email-masked]
*>>Subject: Re: directly connected sources
*>>Date: Wed, 5 Sep 2001 12:35:06 -0700
*>>
*>>
*>>Tom,
*>>
*>>The current wording is:
*>>
*>>    When an RP in a PIM-SM domain first learns of a new sender, e.g. via
*>>    PIM register messages, it constructs a "Source-Active" (SA) message
*>>    and sends it to its MSDP peers.
*>>
*>>Would it be sufficient to add "or if it is the DR for a directly connected
*>>source" to the "e.g."?
*>>
*>>   Bill
*>
*>
*>_________________________________________________________________
*>Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp
*>

---

From: "LiuYue" <[email-masked]>
Date: Sat, 15 Sep 2001 09:49:05 +0800

Although SSM make use of source-based trees, it's not a dense-mode protocol. 
In my opinion,a DM protocol is designed for the situations where receivers 
distributed densely, and consequently contains a flood and prune process. 
But SSM has no constraints on the distribution of receivers, i.e., the distribution
may be sparce or dense, and usually make use of receiver explicit join process, so
one can not say it's a SM or DM protocol.
SSM is a service model, not a protocol. Some call it a subset of PIM-SM 
because it can be easilly implemented by making little change to the PIM-SM
protocol, which is rather stable. Most of the changes due to the multicast
addresses assigned by IANA to SSM model, 232/8.

Regards,
Liu Yue

---

From: John Zwiebel <[email-masked]>
Date: Fri, 14 Sep 2001 19:30:00 -0700

> of shared trees..some even call it a subset of pim-sm (ism )..

Everyone else has tried to answer this, and I'm not satisfied with any
of
those answers....

SSM is _just_ PIM-SM Shortest Path Trees.

The last hop router figures out both the source and the group via
whatever method (usually IGMPv3 for now, but there's also URL and
you could even manually configure it in the router if that were
implemented)
and sends a PIM (S,G) join toward the source.

That's it.  All the other stuff obfuscates the reality.
A router running IOS code from 10.3 (which is really, really old)
can still participate in an SSM forwarding path as long as its
not the last hop.

> _______________________________________________
> Pim-external mailing list
> [email-masked]
> http://mailist.procket.com/mailman/listinfo/pim-external