Subject: pim-sm and igmp-routing

From: [email-masked]
Date: Wed, 26 Sep 2001 15:49:33 -0400

Juan,

        I am wondering how group membership is conveyed to PIM in R1 ?.
You must have support of IGMP in R1 and which should convey the membership
to PIM module.

BTW, why you need two PIM routers in a network ?

thanks,
swami

----- Forwarded by Swaminathan Ramalingam/VRLK on 09/26/01 03:45 PM -----
                                                                                                                      
                    juan                                                                                              
                    <juan_mcast@yaho        To:                                                                       
                    o.com>                  cc:                                                                       
                    Sent by:                bcc:                                                                      
                    owner-pim@catari        Subject:     pim-sm and igmp-routing                                      
                    na.usc.edu                                                                                        

                    09/26/01 01:36                                                                                    
                    PM                                                                                                

Hi,

I'm coming up with some scenarios to test pim-sm.  There are a couple
of test cases where I ran into unexpected results.

The test below is one of them.  It shows a shared network with 2 PIM
routers
(R1 and R2) and an IGMP host receiver.  In this case R1 is the PIM-DR but
for
whatever reason it does not support IGMP-routing.  Therefore, R2 is used to

handle the hosts' IGMP membership reports.

I understand that if we make either R1 or R2, both the DR and the router
handling IGMP requests, then things will work.  I am just wondering if
it's a pre-requisite that a DR interface _has_ to support IGMP routing,
and cannot delegate the IGMP routing functionality to another router.

- test 3.5.2: shared net + igmp host + multiple PIM routers
  * setup
       DR = R1                         RP
       IGMP support = R2               |
                                       R1     host(igmp-join(*,g1))
                                       |      |
                                   ----+-+----+-----
                                         |
                                         R2
                                         |
                                         sender(s1->g1)
  * test summary
    - host sends igmp join(*,g1)
      * R2 receives the igmp membership packet
        - downstram-state for if-north : no-info
        - inh_olist(s,g,rpt): null !!  //pim_include(*,G)=null - we're not
the DR
        - us-state if-north:  ni   !!  //no pim join sent to the rp
    - sender sends (s1->g1) mcast packet
      * R2
        - drops ?! since oil=null

Thanks
Juan

__________________________________________________
Do You Yahoo!?
Get email alerts & NEW webcam video instant messaging with Yahoo!
Messenger. http://im.yahoo.com

(Embedded image moved to file: pic26165.pcx)

---

From: juan <[email-masked]>
Date: Wed, 26 Sep 2001 14:09:52 -0700 (PDT)

>         I am wondering how group membership is conveyed to PIM in R1 ?.

Hi Swami,

In this case R1 does not learn about group memberships...
- neither via IGMP routing (R1 is not running IGMP routing protocol)
- nor via pim joins (*,g1) relayed by other PIM routers

> You must have support of IGMP in R1 and which should convey the membership

I guess this is preceisely the question that I'm asking - is it a 
requirement?  

Or could the DR (R1) be used only to perform the pim-tunneling/encapsulation
functionality in case that there are mcast data senders on the local subnet,
and leave the igmp routing functionality to another router, that then would
send the pim joins towards the RP?

> BTW, why you need two PIM routers in a network ?

Well, it's just the network configuration.  R1 cannot be directly connected 
to the subnet where the sender of (s1->g1) traffic is located.  The shared
network is simply an L2 switch to which 2 routers are connected, along with
other workstations.

> > The test below shows a shared network with 2 PIM routers (R1 and R2)
> > and an IGMP host receiver.  In this case R1 is the PIM-DR but for whatever
> > reason it does not support IGMP-routing.  Therefore, R2 is used to handle the
> > hosts' IGMP membership reports.  
> > 
> > I understand that if we make either R1 or R2 both the DR and the router
> >        - inh_olist(s,g,rpt): null !!!   //pim_include(*,G)=null - not the DR
> >        - us-state if-north:  ni   !!!   //no pim join sent to the rp

__________________________________________________
Do You Yahoo!?
Get email alerts & NEW webcam video instant messaging with Yahoo! Messenger. http://im.yahoo.com

---

From: John Zwiebel <[email-masked]>
Date: Wed, 26 Sep 2001 15:37:49 -0700

> I guess this is preceisely the question that I'm asking - is it a

Yes.

The new PIM spec states that unless there is an assert, the DR is
responsible for getting the PIM routes set up correctly to deliver
traffic to local members.

The PIM DR is the highest IP address: it must maintain an IGMP cache.

The IGMP querier is the lowest IP address: theoretically, this router
wouldn't have to run PIM -- actually it wouldn't even have to be a 
router since the only thing it does (in this case) is send out IGMP
queries.

> _______________________________________________
> Pim-external mailing list
> [email-masked]
> http://mailist.procket.com/mailman/listinfo/pim-external