Subject: [pim] RP advt. doubt

From: "Katta Sambasivarao" <[email-masked]>
Date: 16 Jan 2002 14:55:05 -0000

hi,
I have a doubt in C-RP configuration and C-RP message adverttisement.

The Section. 1.3 of BSR draft talks about C-RP configuration for admin and global scopes. It says "We also recommend that the default be that a C-RP is a C-RP for all scopes, both global and admin scoped."

What does it mean? If a router is configured to be C-RP for say 224.0.0.0/4 (global zone) and it learns 2 BSRs, one for global and one for "admin zone" say 232.0.0.0/8.

Then how the C-RP advertisement should be done. Is it supposed to advertise one C-RP message to "global zone" BSR for global zone address and C-RP message for "admin zone" address to BSR of "admin zone".

Or Is the C-RP advetisement for admin zone should be done only when C-RP is configured explicitly for prefix in that "scope zone".

Please clarify.
Thanks in advance.

regards,
Katta

---

From: Mark Handley <[email-masked]>
Date: Wed, 16 Jan 2002 08:17:45 -0800

>The Section. 1.3 of BSR draft talks about C-RP configuration for admin and glo
>bal scopes. It says "We also recommend that the default be that a C-RP is a C-
>RP for all scopes, both global and admin scoped."
>
>What does it mean? If a router is configured to be C-RP for say 224.0.0.0/4 (g
>lobal zone) and it learns 2 BSRs, one for global and one for "admin zone" say 
>232.0.0.0/8.
>
>Then how the C-RP advertisement should be done. Is it supposed to advertise on
>e C-RP message to "global zone" BSR for global zone address and C-RP message f
>or "admin zone" address to BSR of "admin zone".

Yes.

>Or Is the C-RP advetisement for admin zone should be done only when C-RP is co
>nfigured explicitly for prefix in that "scope zone".

The "we recommend" part is intended to say that it should advertise to
the BSR of each scope zone it hears about from BSMs, unless explicitly
configured not to. 

 - Mark