Subject: Re Re [pim] RP map problem - BSR

From: "Katta Sambasivarao" <[email-masked]>
Date: 9 Jan 2002 06:26:15 -0000

hi Jhingran,
I agree that re-mapping groups for each BSR message is
lot of overhead. But we dont do re-mapping if no change
in RP  priority is detected for old RPs. Let me put my
idea in detail.

While one checks for missing RP's in BSR message, one can
check whether that RP priority changed. If priority
change is detected, one can recompute group mappings only
for groups with (*,G) or (S, G, RPt) state and which fall
in this RP-routers group prefix range. This is not going
to happen for each BSR message. Only when some
configuration change occurs on some C-RP.

The "hold time 0 RP-advetisement" when RP priority
changed may not work out as C-RP advertisements may get
lost in transit to BSR. Such unfortunate situation will
result in chaos. Of couse it is very very improbable case
but not impossible case.

regards,
Katta

On Wed, 09 Jan 2002 P.Jhingran wrote :
>
> hi katta,
>           I think a C-RP should not abruptly change its
> RP priority. It should first advertise a Hold time of 0
> to the BSR, so as to inform the entire Domain that the
> C-RP is going down. It can now start advertising with a
> changed RP priority.
> The above shall take care of "A router that booted late
> and received 2nd BSR message will map G to RP2 while
> this router will use RP1 for G."
> I think one can interpret Change of RP priority as the
> same C-RP has booted up again/ freshly with different
> RP priority. Checking the priority of the RP's every
> time one receives BSR message will add additional
> overhead to the BSR-RP mechanism.
>
> regards,
> P.Jhingran
>
> On Tue, 08 Jan 2002 Katta Sambasivarao wrote :
> >
> > hi,
> > I have a doubt about using RP-set info received in
> > BSR message.
> >
> > Section 3.4 of BSR draft talks about checking for new
>
> > RPs and missing old RPs in BSR message for J/P states
>
> > this router got.
> >
> > Suppose I received a BSR message with RP1 and RP2 for
>
> > group (G/32) and RP1 priority is more than RP2.
> >
> > Now I select R
r BSR
> > message, suppose that the priority of RP1 is less
> than
> > RP2.
> > From the draft(sec 3.4), I understood that RP
> priority
> > is used only in tie breaking. Once we selcted RP we
> > will not change until that RP becomes un-available or
>
> > new RP becomes available. So the change in priority
> > like in above case will not affect the existing
> states.
> >
> > But will that not lead to problem. A router that
> booted
> > late and received 2nd BSR message will map G to RP2
> > while this router will use RP1 for G.
> >
> > I think, Section 3.4 should address the change in RP
> > priority case also. A router should check for
> > correctness of old RP mappings as per new BSR
> message.
> >
> > Please correct me, if my understanding is not
> correct.
> >
> > Thanks in advance.
> >
> > regards,
> > Katta
> >
> >
> >
> >
>
>

---

From: "P.Jhingran" <[email-masked]>
Date: 9 Jan 2002 08:25:50 -0000

hi katta,
         Well I think its all implementaion specific.Either of the two approaches can solve the problem but one has to look for an efficient solution.
I think change in CRP priority will be less frequent than the handling of BSR advertisement, i prefer the "hold time 0 RP-advetisement" technique.
I would definitely like to receive comments on this specially from the authors.
regards,
P.Jhingran

On Wed, 09 Jan 2002 Katta Sambasivarao wrote :
> > RP priority. Checking the priori
 will add additional