Subject: [pim] Downstream per-interface (S,G,rpt) state-machine

From: "Shankar Vasudevan" <[email-masked]>
Date: 8 Jan 2002 04:57:11 -0000

Hi all,

     downstream (s,G,rpt) state machine does not handle reception of (*, *, RP(G)) Join. I guess the state change on reception of this join is similar to receiving (*,G)join. Is my assumption right ? 

thanx and regards,
shankar

---

From: Mark Handley <[email-masked]>
Date: Tue, 08 Jan 2002 07:50:13 -0800

>     downstream (s,G,rpt) state machine does not handle reception of (*, *, RP
>(G)) Join. I guess the state change on reception of this join is similar to re
>ceiving (*,G)join. Is my assumption right ? 

No, the state machine is correct.  A (*,*,RP(G)) Join does not affect
(*,G) state.  This was a change that was made in the latest draft and
discussed at the last IETF.

My slides are online at:
  http://www.icir.org/mjh/tmp/pim-slc.ps
They should help explain why.  Note that some decisions were taken at
the IETF that the slides don't reflect but the minutes should.

Cheers,
	Mark