Subject: [pim] Is a non-DQ router supposed to process IGMP reports

From: "P.Jhingran" <[email-masked]>
Date: 7 Jan 2002 15:33:04 -0000

hi all,
        I wnat to confirm the processing of IGMP reports. 
Is there a limitation that a router who has lost Querier Election should also not process IGMP reports ??
If this is so then it is a matter of concern with respect to multicasting routing protocols running on the router !!.
regards,
P. Jhingarn

---

From: David Barnett <[email-masked]>
Date: Mon, 7 Jan 2002 11:51:13 -0500

> If this is so then it is a matter of concern with respect to multicasting routing protocols running on the router !!.

Hello,
In my understanding, it's not that the non querier doesn't process membership 
reports, it does. Rather it just relies on the Querier to 'query' for them.

-Dave

---

From: Hugh Holbrook <[email-masked]>
Date: Mon, 7 Jan 2002 09:19:08 -0800 (PST)

> Date: 7 Jan 2002 15:33:04 -0000
> From: "P.Jhingran" <[email-masked]>

> should also not process IGMP reports ??

Absolutely not.

All routers on the LAN need to process all IGMP reports and this is
stated in the protocol spec.  In PIM-SM, it is typically the DR that
sends a PIM join in response to an IGMP report.  The DR is, typically
the router with the highest IP address, whereas the IGMP Querier is
the router with the lowest IP address.  Any other router needs to know
the IGMP join state, too, if it ends up being an Assert winner.

-Hugh

---

From: Paras Trivedi <[email-masked]>
Date: Mon, 7 Jan 2002 09:35:02 -0800 (PST)

All routers (including non-queriers) must process the IGMP reports.
The non-querier routers may ignore the IGMP leave messages.
But must process general query and group specific queries as well.

- Paras.

---

From: Mark Handley <[email-masked]>
Date: Mon, 07 Jan 2002 10:13:16 -0800

>reports, it does. Rather it just relies on the Querier to 'query' for them.

If you're a PIM router, you MUST process IGMP membership information
if:

 1. You're the DR.
 2. You won an assert - you become the effective DR for that group or (S,G).

Because of (2), it's probably a good idea for all PIM routers to
process and store all IGMP membership information.

Deciding whether to process IGMP membership reports in PIM is
completely unrelated to who won the IGMP querier election.

Cheers,
	Mark