Subject: [pim] ??confused state?? :-)

From: "Prashant Jhingran" <[email-masked]>
Date: 28 Aug 2002 13:54:50 -0000

hi all,
        Please have a look at the following topology:-

  The following topology can be a part of a large multicast 
network.

 	RECEIVER       SENDER
      |_| DDR           |_| SDR
  	|		      |
  	|			|
  	|			|
  	|			|
  	|			|
  	|			|
  	|    _____________|
  	|___|
  	|   | IR
  	|___|
  	|
  	|
  	|
  	|
       |___| other links
  	|   |_
      _|___| RP
  	|   |

  Now my doubt is regarding the sequence of events which shall 
take place once the SDR starts sending Register messages towards 
the RP.
Lets assume that the (*, G) tree is already stabilished before the 
source starts pumping datapackets.

At the RP,interface to reach both the source and the receivers is 
same so there is a possibility of an assert like but not exactly 
assert situation at the RP,if not always but at least for some 
time.

  I feel that the following should be the sequence of events:-

  1. RP receives Register mesg. from SDR.
  2. RP de-capsulates the same and sends multicast data towards    
DDR    via IR.
  3. Register threshold exceeds at RP and hence it sends a SG join 
towards Source.
  4. SDR starts sending native data packet along with register 
mesg towards RP, again via IR.
  5. IR should maintain both (S, G) and (*, G) entries as a result 
of which it should fwd the data packets to RP as well as towards 
DDR.
  6. Now RP receives datapacket on the (*, G) Out going interface 
and as a result might indicate Assert..but truly speaking assert 
can happen on a multi-access link !!!
            And the chaos begins!!!
  7. IR should also trigger (S, G, rpt) prune towards RP.
  8. RP should respond to it by pruning off the interface towards 
IR.
  9. RP should also send Register Stop towards the SDR.
  10. SDR should stop sending registers.
  11. RP should also sent (S, G) prune towards the Source via 
IR.
  12. IR has to fwd the (S, G) prune towards SDR !! (should it 
really do this ?????)
  13. Source is pruned off at SDR.

  And a fresh cycle starting from the step1 begins(once the keep 
alive timer expires at IR).

I would like to have comments on my thinking and please suggest 
the correct set of actions.I feel the above topology is very 
different from the normal ones and it would be nice to have 
comments from the authors too. Please note that i am following the 
draft and not the old RFC.

thanks and regards,
Prashant

_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: Mathur Sonum-CSM109 <[email-masked]>
Date: Wed, 28 Aug 2002 20:54:59 -0500

Prashant,

After step 6, RP will send Assert packet, but this Assert (with RPT bit set) will be ignored by IR as IR has no (*,G) downstream on that interface. So there should not be any chaos. And there will not be more than one Assert messages as this branch will be Pruned by RP when RP gets (S,G,RPT) Prune from IR.

As soon as IR gets the first native data packet, it sends (S,G,RPT) Prune towards RP, and RP will then send (S,G) Prune to IR. This (S,G) Prune will not be forwarded by IR to SDR. This is because IR will have interface towards receiver in the downstream list of (S,G) entry. IR will be in the (S,G) forwarding state, which would be refreshed by data packets. RP will remain in Pruned state and should send Register Stop to the next and subsequent periodic Null Register messages.

Hope my assumptions are correct about the topology.
--
Sonum

> -----Original Message-----
> From: Prashant Jhingran [mailto:[email-masked]]
> Sent: Wednesday, August 28, 2002 6:55 AM
> To: [email-masked]
> Subject: [pim] ??confused state?? :-)
> 
> 
> hi all,