Subject: Re: [pim] Query on Upstream(S,G,rpt) State machine for triggered messages

From: "[email-masked]" <[email-masked]>
Date: Sun, 16 Feb 2003 23:29:23 -0500 (EST)

Hi pavlin,
I have a doubt regarding the part A of your reply. I have asked this previously about periodic SG RPT prunes.
Draft does not say that SG RPT prunes need to be sent when there is only (*,*, RP) state. rather it says that (S, G) RPT prunes are sent along with a (*, G) join. so when there is no state for (*, G) how can one send (S, G) RPT prunes.
Please clarify me about this.
Thanks in Advance.
rajesh.

 --- On Wed 12/18, Pavlin Radoslavov < [email-masked] > wrote:
From: Pavlin Radoslavov [mailto: [email-masked]]
To: [email-masked]
     Cc: [email-masked]
Date: Wed, 18 Dec 2002 15:29:16 -0800
Subject: Re: [pim] Query on Upstream(S,G,rpt) State machine for triggered messages 

> Hi,
> In the state machine for (S,G,rpt) triggered messages (Section 4.5.9) the
> state tranistions from "RPTNotJoined" to "Not Pruned" occurs when
> "inherited_olist(S,G,rpt)--> NON-NULL" and the reverse state tranistion from
> "Not Pruned" to "RPTNotJoined" occurs when "RPTJoinDesired(G)-->False". My
> question is why shouldnt we use the "RPTJoinDesired(G)--> TRUE" event for
> the former state tranistion (i.e) from "RPTNotJoined" to "Not Pruned".
> Doesnt this event itself convey that we have joined the RPT and thus should
> be in the Not Pruned state? 

My guess is:

 (a) We want the "Not Pruned" to "RPTNotJoined" transaction to occur
  when "RPTJoinDesired(G)-->False", because the "RPTNotJoined" state
  is the equivalent of the state when we don't need the (S,G,rpt)
  state. Keeping the (S,G,rpt) state makes sense only if there is
  (*,G) or (*,*,RP) Join, hence the "granularity" of this
  transaction happening is "per (*,G)" or "per (*,*,RP)"
  (by "granularity" here I mean that it happens when there is (*,G)
  or (*,*,RP)-specific event such as (*,*,RP) or (*,G) Join).

  (b) The "RPTNotJoined" to "Not Pruned" transaction uses the
  "inherited_olist(S,G,rpt)--> NON-NULL" event, because for
  data forwarding purpose the granularity is "per source-group", and
  therefore it needs to consider things like "lost_assert(S,G,rpt)"
  which are used in the computation of "inherited_olist(S,G,rpt),
  but are NOT used in the computation of "RPTJoinDesired(G)"

Regards,
Pavlin
_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

_______________________________________________
Join Excite! - http://www.excite.com
The most personalized portal on the Web!
_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: Pavlin Radoslavov <[email-masked]>
Date: Tue, 18 Feb 2003 17:25:58 -0800

> Please clarify me about this.

If you are referring about Section 4.5.8 "(S,G,rpt) Periodic
Messages", yes, the draft doesn't say that (S,G,rpt) Prunes are sent
along with the (*,*,RP) Joins (when there are no (*,G) Joins).
I believe this is an omission in the draft that is pending to be
resolved.

Thanks,
Pavlin