Subject: Re: [pim] PIM snooping resources

From: "dsa main" <[email-masked]>
Date: Tue, 04 Mar 2003 02:09:32 +0000

Hi Gerd,

Thank you for the info. I went through your thesis. It is pretty good.
I also came across an ietf draft 
"http://www.potaroo.net/ietf/ids/draft-tsenevir-pim-sm-snoop-00.txt" - 
expired ?? I think an up-to-date draft similar to the igmp snooping one will 
be cool..

Assume a generic scenario where MR1-MR4 are multicast routers which
support IGMPv2/v3 and PIMSNOOP is a snooping device.

          MR2
           |
           |
MR1----PIMSNOOP----MR4
           |
           |
          MR4

On each interface is it needed to keep track of all the PIM-SM join and 
prune messages like Join (*, *, RP), Prune (*, *, RP), Join (*, G),
Prune (*, G), Join (S, G, rpt), Prune(S, G, rpt), Join (S, G)
and  Prune (S, G) for building the snooping table ?? What all assumptions 
can be made to make this simple ?

Also is it needed to lookup on (S, G) rather than G when it comes to
switching/forwarding a multicast packet based on the snooping table ?

Regards
DSA

>From: Gerd Besch <[email-masked]>
>To: [email-masked]
>Subject: Re: [pim] PIM snooping resources
>Date: Tue, 04 Mar 2003 00:21:56 +0100
>
>  Hi DSA,
>
>I worte my thesis about the following subject 'Analysis and engineering of 
>the infrastructure required to support multicast traffic at an Internet 
>Exchange point' 
><http://besch.gmxhome.de/eng/thesis-gerd-besch-preface.html>
>
>Abstract:
>"This thesis discusses using 'PIM-snooping' as a solution for handling
>multicast traffic at a Multicast Internet Exchange Point (MIX) on a shared
>Gigabit-Ethernet switch fabric. Existing MIXs essentially treat multicast
>traffic as broadcast traffic. Switch ports are flooded due to the lack of
>information on how to efficiently replicate multicast traffic only onto 
>ports
>where receivers for specific multicast groups exist.
>Protocol Independent Multicast Join/Prune messages can be exploited to
>provide necessary multicast containment."
>
>If you're interested to receive a copy (PDF) of my thesis just drop me a 
>line.
>
>cheers,
>Gerd
>
>ps: real-name postings would be really coooooool! ;))))))
>
>dsa main wrote:
>
>>Hi All,
>>
>>I am looking for some pointers on PIM snooping...
>>
>>Is there any documents on PIM snooping implementation ?
>>
>>Regards
>>DSA
>
>
>
>
>_______________________________________________
>pim mailing list
>[email-masked]
>http://catarina.usc.edu/mailman/listinfo/pim

_________________________________________________________________
Tired of spam? Get advanced junk mail protection with MSN 8. 
http://join.msn.com/?page=features/junkmail

_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: Marshall Eubanks <[email-masked]>
Date: Tue, 4 Mar 2003 08:36:13 -0500

PIM snooping is of most use at exchanges, where traffic is routed 
between AS's.
Interdomain multicast traffic is (from the router viewpoint) _all_ SSM - 
i.e., there are
only (S,G) joins across a domain boundary. Therefore it is my contention 
that PIM snooping is
best accomplished by focusing on (S,G) traffic only.

This also means that the market for PIM snooping is likely to be much 
smaller than
for IGMP snooping.

On Monday, March 3, 2003, at 09:09  PM, dsa main wrote:

> expired ?? I think an up-to-date draft similar to the igmp snooping one 
> will be cool..
>

I may be missing something, but I do not see the need for PIM snooping 
in this scenario.
(Or is PIMSNOOP attached to MR2 and MR4 - which is not how the ascii art 
looks here ?)

BTW, I know that Foundry has implemented a type of PIM snooping. If 
there are others I would like to know
about them.

                                   Regards
                                  Marshall Eubanks

> and  Prune (S, G) for building the snooping table ?? What all 
> assumptions can be made to make this simple ?
>
>> I worte my thesis about the following subject 'Analysis and 
>> engineering of the infrastructure required to support multicast 
>> traffic at an Internet Exchange point' 
>> information on how to efficiently replicate multicast traffic only 
>> onto ports
>> If you're interested to receive a copy (PDF) of my thesis just drop me 
>> a line.
>>
>> cheers,
>> Gerd
>>

T.M. Eubanks
Multicast Technologies, Inc.
Phone : 703-293-9601       Fax     : 703-293-9609
e-mail : [email-masked]
http://www.multicasttech.com

Test your network for multicast :
http://www.multicasttech.com/mt/
  Status of Multicast on the Web  :
  http://www.multicasttech.com/status/index.html

---

From: Gregory Bell <[email-masked]>
Date: Tue, 04 Mar 2003 09:28:26 -0800

> there are others I would like to know

You might look at Cisco's RGMP.  I think it bears roughly the same 
relationship to PIM snooping that CGMP bears to IGMP snooping (ie, 
neighboring routers do some of the work in each case).

PIM snooping might be useful in the enterprise as well.  If you have a 
layer-two core interconnecting half a dozen PIM routers, you might want 
to avoid flooding on the switch.

- Greg

-- 
Gregory Bell
Network Systems Engineer
Lawrence Berkeley National Laboratory
1 Cyclotron Road, Mail Stop 50E0101
Berkeley, CA 94720-8140 USA
(510) 486-6817
[email-masked]