Subject: [pim] (S,G) Assert state machine in Winner state.

From: "Sridhar Vallepalli" <[email-masked]>
Date: Sat, 1 Mar 2003 15:19:03 -0800

A question about router in assert winner state never getting out of it untill either the interface or the route gets deleted. 

Consider the topology below: R1 and R2 are upstream routers and R3 is the downstream router 

                    +----------+                           +----------+ 
                    |      R1   |                            |     R2    | 
                    |             |                            |             | 
                    +----+----+                           +-----+---+ 
                           |                                           | 
         ---------------+----------------+------------------+-------------- 
                                                 | 
                                                 | 
                                         +-----+------+ 
                                         |                 | 
                                         |        R3     | 
                                         +-------------+ 

1) R1 has the (S,G) state with a better metric to source than R2 and moved to winner state while R2 is in Loser state. 
2) R3 is tracking the assert state by storing the assert winner. 
3) R2 has gone down leaving R1 alone in the upstream routers. 

There is no event under the above scenario where R1 will move back to the NOINFO state and freeup all the router resources particularly assert timer, which periodically keeps sending assert messages. Similarly R3 will be processing these assert messages and will re/start its assert timer. 

The only event which triggers to move to NOINFO is when the interface is deleted from oif of (S,G) entry or the entry itself getting deleted. 

When there are a large number of (S,G) routes this would not only consume significant router resources in terms of memory, timers and cpu utilization, but also will be flooding the network with assert messages periodically. 

I was wondering if this is intentionally left out this way or is there anyway this can be avoided???

Thanks

Sridhar

---

From: Mark Handley <[email-masked]>
Date: Sun, 02 Mar 2003 12:31:03 -0800

We made a policy decision not to optimize corner cases - PIM-SM is too
complex already.  This is a corner case, and not considered worthy of
optimization.

 - Mark
_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim