Subject: [pim] CouldRegister(S,G)

From: "Sridhar Vallepalli" <[email-masked]>
Date: Fri, 18 Apr 2003 12:41:50 -0700

Hi, 
	If first hop router doesn't have unicast reachability to RP should the router take the hit of encapsulation, finally to be dropped at the unicast forwarding. Can CouldRegister(S,G) check if RP(G) is reachable before returning TRUE or FALSE.
This way appropriate state events in per-(S,G) register state-machine will happen.

Please comment.

Thanks
Sridhar

---

From: John Zwiebel <[email-masked]>
Date: Fri, 18 Apr 2003 14:16:58 -0700

IMHO, this is an implementation specific question.

NOTE: one problem with PIM is that often mpackets are sent
with TTL that isn't large enough to get to the RP, but that
doesn't prevent the PIM register from getting to the RP to
create state.  An implementation might choose to set the
encapsulation TTL to the same as the mpacket to prevent
stqate from being created and disappearing over and over again.

On Friday, April 18, 2003, at 12:41 PM, Sridhar Vallepalli wrote:

> Hi,
>         If first hop router doesn't have unicast reachability to RP 
> should the router take the hit of encapsulation, finally to be dropped 
> at the unicast forwarding. Can CouldRegister(S,G) check if RP(G) is 
> reachable before returning TRUE or FALSE.
>

---

From: "Sri Manikandan" <[email-masked]>
Date: Sat, 19 Apr 2003 14:20:56 +0530

unsubscribe

***************************************************************************
This message is proprietary to Future Software Limited (FSL) 
and is intended solely for the use of the individual to whom it
is addressed. It may contain  privileged or confidential information 
and should not be circulated or used for any purpose other than for 
what it is intended. 

If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient,
you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message. 
FSL accepts no responsibility for loss or damage arising from 
the use of the information transmitted by this email including
damage from virus.
***************************************************************************