Subject: [pim] PIM BSR Draft

From: "bharat_joshi" <[email-masked]>
Date: Wed, 7 May 2003 19:54:43 +0530

Hi,

I was going through the C-BSR draft. 

Can somebody explain what will happen when a new Router comes up and can be the preferred BSR in the PIM domain?

The draft mention that a router will be in pending state after start-up and start BS timer to BS timeout value.

Lets say that the DR on the network, pass on the BSM to this new router.

Lets assume that this new router is having higher priority and so should be elected as a BSR.

Now the state-machine shows that when in pending state and a non-preferred BSM is received ..don't do anything.

Now when the BS timer will expire, this new router will think that he has become the new elected BSR but he doesn't have any information about the C-RPs till now as C-RPs would be unicasting their info to the old BSR.

Either there is something wrong here or I am not able to understand it properly.

Can somebody help me in understanding this??

TIA,

Best Regards,
Bharat

==============================
Infosys Technologies Ltd.
Bangalore, India

_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: Rishabh Parekh <[email-masked]>
Date: Wed, 7 May 2003 17:37:09 -0700

Bharat,
When a new router comes up and it becomes an Elected-BSR from a Pending-BSR, 
it originates a BootStrap message. This BS message is received at the 
Candidate-RPs (and other ordinary non-CRP non-CBSR PIM routers) and they 
appoint the new router as the BSR. The C-RPs then advertise thier C-RP 
messages to the newly elected BSR which builds and distributes the RP set 
information in subsequent BS messages.

I hope this helps to clarify your doubts,
Rishabh.

On Wednesday 07 May 2003 07:24 am, bharat_joshi wrote:
> Now when the BS timer will expire, this new router will think that he has
> become the new elected BSR but he doesn't have any information about the
> C-RPs till now as C-RPs would be unicasting their info to the old BSR.
>