Subject: Fwd: [pim] Query regarding Upstream (*,G) state machine

From: Madhu Reddy <[email-masked]>
Date: Fri, 30 May 2003 08:24:12 -0700 (PDT)

Trying again as I did not get an answer. Thanks.

Madhu

> 
> In Joined State, there are two events specified in
> the
> table : "RPF'(*,G) changes" and "RPF'(*,G) changes
> due
> to Assert". What is the difference between the two? 
> In the description, there is description only for
> one
> of these events and the description for event 
> "RPF'(*,G) changes" actually matches that of the
> event
> 
> "RPF'(*,G) changes due to Assert". Any help is
> appreciated. Thanks.
> 
> Madhu
> _______________________________________________
> pim mailing list
> [email-masked]
> http://catarina.usc.edu/mailman/listinfo/pim

_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: Pavlin Radoslavov <[email-masked]>
Date: Fri, 30 May 2003 11:54:49 -0700

> Trying again as I did not get an answer. Thanks.

I think that the I-D needs to be corrected here (actually, someting
ago I had already marked my copy of the draft re. exactly same
thing, which I should bring to the attention of one of the authors
sometime very soon :)

I believe the correction should be like:
 * Remove "RPF'(*,G) changes due to Assert" from the table
 * Replace "RPF'(*,G) changes" with something like
   "RPF'(*,G)) changes for a reason other than MRIB.next_hop(RP(G))
   changes".
 * Do the same replacing as above in the paragraph that later
   describes this action (page 49 in the 07 PS version).
 * Remove "due to an Assert(*,G)( on the RPF_interface(RP(G))." from
   the first sentence in the above paragraph and replace it with
   something similar as above.

Regards,
Pavlin