Subject: [pim] RE: PIM-SM, RFC 2362

From: "Liguori, Ralph" <[email-masked]>
Date: Thu, 15 May 2003 08:03:41 -0400

Can you assist in identifying any modifications that allow PIM to span
inter-domain wide-area networks.  Also, is there an alternate multicast
protocol that will that span inter-domain wide-area networks ?
Thank you,
Ralph Liguori
Networks Division (IN11)
DISA Interoperability Directorate
Fort Monmouth, NJ  07703
732-427-6888 Fax: 732-427-6798
DSN: 987-XXXX

-----Original Message-----
From: ahmed helmy [mailto:[email-masked]]
Sent: Wednesday, May 14, 2003 5:58 PM
To: Liguori, Ralph
Subject: Re: PIM-SM, RFC 2362

Hi,

PIM-SM was basically designed for intra-domain networks.
Recently there has been several modifications and suggestions for protocols
that 'glue' several PIM-SM domains together, that span inter-domain
wide-area networks.

I have stopped working on PIM-SM spec several years ago, but you can contact
the active pim group at [email-masked]

Regards,
-Ahmed
-------

Ahmed Helmy
Assistant Professor of Computer Networks
Department of Electrical Engineering
University of Southern California
http://ceng.usc.edu/~helmy

----- Original Message -----
From: "Liguori, Ralph" <[email-masked]>
Date: Wednesday, May 14, 2003 3:15 pm
Subject: PIM-SM, RFC 2362

> Mr. Helmy, does PIM-SM allow routers to efficiently route multicast groups
> that span both intra- and inter-domain wide-area networks ?
> Thanks,
> Ralph Liguori
> Networks Division (IN11)
> DISA Interoperability Directorate
> Fort Monmouth, NJ  07703
> 732-427-6888 Fax: 732-427-6798
> DSN: 987-XXXX
> 
> 
_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: Marshall Eubanks <[email-masked]>
Date: Thu, 15 May 2003 23:27:18 -0400

Depends on what you want to do :

A PIM domain can be pretty wide (it can include more than one 
autonomous system, for example - CANARIE does this) or

PIM joins can cross domain boundaries (this is how interdomain 
multicast is done). However, all inter (PIM) domain
joins are (S,G) joins (there are no interdomain (*,G) joins) so

- In ASM you need a means of source discovery - presently done by MSDP
- In SSM all joins are (S,G) anyway, so nothing need be done.

If you want to do true interdomain multicast, you will also need to run 
MBGP.

>> 732-427-6888 Fax: 732-427-6798
                                  Regards
                                  Marshall Eubanks

T.M. Eubanks
Multicast Technologies, Inc.
e-mail : [email-masked]
http://www.multicasttech.com

Test your network for multicast :
http://www.multicasttech.com/mt/