Subject: RE: [pim] Longest prefix match!!!

From: "bharat_joshi" <[email-masked]>
Date: Wed, 28 May 2003 17:44:45 +0530

Hi,

I think a PIM-SM implementation must give warning
when a admin configure the group-range with this
kind of mask.

AFAIK, 224.0.0.0/16 is not a valid combination so
it should never be used.

Thanks,
Bharat

-----Original Message-----
From:	Ganapath [mailto:[email-masked]]
Sent:	Wed 5/28/2003 1:21 PM
To:	[email-masked]
Cc:	
Subject:	[pim] Longest prefix match!!!

Hi,

It's all related to longest(highest) prefix match. We would like 
to know if there is a difference between 224.0.0.0/4 and 
224.0.0.0/16 when we have the group 224.0.0.1(just an example)

When we consdier the prefix values given by these two group 
ranges
it comes out to be,

    Group range     Group addr           Mask addr        Prefix 
value
1. 224.0.0.0/4  => 224.0.0.0       AND  240.0.0.0      => 224
2. 224.0.0.0/16 => 224.0.0.0       AND  255.255.0.0    => 224

Which one should we choose when we have the group 224.0.0.1??
One point is, since both the prefixes are offering the scope for 4 
and 8 bits, and we don't have bits set after 4 bits and before 8 
bits in 224.0.0.1.

So any prefix should be fine in this case.

Of course things will be different when we have 224.1.0.0/16 and 
224.0.0.0/4 and have to select one of these two prefixes for a 
group address 224.1.0.0.

comments please,

Regards,
Ganapath
Corecess Inc

___________________________________________________
Get email that means BUSINESS! me @ mycompany.com.
Just Rs.1499/year.
To start, click http://www.rediffmailpro.com

_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: Rajamanickam jaganbabu <[email-masked]>
Date: Wed, 28 May 2003 16:59:33 +0100 (BST)

Hi,
   We can have both 224.0.0.0/4 and 224.0.0.0/16 in the group-range table, both are very valid combination. It is the best to chose the longest prefix match (i.e) 224.0.0.0/16. 
   
For Example, 
       If you have both both the routes in your group-range table and if you are receiving a group address 224.0.12.2, then according to the match prefix we should be getting 224.0.0./16 as a output. At the same time if we get 224.1.12.2, then the best match would be 224.0.0.0/4, so both the above routes mentioned are very valid route entries.
 
Thanx,
Jags

bharat_joshi <[email-masked]> wrote:
Hi,

Thanks,
Bharat

-----Original Message-----
From: Ganapath [mailto:[email-masked]]
Sent: Wed 5/28/2003 1:21 PM
To: [email-masked]
Cc: 
Subject: [pim] Longest prefix match!!!

Hi,

comments please,

Regards,
Ganapath
Corecess Inc

_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim
Catch all the cricket action. Download Yahoo! Score tracker