Subject: [pim] IGMPv3 and RFC 2715

From: "Shankar Vasudevan" <[email-masked]>
Date: Wed, 21 May 2003 14:21:29 GMT

Hi *,

  RFC 2715 specifies how a IGMP-only component interops with other multicast routing protocols. This covers IGMPv2 only. Is there a similar specification which extends the same interop rules to IGMPv3 ?

 I am more interested in the behaviour of a router which has the PIM-SM on some links and IGMPv3 on other links, and when a (S,G) exclude is received and how this is reflected in the PIM-SM protocol.

  Is there any implementation which has IGMPv3 (S,G) exclude messages triggering PIM-SM (S,G,rpt) prunes ?
 
Best Regards,
shankar
_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: John Zwiebel <[email-masked]>
Date: Wed, 21 May 2003 10:06:56 -0700

On Wednesday, May 21, 2003, at 07:21 AM, Shankar Vasudevan wrote:

> Hi *,
>
>   RFC 2715 specifies how a IGMP-only component interops with other 
> multicast routing protocols. This covers IGMPv2 only. Is there a 
> similar specification which extends the same interop rules to IGMPv3 ?
>
>  I am more interested in the behaviour of a router which has the 
> PIM-SM on some links and IGMPv3 on other links, and when a (S,G) 
> exclude is received and how this is reflected in the PIM-SM protocol.
>

IGMPv3 is used with SSM.  RP-bit prunes are part of ASM.
It would be "better" to convince your customer that they want to move 
to SSM than
to try to integrate IGMPv3 (S,G) include/exclude messages into ASM.
(I'll admit I don't see why runbox would be interested in ASM).