Subject: [pim] Longest prefix match!!!

From: "Ganapath" <[email-masked]>
Date: 28 May 2003 07:51:30 -0000

Hi,

It's all related to longest(highest) prefix match. We would like 
to know if there is a difference between 224.0.0.0/4 and 
224.0.0.0/16 when we have the group 224.0.0.1(just an example)

When we consdier the prefix values given by these two group 
ranges
it comes out to be,

    Group range     Group addr           Mask addr        Prefix 
value
1. 224.0.0.0/4  => 224.0.0.0       AND  240.0.0.0      => 224
2. 224.0.0.0/16 => 224.0.0.0       AND  255.255.0.0    => 224

Which one should we choose when we have the group 224.0.0.1??
One point is, since both the prefixes are offering the scope for 4 
and 8 bits, and we don't have bits set after 4 bits and before 8 
bits in 224.0.0.1.

So any prefix should be fine in this case.

Of course things will be different when we have 224.1.0.0/16 and 
224.0.0.0/4 and have to select one of these two prefixes for a 
group address 224.1.0.0.

comments please,

Regards,
Ganapath
Corecess Inc

___________________________________________________
Get email that means BUSINESS! me @ mycompany.com.
Just Rs.1499/year.
To start, click http://www.rediffmailpro.com

_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: John Zwiebel <[email-masked]>
Date: Wed, 28 May 2003 07:28:17 -0700

FWIW, you should probably match on 224.0.0.0/24
since this is reserved for link-local addresses.

On Wednesday, May 28, 2003, at 12:51 AM, Ganapath wrote:

> Hi,
>
> It's all related to longest(highest) prefix match. We would like to 
> know if there is a difference between 224.0.0.0/4 and 224.0.0.0/16 
> when we have the group 224.0.0.1(just an example)
>
> When we consdier the prefix values given by these two group ranges
> it comes out to be,
>
>    Group range     Group addr           Mask addr        Prefix value
> One point is, since both the prefixes are offering the scope for 4 and 
> 8 bits, and we don't have bits set after 4 bits and before 8 bits in 
> 224.0.0.1.
>
> 224.0.0.0/4 and have to select one of these two prefixes for a group 
> address 224.1.0.0.
>
> comments please,
>
> Regards,
> Ganapath
> Corecess Inc
>
>