Subject: [pim] about the keep alive timer

From: "Zhang Yanxing" <[email-masked]>
Date: Mon, 19 May 2003 16:57:32 +0800

about the keep alive timer

I noted that in the specification, the (S,G) entry 
should have the keep alive timer, I am not very clear 
what's main function.I think the join timer expiry 
or all the joined interfaces are pruned, the entry 
can be deleted. I think the 
first hop router (DR) with directly connected source 
and the RP , which keep the tiemr, may be have some 
sense. Can anyone clarify for me ? Thanks
_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: John Zwiebel <[email-masked]>
Date: Mon, 19 May 2003 07:47:47 -0700

> sense. Can anyone clarify for me ? Thanks

Except for the last-hop router, you are correct that the join/prune
messages can be used to keep state alive on the shortest-path.
And yes, the DR and the RP are the other places this is
required.

FWIW: quite often when trying to debug a network configuration
problem, monitoring the (S,G) keepalive timer is very helpful.