Subject: RE: [pim] about the (*,G),(S,G) entry creation and deletion

From: "Bandi, Sarveshwar" <[email-masked]>
Date: Wed, 21 May 2003 02:43:41 -0400

One comment, I dont think the spec says explicitly that a (*,G) should exist
when (S,G) exists. If someone were to have only SSM routes in a network,
having (*,G) routes would not make any sense. I think creation of (*,G)
route when (S,G) routes are created is an implementation issue. We have an
implementation where (*,G) routes created as and when needed.

Would love to hear others comments on this

Regards,
Sarvesh

-----Original Message-----
From: Zhang Yanxing [mailto:[email-masked]]
Sent: Wednesday, May 21, 2003 8:06 AM
To: [email-masked]
Subject: [pim] about the (*,G),(S,G) entry creation and deletion

      I think it maybe one implementation problem, I want to speak out my
thought to see if it is correct.
Multicast Route entry is created when some interfaces receive the (*,G) or
(S,G)  join message. 
When all the joined before interfaces recieve prune message(after the prune
override interval) or
the join timer expires, the entry will be deleted. This mechanism shows the
difference between the DM and 
SM.
     But at the DR with the directly connected senders and the RP, I think
the (S,G) entry creation is something 
like the DM, it is built by the traffic driven.
     Another point is that does the specification imply that if (S,G) exist,
the (*,G) should exist too?
     Welcome comments, Thanks.
_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim
_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: "Zhang Yanxing" <[email-masked]>
Date: Wed, 21 May 2003 16:04:10 +0800

-----Original Message-----
From: Prashant Jhingran [mailto:[email-masked]]
Sent: 2003年5月21日 15:06
To: Zhang Yanxing; [email-masked]
Subject: RE: [pim] about the (*,G),(S,G) entry creation and deletion

Hi,
--*,G is definitely not a must for SG entry. 
If a DDR receives a Source specific IGMP (v3) report then it forms a SG tree and this may happen for both SSM and non-SSM group range.

--At RP the creation of SG entry is influenced by presence of  Receivers for the group. If no receivers then RP is supposed to send a Register stop and no need for SG state creation.
    The (S,G) entry is not created when no receivers on the RP tree for the group, but druing the register_suppression time, if a reciever emerge on the RP tree for the group, The RP may wait at most the register_suppression to create the the (S,G) and send the (S,G) join towards the source.

--At SDR however it is data driven unless a source specific SG tree is formed by a DDR before source starts pumping data packets.

would like to have some comments on this.

regards,
Prashant

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Zhang Yanxing
Sent: Wednesday, May 21, 2003 8:06 AM
To: [email-masked]
Subject: [pim] about the (*,G),(S,G) entry creation and deletion

      I think it maybe one implementation problem, I want to speak out my thought to see if it is correct.
Multicast Route entry is created when some interfaces receive the (*,G) or (S,G)  join message. 
When all the joined before interfaces recieve prune message(after the prune override interval) or
the join timer expires, the entry will be deleted. This mechanism shows the difference between the DM and 
SM.
     But at the DR with the directly connected senders and the RP, I think the (S,G) entry creation is something 
like the DM, it is built by the traffic driven.
     Another point is that does the specification imply that if (S,G) exist, the (*,G) should exist too?
     Welcome comments, Thanks.
_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim
_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: Rajamanickam jaganbabu <[email-masked]>
Date: Wed, 21 May 2003 09:58:39 +0100 (BST)

Hi guys,
  We had a same kind of discussion some time back, I think it would be clear if you read the below thread, with the topology.
Thanx,
Jags

Note: forwarded message attached.

Catch all the cricket action. Download Yahoo! Score tracker

Subject: RE: [pim] doubt regard RP absence in the network
From: Rajamanickam jaganbabu <[email-masked]>
To: [email-masked], "'john nowa'" <[email-masked]>
Cc: [email-masked]
Date: Thu, 19 Dec 2002 08:50:47 +0000 (GMT)
List-Id: <pim.catarina.usc.edu>

Hi Uma,
   I think, you need to read my topology properly, where i have mensioned about IGMPV3 and not IGMPV2. If you spend some time to read the topology properly, you might not be having such a doubts (IGMPV3/V2).
Regards,
Jags
 Uma C <[email-masked]> wrote:Hello John & Jags I also agreed upon what Jags has mentioned in his topology. 
>>> 3, In case, if RP goes off, then R1 has to remove the (*,G) entry from the forwarding table and remove the inherited outgoing list, so after the (*,G) removal, the multicast forwarder looks like this.

>>> (S,G) - oiflist=2
>>> [Uma C]  Yes, multicast packets should flow on interface 2. I agree with this. 
 Pl confirm only this -* Received IGMPv2 Join, created a (*,G) entry. * Switched to SPT, hence (S,G) entry is created. (*, G) and (S, G) entry holds the same oif. * Packets are flowing through SPT.* Now when the RP information is not present. (*,G) entry is deleted. Will the (S,G) entry exists ? Would the data packets flow ?.  Note:- In all this discussion I was only referring to receivers joining through IGMPv2 Join. In the case of IGMPv3 Join ie., source specific Join I agree that packets will be flowing irrespective of RP informations present or not. Hope this time I have expressed my thoughts clearly. Thanks & RegardsC.Uma -----Original Message-----
From: john nowa [mailto:[email-masked]]
Sent: Wednesday, December 18, 2002 9:09 PM
To: Rajamanickam jaganbabu; [email-masked]
Cc: [email-masked]
Subject: RE: [pim] doubt regard RP absence in the network

hello umaaa, 
       I guess, whatever jags referring is correct. According to his topology, we can still forward the multicast packet for (S,G). 
John 
 Rajamanickam jaganbabu <[email-masked]> wrote: 
Hi uma, 

Whatever I have mentioned below was only with respect to SM domain (I haven't mentioned SSM case, which is altogether a different story). I don't understand why you need to delete even (S,G) if you don't have (*,G), draft doesn't say that. But according to the draft, we need to remove only inherited outlist from (S,G) entry, but in our case we have immediate outgoing list in (S,G) which is not a part of inherited list (if the (S,G) immediate outlist and inherited outlist are same then only we should remove (S,G) entry from your multicast forwarding table), so there is no point and we should not delete (S,G) entry from the multicast routing table even if (*,G) entry is deleted. 

I hope u understand the logic. 

Regards, 

Jags

 Uma C <[email-masked]> wrote: Hello Jags Pl find my response inlined with the tag <UMA>. RegardsC.Uma -----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Rajamanickam jaganbabu
Sent: Wednesday, December 18, 2002 2:44 PM
To: [email-masked]
Cc: [email-masked]
Subject: RE: [pim] doubt regard RP absence in the network

Hi uma,

1. Even in normal SM case, multicast forwarding is possible even if we don't have RP information. 
[Uma C] I guess not. In the example you had given includes SSM also. 

=========

2. When we are deleting (*,G) entry, it is not mandatory to remove all the (S,G) entry from the multicast forwarder unless and until all the outgoing interface list is null.
[Uma C] I agree with you. And in the SM case there cannot be a situation when (*,G) is deleted but (S,G) still remains.

==================

I have explained how it can happen using the following topology (fig. as an attachment).

Explanation:

1. If Rec_1 sends an (*,G) IGMP join to the PIM router "R1", then the PIM forwarding table at R1 look like 

(*,G) - oiflist=1

2. After some time, if Rec_2 send (src,G,1) IGMPV3 join, then the PIM forwarding table at R1 looks like

(S,G) - oiflist=1,2

(*,G) - oiflist=1

In the above forwarding table while adding (S,G) entry, the inherited outgoing list will be 1 and the immediate outgoing list will be 2, so consolidating the outgoing interface for (S,G) will 1 and 2

3, In case, if RP goes off, then R1 has to remove the (*,G) entry from the forwarding table and remove the inherited outgoing list, so after the (*,G) removal, the multicast forwarder looks like this.

(S,G) - oiflist=2
[Uma C]  Yes, multicast packets should flow on interface 2. I agree with this. But the discussion started with whether multicast packets can be forwarded in PIM-SM domain only (This is want Rajesh asked for) when RP information is not present. In this case do not execute the step 2, so the (*,G) and (S,G) will hold the same oif, and hence both of these entries get deleted. So the multicast packets stop flowing.

================

So even in SM. it is not necessary to remove all the (S,G) entries if you remove (*,G) entry from the multicast forwarding table.
[Uma C] I guess not in the SM domain (which doesnot include SSM). I apreciate the interest you had taken to explain the situation with a topology. Thanks Jags.

=================

Regards,

Jags

Uma C <[email-masked]> wrote: 

Hello Jags 

I guess in the case of IGMPv3, we do not create any (*,G) entry as the Group range for SSM is different. And as you said we can still forward the packets whether there is RP information or not. 

But in the case of SM only, where (*,G) and (S,G) entry exists and (S,G) entry holds the oif of the (*,G), if the RP information is not present - 

* (*,G) will be deleted and oif learnt from (*,G) will be deleted from (S,G) also, irrespective of whether local receivers present or not. 

* When the RP information is learnt again, (*,G) entry would be re-created if the receivers are still present. 

Do you still think if RP information is not present (in the case of SM only), multicast packets would flow ? 

Thanks & Regards 

C.Uma 

-----Original Message-----
From: Rajamanickam jaganbabu [mailto:[email-masked]]
Sent: Wednesday, December 18, 2002 11:16 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [pim] doubt regard RP absence in the network

Hi Uma, 

If there is an IGMPV3 request from the receiver, asking for (S,G,I) join to a particular source, then we will be having an (S,G) entry, which will be the super set of (*,G) outgoing list. If we lost (*,G) information, then it will affect (S,G) inherited outgoing list but there is a possible case where we can have immediate outgoing list exist for (S,G) (which is not in inherited outgoing list), so at this point even we delete (*,G) entry from our multicast forwarding table still (S,G) entry will be existing in the multicast forwarding table.

So my conclusion is, in the above case even if we lost our RP information, still we can forward the multicast packet using (S,G) information for a source "S". 

Thanx, 

Jags

Uma C <[email-masked]> wrote: 

Hello Jags 

When there is no RP information - 

1. (*,G) entry would surely get deleted. Outgoing interface in that (*,G) and (S,G) also gets deleted. So how are the packets still flowing ? 

2. If the (*,G) entry alone gets deleted because of the RP information not present and when the receiver leave the group, will the (S,G) entry get deleted ?. If yes how ? On what basis will this (S,G) entry get deleted. 

I guess the entries at SPT built routers would get deleted only when source of the multicast packet stops sending packets. 

I feel that, when the (*,G) entry gets deleted, (S,G) entry also would be deleted and there want be a case in which multicast packets will be flowing. Well I haven't thought about SSM case. 

Pl correct me if I am in wrong in my understanding. 

Thanks & Regards 

C.Uma 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Rajamanickam jaganbabu
Sent: Tuesday, December 17, 2002 8:38 PM
To: [email-masked]; [email-masked]
Subject: Re: [pim] doubt regard RP absence in the network

Hi rajesh, 

If the receiver and the source has the Source Path Tree established (i.e if we have (S,G) entry in the Multicast forwarding table), then irrespective of the RP information availability, the multicast packet will be forwarded. 

I hope the above information will help you, if i have understood your question correctly. 

Regards, 

Jags 

"[email-masked]" <[email-masked]> wrote: 

Hi,
I have the following doubt,

If there is no RP in the network or all the RPs expire in the network. Can there be packet forwarding activity in a PIM-SM (only) domain. In clear my doubt is can the receivers switched over to the packet forwarding via SPT still continue to receive the data packets even if there is not RP information with him.
thanks in advance
rajesh,

Join Excite! - <http://www.excite.com/>
The most personalized portal on the Web! 

Catch all the cricket action. Download Yahoo! Score tracker <http://in.sports.yahoo.com/cricket/tracker.html>

Catch all the cricket action. Download Yahoo! Score tracker <http://in.sports.yahoo.com/cricket/tracker.html>

 Catch all the cricket action. Download Yahoo! Score tracker

 Catch all the cricket action. Download Yahoo! Score tracker

 Catch all the cricket action. Download Yahoo! Score tracker

Catch all the cricket action. Download Yahoo! Score tracker