Subject: [pim] Small doubt regarding the assert

From: "[email-masked]" <[email-masked]>
Date: Tue, 28 Oct 2003 08:38:43 -0500 (EST)

Hi all,
Why does the draft state that. For the data triggered asserts the source address MAY be set to the actual source of the data packet. Why can't it be said that the Source address in the assert for data packet arriving on the olist of a (*, G) state MUST be INADDR_ANY.
Can I know the reason why it should be that way. Is it required to maintain backward compatability?
Thanks in advance
Rajesh.

_______________________________________________
Join Excite! - http://www.excite.com
The most personalized portal on the Web!

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 29 Oct 2003 05:18:11 -0500 (EST)

Thank you very much.
I have one more doubt. Consider the following scenario.

      R1             R2
       |              |
       |              |
       ----------------     
              |
              |
              R3

In the above case consider both R1 and R2 had down stream state for (*, G) or (S, G). Asserts will then happen between R1 and R2. Let us consider R2 wins the assert hence R1 will go to "Iam Assert Loser" state. But in R1 consider that after some time the Assert state machine of R1 goes into "No Info State" due to "could Assert" becoming false . Now it is clear that R2 has no worries and can forward traffic on the lan even without the help of Assert state machine. But to my understanding Draft provides no method by which R2 can forget about its assert state machine and start forwarding on the lan. Why wasnt it taken care in the draft. Is it left to the implementor?
Please forgive me and point me to the section if such technique already exists in the draft.

Thanks in advance
rajesh.

 --- On Tue 10/28, Isidor Kouvelas < [email-masked] > wrote:
From: Isidor Kouvelas [mailto: [email-masked]]
To: [email-masked]
     Cc: [email-masked]
Date: Tue, 28 Oct 2003 11:51:13 -0800
Subject: Re: [pim] Small doubt regarding the assert 

<br>If the data packet that triggered the assert was forwarded on the link<br>by a router with (S,G) state, then a (*,G) assert with an INADDR_ANY<br>source address will not resolve the forwarding conflict. The reason is<br>that when the router with the (S,G) state receives the assert it will<br>not know that it has to respons with an (S,G) assert. <br>The forwarding conflict will have to wait to be resolved when the<br>router with the (*,G) state forwards a data packet onto the link and<br>the router with the (S,G) state responds with the assert.<br>By providing the source address of the data packet in the (*,G) assert<br>you optimise this behaviour by allowing the router with the (S,G)<br>state to respond immediately thus eliminating the additional delay.<br><br>Isidor<br><br>"[email-masked]" writes:<br>><br>>Hi all,<br>>Why does the draft state that. For the data triggered asserts the source addre<br>>ss MAY be set to the actual source of the data packet. Why can't!
  it be said th<br>>at the Source address in the assert for data packet arriving on the olist of a<br>> (*, G) state MUST be INADDR_ANY.<br>>Can I know the reason why it should be that way. Is it required to maintain ba<br>>ckward compatability?<br>>Thanks in advance<br>>Rajesh.<br>><br>><br>><br>><br>>_______________________________________________<br>>Join Excite! - http://www.excite.com<br>>The most personalized portal on the Web!<br>><br>>_______________________________________________<br>>pim mailing list<br>>[email-masked]<br>>https://www1.ietf.org/mailman/listinfo/pim<br>><br>