Subject: [pim] What is the difference between RPF Neighbor and RPF' Neighbor

From: "Rabindranath Das" <[email-masked]>
Date: Thu, 9 Oct 2003 17:52:43 +0530

PIM DM Draft is not very clear about the differences between RPF neighbor and RPF' neighbor.
What I understood is, for a DUT any neighbor on the same LAN as the RFF interface
(of a DUT for a particular source S) is called RPF Neighbor; but when DUT's routing
table is concerned to reach source S then the routing table will recommend one of the
RPF neighbor as the next hop or the gateway. That is probably the RPF' neighbor.
 
Please let me know if I am making any mistake. 

--Rabin
_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: John Zwiebel <[email-masked]>
Date: Thu, 9 Oct 2003 10:50:27 -0700

RPF neighbor is the one the IGP points to as the next-hop toward the 
source
RPF' neighbor is the one that is actually used and it may be set by an 
assert
	for instance.

The idea that all routers on that lan are RPF neighbors isn't quite 
right.

---

From: Prashant Jhingran <[email-masked]>
Date: Mon, 13 Oct 2003 14:43:30 +0530

Hi,
            As per the draft:

neighbor RPF'(S,G) {
  if ( I_Am_Assert_loser(S, G, RPF_interface(S) )) {
    return AssertWinner(S, G, RPF_interface(S) )
  } else {
    return MRIB.next_hop( S )
  }
}

while the RPF nbr is simply "MRIB.next_hop( S )" .

Now  "MRIB.next_hop( S )" cannot yield  "any neighbor on the same LAN as the
RFF interface" as it  is dependant on routing database MRIB.

regards,
Prashant

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of John Zwiebel
Sent: Thursday, October 09, 2003 11:20 PM
To: Rabindranath Das
Cc: [email-masked]; [email-masked]; John Zwiebel
Subject: Re: [pim] What is the difference between RPF Neighbor and RPF'
Neighbor

RPF neighbor is the one the IGP points to as the next-hop toward the source
RPF' neighbor is the one that is actually used and it may be set by an
assert
for instance.

The idea that all routers on that lan are RPF neighbors isn't quite right.

PIM DM Draft is not very clear about the differences between RPF neighbor
and RPF' neighbor.
What I understood is, for a DUT any neighbor on the same LAN as the RFF
interface
(of a DUT for a particular source S) is called RPF Neighbor; but when DUT's
routing
table is concerned to reach source S then the routing table will recommend
one of the
RPF neighbor as the next hop or the gateway. That is probably the RPF'
neighbor.

--Rabin