Subject: [pim] Question on (S,G,rpt) prune state

From: Jim T <[email-masked]>
Date: Mon, 13 Oct 2003 13:02:40 -0700 (PDT)

Hi,
 
I'm new to PIM and have been going through the PIM-SM draft (v7). I had a couple of (possibly newbie) questions and hope someone will answer.
 
a) Can (S,G) and (S,G,rpt) states exist at the same time on a router? I think not because the former is on the SPT while the latter is meant for prune state on the RPT. But I'm a bit confused by the description in section 4.1.5.
 
b) This is touching upon implementation but I'm asking it to understand the whole thing better. When a (S,G,rpt) Prune is received, would a router actually create a "(S,G) style forwarding entry" which would have its olist set to that the olist of the (*,G) state minus the interface on which (S,G,rpt) Prune is received?
 
Thanks much,
Jim

---------------------------------
Do you Yahoo!?
The New Yahoo! Shopping - with improved product search

_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: John Zwiebel <[email-masked]>
Date: Mon, 13 Oct 2003 14:40:41 -0700

On Monday, October 13, 2003, at 01:02 PM, Jim T wrote:

> a) Can (S,G) and (S,G,rpt) states exist at the same time on a router?

No

> b) This is touching upon implementation but I'm asking it to 
> understand the whole thing better. When a (S,G,rpt) Prune is received, 
> would a router actually create a "(S,G) style forwarding entry" which 
> would have its olist set to that the olist of the (*,G) state minus 
> the interface on which (S,G,rpt) Prune is received?

yes, remember to keep the rp-bit set for the entry and that the
RPF is still toward the RP not the source

---

From: Pavlin Radoslavov <[email-masked]>
Date: Mon, 13 Oct 2003 19:47:47 -0700

> > a) Can (S,G) and (S,G,rpt) states exist at the same time on a router?

You could have (S,G) and (S,G,rpt) routing entries at the same
time. Though, this is more like an implementation-specific detail.
E.g., the (S,G) and (S,G,rpt) state machines are specified
independently from each other, and the spec doesn't say whether
you could/must/could-not/must-not have (S,G) and (S,G,rpt) state at
the same time.

Of course, the final result (e.g., the forwarding state that is
installed in the forwarding engine) would have to consider both the
(S,G) and the (S,G,rpt) routing entries (see the definition of
inherited_olist(S,G,rpt) and inherited_olist(S,G) on page 14).

Pavlin