Subject: RE: [pim] Question on (S,G,rpt) prune state

From: Bandi Sarveshwar-G19441 <[email-masked]>
Date: Tue, 14 Oct 2003 12:26:07 +0530

Hi Jim,
    By "(S,G) and (S,G,rpt) states" are you referring to (S,G) and (S,G,rpt) routing entries. If so than that might be an implementation specific detail. But if you are referring to states with regards state machine described in section 4.5.9, then both (S,G) and (S,G,rpt) states can co-exist. For example in the last hop router directly connected to receiving host, if we decide to switch-to-spt, then (S,G) states will exist to form a SPT towards the source. While the (S,G,rpt) states will be responsible for sending Prune(S,G,rpt) along the RPT towards the RP. 
 
Regards,
Sarvesh

-----Original Message-----
From: Jim T [mailto:[email-masked]]
Sent: Tuesday, October 14, 2003 1:33 AM
To: [email-masked]
Subject: [pim] Question on (S,G,rpt) prune state

Hi,
 
I'm new to PIM and have been going through the PIM-SM draft (v7). I had a couple of (possibly newbie) questions and hope someone will answer.
 
a) Can (S,G) and (S,G,rpt) states exist at the same time on a router? I think not because the former is on the SPT while the latter is meant for prune state on the RPT. But I'm a bit confused by the description in section 4.1.5.
 
b) This is touching upon implementation but I'm asking it to understand the whole thing better. When a (S,G,rpt) Prune is received, would a router actually create a "(S,G) style forwarding entry" which would have its olist set to that the olist of the (*,G) state minus the interface on which (S,G,rpt) Prune is received?
 
Thanks much,
Jim

  _____  

Do you Yahoo!?
The  <http://shopping.yahoo.com/?__yltc=s%3A150000443%2Cd%3A22708228%2Cslk%3Atext%2Csec%3Amail> New Yahoo! Shopping - with improved product search

_______________________________________________
pim mailing list
[email-masked]
http://catarina.usc.edu/mailman/listinfo/pim

---

From: Jim T <[email-masked]>
Date: Tue, 14 Oct 2003 12:27:15 -0700 (PDT)

My question (a) was regarding PIM-SM state-machine states. After going through the responses and section 4.5.9, I'm beginning to understand better. The last-hop router, say R1, will have (S,G) state after switchover to the SPT and it will have (S,G,rpt) upstream state for pruning itself off the RPT. Also, if R1 is an intermediate router on the RPT to some other downstream router, say R2, R2 may send a (S,G,rpt) Prune message to R1 and so R1 would have downstream state too for (S,G,rpt). The forwarding state/s installed would have to consider both (S,G) and (S,G,rpt) entries.
 
I have one other (naive?) question. Once a router (R1 or R2 above) finds that it no longer needs to forward along the RPT (inherited_olist(S,G,rpt) is null), does it keep the (*,G) state or does it remove it?
 
Jim

Bandi Sarveshwar-G19441 <[email-masked]> wrote:
Hi Jim,
    By "(S,G) and (S,G,rpt) states" are you referring to (S,G) and (S,G,rpt) routing entries. If so than that might be an implementation specific detail. But if you are referring to states with regards state machine described in section 4.5.9, then both (S,G) and (S,G,rpt) states can co-exist. For example in the last hop router directly connected to receiving host, if we decide to switch-to-spt, then (S,G) states will exist to form a SPT towards the source. While the (S,G,rpt) states will be responsible for sending Prune(S,G,rpt) along the RPT towards the RP. 
 
Regards,
Sarvesh
-----Original Message-----
From: Jim T [mailto:[email-masked]]
Sent: Tuesday, October 14, 2003 1:33 AM
To: [email-masked]
Subject: [pim] Question on (S,G,rpt) prune state

Hi,

 
 
Thanks much,
Jim

---------------------------------
Do you Yahoo!?
The New Yahoo! Shopping - with improved product search

---------------------------------
Do you Yahoo!?
The New Yahoo! Shopping - with improved product search

---

From: Pavlin Radoslavov <[email-masked]>
Date: Tue, 14 Oct 2003 12:39:22 -0700

> My question (a) was regarding PIM-SM state-machine states. After
> going through the responses and section 4.5.9, I'm beginning to
> understand better. The last-hop router, say R1, will have (S,G)
> state after switchover to the SPT and it will have (S,G,rpt)
> upstream state for pruning itself off the RPT. Also, if R1 is an
> intermediate router on the RPT to some other downstream router,
> say R2, R2 may send a (S,G,rpt) Prune message to R1 and so R1
> would have downstream state too for (S,G,rpt). The forwarding
> state/s installed would have to consider both (S,G) and (S,G,rpt)
> entries.
>  
> I have one other (naive?) question. Once a router (R1 or R2 above)
> finds that it no longer needs to forward along the RPT
> (inherited_olist(S,G,rpt) is null), does it keep the (*,G) state
> or does it remove it?

Presumably, the (*,G) state was installed because of IGMP/MLD (*,G)
Join and/or PIM-SM (*,G) Join; i.e., it indicates interest in
receiving multicast data from all senders for group G. Hence, the
(*,G) state should stay to take care of receiving multicast data for
all other sender for group G (except the above sender S).

Pavlin

---

From: John Zwiebel <[email-masked]>
Date: Tue, 14 Oct 2003 13:23:18 -0700

On Tuesday, October 14, 2003, at 12:27 PM, Jim T wrote:

> (inherited_olist(S,G,rpt) is null), does it keep the (*,G) state or 
> does it remove it?
>  
>
(*,G) state is independent.  You don't create (*,G) state
because of the receipt of a (S,G,R) prune -- although an implementation
may choose to do that.  (*,G) is created when you receive an
IGMP host report (last-hop) or a PIM (*,G) join message.  The
state is maintained as long as you continue to receive the
(*,G) join.

If one wanted to be really "picky" the JOIN message actually
doesn't create (*,G) state it just adds an interface to the
(*,G) Outgoing interface list with a 3 minute expiration timer.
Then a (*,G) prune message would delete this interface.  Whether
or not you have (*,G) state with a NULL olist is an
implementation question.