Subject: [pim] PIM MIB Draft

From: "Nicholas, Jonathan" <[email-masked]>
Date: Wed, 29 Oct 2003 09:21:59 -0500

All,

Tom asked me to send this to the list.  It is the same as the previous draft except for cosmetic changes (dates, etc.)

Jonathan Nicholas
Network Systems Engineer
ITT Aerospace/Communications Division

 <<draft-ietf-pim-mib-v2-02.txt>> 
************************************
This email and any files transmitted with it are proprietary and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the sender. Please note that any views or opinions presented in this email are solely those of the author and do not necessarily represent those of ITT Industries, Inc. The recipient should check this email and any attachments for the presence of viruses. ITT Industries accepts no liability for any damage caused by any virus transmitted by this email.
************************************

---

From: [email-masked] (Ketan TALAULIKAR)
Date: Thu, 30 Oct 2003 05:39:41 -0500

Hello ALL,

Follow my comments on the PIM MIB draft.

1) General : How about introducing configuration for Static RPs - something that is very widely used in the Internet today ?

2) General : In line with the evolution of the PIM-SM spec for IPv6 support, should we not make changes for IPv6 in the MIB as well ?

3) General : How about including configuration for BIDIR-PIM operations ?

4) General : How about inclusion of a new compliance group for BSR operations and separating it from the SM group ? This would allow implementation that do not implement BSR to claim compliance to the SM related portions.

5) Node or domain level configuration for Hello Interval on the lines of Join-Prune interval.

6) Isnt the pimInterfaceHelloHoldtime object redundant ? The PIM-SM spec states that the holdtime should be 3.5 times the Hello interval and hence the hold time can always be derived from the Hello interval configured. The same argument also applies to pimInterfaceJoinPruneHoldtime. 

7) The PIM-SM specification states that the GENID option SHOULD be used while the PIM-DM says it MAY be used. Why this difference ? Are there any interop issues with this ?

8) The pimNeighborDRPresent, I assume, refers to the DR Priority Hello option ? This is not very clear from the object name and the description.

9) Should there not be an object in the pimInterfaceTable that specifies the component to which interface belongs ? Supporting multiple instance configuration in the MIB using the pimComponentTable provides only *half-way* support for multiple instances.

10) The description of the pimNeighborLoss object has been confusing to me. *This trap should be generated when the neighbor timer expires, and the router has no other neighbors on the same interface with a lower IP address than itself.* Any reason for not triggering this trap for any neighbor loss ?

Would welcome views on the above.

Ketan

> <<draft-ietf-pim-mib-v2-02.txt>>

__________________________________________________________________
McAfee VirusScan Online from the Netscape Network.
Comprehensive protection for your entire computer. Get your free trial today!
http://channels.netscape.com/ns/computing/mcafee/index.jsp?promo=393397

Get AOL Instant Messenger 5.1 free of charge.  Download Now!
http://aim.aol.com/aimnew/Aim/register.adp?promo=380455

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: [email-masked] (Ketan TALAULIKAR)
Date: Thu, 30 Oct 2003 05:39:41 -0500

Hello ALL,

Ketan