Subject: RE: [pim] query on maintaining secondary address list

From: "Ganapathasaa" <[email-masked]>
Date: Mon, 24 Nov 2003 10:50:18 +0900

Hi,
Is it not same even in IPv4? The only use I can see from maintaining secondary IP address list is, we can send PIM joins directly to secondary address(in place of upstream neighbor's address)even if we dont have routing entry(for that perticular secondary address) in our unicast routing table. But is this the work to be done by PIM? and I feel this is not the purpose of maintaining secondary address lists. Still I am not clear about including address list option in Hello messages.
Please send your comments on this,

Regards,
Ganapath

	-----Original Message----- 
	From: Mike Davison [mailto:[email-masked]] 
	Sent: Fri 11/21/2003 9:33 AM 
	To: [email-masked] 
	Cc: 
	Subject: Re: [pim] query on maintaining secondary address list

	The secondary address list is needed for IPv6 support. PIM uses a 
	link-local IPv6 address when communicating with neighbors yet a 
	global-scope address is also needed. 

	Mike 

	On Thu, 2003-11-20 at 00:57, Ganapathasaa wrote: 
	> Hi, 
	>  
	> New PIM-SM draft draft-ietf-pim-sm-v2-new-08.txt mentions about 
	> "Maintaining Secondary Address Lists" in section 
	> 4.3.4. I am not quite clear why do we need to maintain secondary 
	> address lists in first place. Is this helpful only in alerting 
	> adminstrator in case of wrong configurations? It looks like, new 
	> option included in Hello message is to distinguish and to make 
	> independent processing checks at primary and secondary IP. Anyway I am 
	> not clear, please send your comments on this. 
	>  
	> Thanx in advance, 
	> Ganapath 
	> ----------------------------------- 
	> Engineer, Protocol Team/R&D Center 
	> Corecess Inc, 
	> 500-2, Sangdaewon-Dong, Jungwon-Ku, 
	> Seongnam-city, Kyungki-do, 
	> Korea, 462-120 
	> Tel) 82-31-739-6907 
	> Fax) 82-31-739-6899 
	> www.corecess.com 
	> ----------------------------------- 

	_______________________________________________ 
	pim mailing list 
	[email-masked] 
	https://www1.ietf.org/mailman/listinfo/pim

---

From: John Zwiebel <[email-masked]>
Date: Sun, 23 Nov 2003 18:07:36 -0800

There's a suz (for suzuki) draft that explains this in detail,
but in summary, the IPv6 addresses are used quite differently than
IPv4 addresses.

All the IGP's I'm aware of use the link-local address for the
next hop.  This makes it easy for PIM to find the next
upstream router because PIM6 also uses link-local addresses.

But there is nothing 'illegal' with using a global address
as the next hop, most likely in a static route.  In such a case,
(and also in the case where the PIM-RP (a global address) is on the
LAN over which a router wants to send a pim join) the downstream
router has no way of translating the global address next hop
to a link-local pim neighbor.

You're going to find several interesting things when
trying to do pim over ipv6.

On Nov 23, 2003, at 5:50 PM, Ganapathasaa wrote:

> Hi,
> Is it not same even in IPv4? The only use I can see from maintaining 
> secondary IP address list is, we can send PIM joins directly to 
> secondary address(in place of upstream neighbor's address)even if we 
> dont have routing entry(for that perticular secondary address) in our 
> unicast routing table. But is this the work to be done by PIM? and I 
> feel this is not the purpose of maintaining secondary address lists. 
> Still I am not clear about including address list option in Hello 
> messages.
> From:Mike Davison [mailto:[email-masked]]
> Sent:Fri 11/21/2003 9:33 AM
> To:[email-masked]
> Cc:
> Subject:Re: [pim] query on maintaining secondary address list
>
>
>
>

---

From: John Zwiebel <[email-masked]>
Date: Sun, 23 Nov 2003 18:07:36 -0800

---

From: JINMEI Tatuya / 神明達哉 <[email-masked]>
Date: Mon, 24 Nov 2003 12:46:42 +0900

>>>>> On Mon, 24 Nov 2003 10:50:18 +0900, 
>>>>> "Ganapathasaa" <[email-masked]> said:

> Please send your comments on this,

draft-suz-pim-upstream-detection-00.txt described the background of
the address list and the hello option in more details.  The draft has
already expired, but you can get it, e.g., at:

ftp://ftp.kame.net/pub/internet-drafts/draft-suz-pim-upstream-detection-00.txt

There was a related discussion in this list around March 2003.  I
think you can find the discussion in the list archive.

					JINMEI, Tatuya
					Communication Platform Lab.
					Corporate R&D Center, Toshiba Corp.
					[email-masked]

---

From: JINMEI Tatuya / 神明達哉 <[email-masked]>
Date: Mon, 24 Nov 2003 12:46:42 +0900

JINMEI, Tatuya