Subject: [pim] query on maintaining secondary address list

From: "Ganapathasaa" <[email-masked]>
Date: Thu, 20 Nov 2003 17:57:12 +0900

Hi,
 
New PIM-SM draft draft-ietf-pim-sm-v2-new-08.txt mentions about "Maintaining Secondary Address Lists" in section
4.3.4. I am not quite clear why do we need to maintain secondary address lists in first place. Is this helpful only in alerting adminstrator in case of wrong configurations? It looks like, new option included in Hello message is to distinguish and to make independent processing checks at primary and secondary IP. Anyway I am not clear, please send your comments on this.
 
Thanx in advance,
Ganapath
-----------------------------------
Engineer, Protocol Team/R&D Center
Corecess Inc,
500-2, Sangdaewon-Dong, Jungwon-Ku,
Seongnam-city, Kyungki-do,
Korea, 462-120
Tel) 82-31-739-6907
Fax) 82-31-739-6899
www.corecess.com
-----------------------------------

---

From: "Ganapathasaa" <[email-masked]>
Date: Mon, 24 Nov 2003 10:50:18 +0900

Hi,
Is it not same even in IPv4? The only use I can see from maintaining secondary IP address list is, we can send PIM joins directly to secondary address(in place of upstream neighbor's address)even if we dont have routing entry(for that perticular secondary address) in our unicast routing table. But is this the work to be done by PIM? and I feel this is not the purpose of maintaining secondary address lists. Still I am not clear about including address list option in Hello messages.
Please send your comments on this,

Regards,
Ganapath

	-----Original Message----- 
	From: Mike Davison [mailto:[email-masked]] 
	Sent: Fri 11/21/2003 9:33 AM 
	To: [email-masked] 
	Cc: 
	Subject: Re: [pim] query on maintaining secondary address list

	The secondary address list is needed for IPv6 support. PIM uses a 
	link-local IPv6 address when communicating with neighbors yet a 
	global-scope address is also needed. 

	Mike 

	On Thu, 2003-11-20 at 00:57, Ganapathasaa wrote: 
	> Hi, 
	>  
	> New PIM-SM draft draft-ietf-pim-sm-v2-new-08.txt mentions about 
	> "Maintaining Secondary Address Lists" in section 
	> 4.3.4. I am not quite clear why do we need to maintain secondary 
	> address lists in first place. Is this helpful only in alerting 
	> adminstrator in case of wrong configurations? It looks like, new 
	> option included in Hello message is to distinguish and to make 
	> independent processing checks at primary and secondary IP. Anyway I am 
	> not clear, please send your comments on this. 
	>  
	> Thanx in advance, 
	> Ganapath 

	_______________________________________________ 
	pim mailing list 
	[email-masked] 
	https://www1.ietf.org/mailman/listinfo/pim