Subject: [pim] Doubt regarding BSR & Bootstrap messages

From: srinivas <[email-masked]>
Date: Wed, 19 Nov 2003 14:50:41 +0300 (MSK)

Hi all,
  
 Here is my Setup:-
   
R1<-------->R2
^
|
|
V
R3

In the above setup,
Enable PIM over all interfaces in R1, R2 & R3.
Enable BSR using Interface address in R1, say x.x.x.x, which is 
connected to R2. 
Let the R1 get elected as BSR using x.x.x.x.
Now bring the interface correspnding to x.x.x.x down.
you can note that BSMs are sent to R3 from R1.
But in R3, the BSMs get rejected since there is no route to 
x.x.x.x.

So, is it valid to send out Bootstrap Messages even when the 
corresponding interface is down?
What is the use if at all we are sending it?

Now considering the above scenario, R1 is "Elected" BSR even 
though all its BSMs are getting rejected.
R2 & R3 will not have BSR info. So, it is improper to display R1 
as "Elected" whereas none of the neighboring
routers know about the BSR.

Can any one explain about this behavior?

Thanks & regards,
Srinivas
Tasman Networks

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "bharat_joshi" <[email-masked]>
Date: Thu, 20 Nov 2003 00:03:50 +0530

Here is my Setup:-
  
R1<-------->R2
^
|
|
V
R3

In the above setup,

Bharat:
 
Could you please explain why a swicth/router will keep sending
BSMs even if its interface is down.
 
Its probably a wrong configuration. Becuase route for your BSR's IP
address will not be available in R3's unicast routing table.
 
Assigning an IP address for BSR address can be implementation specific.
In your case, You can choose the BSR address independent of your PIM 
interfaces. That could be a ROTUER/SWITCH's IP address which must
always be distribiuted using Unicast Routing protocol.
 
<<<<<<

Bharat:
 
R1's BSM will be discarded if they come with a unicast address which
R3 can not reach using the same interface.
 
But if R1's BSMs are getting discarded , how R1 will be elected as E-BSR?
If R1 was elected as BSR in R3, it will timeout after BS timeout because R3
would not receive any valid BSM. Now the decision to flush the RP set is 
still going on this list. I am not sure if any concrete thing has come out.
 
After this timeout, I think only R1 will show himself as E-BSR, right??
 
I hope this answer your question.
 
People, please correct me if I am wrong.
 
Thanks & Regards,
Bharat
 
<<<<<

Thanks & regards,
Srinivas
Tasman Networks

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim <https://www1.ietf.org/mailman/listinfo/pim> 

)�i��X��X������_��!��l��0�X���+����Y���b�ا~��

---

From: srinivas <[email-masked]>
Date: Thu, 20 Nov 2003 08:39:03 +0300 (MSK)

Hi,
 My comments are inline.

>>>BSMs even if its interface is down

This is what I am also precisely asking for.
Probably I was not clear in my first mail.
I feel BSMs should not be sent to R3 at all. BSMs will not be sent anyways 
to R2 since interface is down.

>>>Assigning an IP address for BSR address can be implementation specific.

Agreed, Since I am using Cisco & Tasman routers, I have to specify the 
interface/interface address as Candidate BSR.

>>>R3 can not reach using the same interface.

Correct, my doubt is NOT "why BSMs are getting rejected in R3", but "Why R1 
is sending BSMs when corresponding interface is down, since all the BSMs are 
going to be rejected anyway" .

>>>But if R1's BSMs are getting discarded , how R1 will be elected as E-BSR?

R1 is elected BSR in R1 itself. R2 & R3 will not have info about BSR since 
R3 is rejects all the BSMs & R2 doesn't receive any.

Though my question is more implementation specific, I thought of posting 
this to the group since 
both Cisco router as well as Tasman router behaved in similar fashion,
and I didnt know where else to post this question.

Thanks,
Srinivas

 bharat_joshi <[email-masked]>:

 Here is my Setup:-

R1<-------->R2
^
|
|
V
R3

In the above setup,

Bharat:

<<<<<<

Bharat:

Thanks & Regards,
Bharat

<<<<<

Thanks & regards,
Srinivas
Tasman Networks

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim 
<https://www1.ietf.org/mailman/listinfo/pim>