Subject: RE: [pim] Doubt regarding BSR & Bootstrap messages

From: "bharat_joshi" <[email-masked]>
Date: Thu, 20 Nov 2003 00:03:50 +0530

Here is my Setup:-
  
R1<-------->R2
^
|
|
V
R3

In the above setup,
Enable PIM over all interfaces in R1, R2 & R3.
Enable BSR using Interface address in R1, say x.x.x.x, which is
connected to R2.
Let the R1 get elected as BSR using x.x.x.x.
Now bring the interface correspnding to x.x.x.x down.
you can note that BSMs are sent to R3 from R1.
But in R3, the BSMs get rejected since there is no route to
x.x.x.x.

So, is it valid to send out Bootstrap Messages even when the
corresponding interface is down?
What is the use if at all we are sending it?

Bharat:
 
Could you please explain why a swicth/router will keep sending
BSMs even if its interface is down.
 
Its probably a wrong configuration. Becuase route for your BSR's IP
address will not be available in R3's unicast routing table.
 
Assigning an IP address for BSR address can be implementation specific.
In your case, You can choose the BSR address independent of your PIM 
interfaces. That could be a ROTUER/SWITCH's IP address which must
always be distribiuted using Unicast Routing protocol.
 
<<<<<<

Now considering the above scenario, R1 is "Elected" BSR even
though all its BSMs are getting rejected.
R2 & R3 will not have BSR info. So, it is improper to display R1
as "Elected" whereas none of the neighboring
routers know about the BSR.

Bharat:
 
R1's BSM will be discarded if they come with a unicast address which
R3 can not reach using the same interface.
 
But if R1's BSMs are getting discarded , how R1 will be elected as E-BSR?
If R1 was elected as BSR in R3, it will timeout after BS timeout because R3
would not receive any valid BSM. Now the decision to flush the RP set is 
still going on this list. I am not sure if any concrete thing has come out.
 
After this timeout, I think only R1 will show himself as E-BSR, right??
 
I hope this answer your question.
 
People, please correct me if I am wrong.
 
Thanks & Regards,
Bharat
 
<<<<<

Can any one explain about this behavior?

Thanks & regards,
Srinivas
Tasman Networks

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim <https://www1.ietf.org/mailman/listinfo/pim> 

)�i��X��X������_��!��l��0�X���+����Y���b�ا~��

---

From: "Ketan TALAULIKAR" <[email-masked]>
Date: Thu, 20 Nov 2003 11:28:56 +0100 (CET)

> always be distribiuted using Unicast Routing protocol.

Note that the current PIM MIB specs will not allow the use of IP address
other than of a PIM enabled interface since the CBSR preference
configuration is in the pimInterfaceTable.

But I agree with your views and feel its something which needs to be
corrected in the MIB. i.e. remove the dependency.

Also, I have a question here, does it make sense to use more than one
router interface as BSR address ? I believe the requirement would only be
of having one per PIM Component (or domain). Ofcourse, its possible that
with admin-scoped BSMs one can use different BSR addresses but I have seen
such usage running into problems when we have (most) implementations which
do not understand admin-scoped BSMs.

Best regards,
Ketan

-- 
Ketan TALAULIKAR
FutureSoft
www.futsoft.com
Work: +32-3-240-8997  GSM: +32-485-370445

***************************************************************************
This message is proprietary to Future Software Limited (FSL)
and is intended solely for the use of the individual to whom it
is addressed. It may contain  privileged or confidential information
and should not be circulated or used for any purpose other than for
what it is intended.

If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient,
you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message.
FSL accepts no responsibility for loss or damage arising from
the use of the information transmitted by this email including
damage from virus.
***************************************************************************

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "Ketan TALAULIKAR" <[email-masked]>
Date: Thu, 20 Nov 2003 11:28:56 +0100 (CET)

Best regards,
Ketan