Subject: [pim] Both source and receiver in PIM-SM

From: Bousquet Laurent <[email-masked]>
Date: Mon, 18 Oct 2004 09:27:28 +0200 (CEST)

Hello all,
 
I am new to PIM and I need some help.
 
I need a protocol in which the hosts will be both source and receiver for the same Xcast group(interaction between the different hosts like in a conference - application Many-to-Many). I think BIDIR-PIM is the best solution but I wonder if PIM-SM is possible : can a host be both a source and a receiver for the same Xcast group in PIM-SM ?
 
I am not sure but I think it can work like this. Each host (host A, host B and host C) which wants to participate in the conference will send Join Messages with IGMP : so, the three hosts belong to the same shared tree. When the host A wants to speak, it creates a source-specific tree towards the RP which distributes the packets to the others participants (the host B and the host C). After, when the host B wants to speak, it also creates a source-specific tree toward the RP which distributes the packets to the hosts A and C. In a nutshell, each host creates its own source-specific tree but uses the same shared tree.
 
Please, could anybody clarify this ?
 
Best regards,
L. Bousquet

---------------------------------
Créez gratuitement votre Yahoo! Mail avec 100 Mo de stockage !
Créez votre Yahoo! Mail

Le nouveau Yahoo! Messenger est arrivé ! Découvrez toutes les nouveautés pour dialoguer instantanément avec vos amis.Téléchargez GRATUITEMENT ici !

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: Prashant Jhingran <[email-masked]>
Date: Mon, 18 Oct 2004 15:53:05 +0800

Hi,
    Yes you are on the right path.
     PIM-SM itself can be used and your thinking is correct.
    According to the PIM-SM protocol, a sender (sourse) may or maynot be
a receiver.
    For creating receivers you need to run IGMP between hosts and the
first hop router's to the hosts.
regards,
Prashant
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Bousquet Laurent
Sent: Monday, October 18, 2004 3:27 PM
To: [email-masked]
Subject: [pim] Both source and receiver in PIM-SM

Hello all,

I need a protocol in which the hosts will be both source and receiver
for the same Xcast group(interaction between the different hosts like in
a conference - application Many-to-Many). I think BIDIR-PIM is the best
solution but I wonder if PIM-SM is possible : can a host be both a
source and a receiver for the same Xcast group in PIM-SM ?
 
I am not sure but I think it can work like this. Each host (host A, host
B and host C) which wants to participate in the conference will send
Join Messages with IGMP : so, the three hosts belong to the same shared
tree. When the host A wants to speak, it creates a source-specific tree
towards the RP which distributes the packets to the others participants
(the host B and the host C). After, when the host B wants to speak, it
also creates a source-specific tree toward the RP which distributes the
packets to the hosts A and C. In a nutshell, each host creates its own
source-specific tree but uses the same shared tree.

Best regards,
L. Bousquet

  _____  

Créez gratuitement votre Yahoo! Mail avec 100 Mo de stockage ! 
Créez
<http://fr.rd.yahoo.com/mail/taglines/*http://fr.rd.yahoo.com/evt=25917/
*http://fr.rd.yahoo.com/mail/mail_taglines_100/default/*http://fr.benefi
ts.yahoo.com/> votre Yahoo! Mail

Le nouveau Yahoo! Messenger est arrivé ! Découvrez toutes les nouveautés
pour dialoguer instantanément avec vos amis. Téléchargez
<http://fr.rd.yahoo.com/mail/taglines/*http://fr.rd.yahoo.com/evt=26111/
*http://fr.rd.yahoo.com/messenger/mail_taglines/default/*http://fr.messe
nger.yahoo.com> GRATUITEMENT ici !
_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: Marshall Eubanks <[email-masked]>
Date: Mon, 18 Oct 2004 09:31:19 -0400

Dear Laurent;

Remember, hosts do not create trees - routers do that. Whether or not
source based trees
are created in ASM depends on the PIM routing cinfiguration in use in
the domain - generally, they
are, but they may not be. In any case, this will not generally be
controllable by the host. Standard
ASM configurations would have true source based trees (not from the
source to the RP but
from the source to the receivers) set up immediately, but this can be
modified if you can set routing  policy or if BiDir routing is
available.

It sounds to me like BiDir may be what you want IF you are not planning to 
cross a domain boundary (i.e., if all of the multicasts are kept
within one autonomous system).
What you describe is very similar to BiDir in operation. If you do have to cross
domain boundaries and use MBGP, you cannot use BiDir, and you should
investigate using SSM.

Regards
Marshall Eubanks

On Mon, 18 Oct 2004 09:27:28 +0200 (CEST), Bousquet Laurent
<[email-masked]> wrote:
> I need a protocol in which the hosts will be both source and receiver for
> the same Xcast group(interaction between the different hosts like in a
> conference - application Many-to-Many). I think BIDIR-PIM is the best
> solution but I wonder if PIM-SM is possible : can a host be both a source
> and a receiver for the same Xcast group in PIM-SM ? 
>   
> I am not sure but I think it can work like this. Each host (host A, host B
> and host C) which wants to participate in the conference will send Join
> Messages with IGMP : so, the three hosts belong to the same shared tree.
> When the host A wants to speak, it creates a source-specific tree towards
> the RP which distributes the packets to the others participants (the host B
> and the host C). After, when the host B wants to speak, it also creates a
> source-specific tree toward the RP which distributes the packets to the
> hosts A and C. In a nutshell, each host creates its own source-specific tree
> but uses the same shared tree. 
>   
>  ________________________________
> pour dialoguer instantanément avec vos amis. Téléchargez GRATUITEMENT ici ! 
> 
>