Subject: [pim] PIM-BI and the state of multicasting in general

From: Jonathan Day <[email-masked]>
Date: Tue, 12 Oct 2004 17:22:46 -0700 (PDT)

Unfortunately, there seem to be no Open Source PIM
implementations under active development. By far the
most common(!) version of PIM out there is PIM-SM.
There's an excellent stand-alone router for that, plus
an implementation in Xorp. These are the only versions
of PIM I've managed to get running on recent
platforms.

A stand-alone PIM-DM router exists, based on an early
version of the stand-alone PIM-SM router, but it does
not seem to compile on recent versions of Linux. A
partial PIM-DM implementation exists for MRT, an
abandoned modular router, but I've no information on
whether it's usable.

There are no PIM implementations (AFAICT) for Zebra
(apparently abandoned), Quagga (based on Zebra and
also apparently abandoned) or Click (the only Open
Source software router that appears to still be
maintained).

On the kernel side, Linux supports PIM-SM only. I
don't know about the *BSDs. Linux is not exactly fast
on the uptake on multicasting, only recently adding
the basic portions of IGMPv3, so I'm not expecting
anything dramatic to happen there with PIM. Any new
support is likely to be user-side only.

Unfortunately, as noted above, the user-side
development seems to be in not much better shape. A
quick glance at directories such as Freshmeat.net
shows that there's no shortage of developers with
time, but multicasting doesn't seem to be an area that
is attracting much interest.

Slightly off-topic, but related, it's not just
multicast routing that's taking a beating. A lot of
multicast end-user tools, such as SDR, VIC, RAT, etc,
are also unmaintained. I'm getting just a little
concerned that multicasting is heading the way of the
dodo. A few announcement services optionally use it,
but you hardly need PIMv2 (Bidirectional) +
Source-Specific Multicasting + Authentication to
support things like RIPv2 or SIP, or packages such as
the Squid web cache.

Just a thought, but maybe there needs to be a little
more awareness amongst users (and probably admins) on
what's out there and why they might want to use it.

> From: Sridhar Komandur <[email-masked]>
> Subject: [pim] bidir pim open source ...
> To: [email-masked]
> Message-ID:
> <[email-masked]>
> Content-Type: text/plain; charset=US-ASCII
> 
> Hi,
> 
> Is there a open source version of bidir pim
> available ? 
> If yes, what is the status of its interop with
> router implementations ?
> 
> [please copy a reply to me as I don't subscribe to
> this group]

__________________________________
Do you Yahoo!?
Yahoo! Mail Address AutoComplete - You start. We finish.
http://promotions.yahoo.com/new_mail 

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: Stig Venaas <[email-masked]>
Date: Wed, 13 Oct 2004 09:36:48 +0200

> of PIM I've managed to get running on recent

I'm mostly involved with IPv6. I've run Xorp and also "pim6sd".
With the latter you can do IPv6 multicast routing on at least
FreeBSD, NetBSD and Linux. The IPv6 multicast support in the
Linux kernel has just been added.

I thought there was both working pimsd and also gated to do
IPv4 PIM-SM on Linux, but I've never tried myself.

> don't know about the *BSDs. Linux is not exactly fast

At least some of the *BSDs do both IPv4 and IPv6 PIM-SM.

> support is likely to be user-side only.

Linux also got MLDv2.

> is attracting much interest.

At least for IPv6 there are some developments. There's
also some development of IPv4 AMT on misc platforms.

> are also unmaintained. I'm getting just a little

UCL does at least some maintenance of the tools.

> what's out there and why they might want to use it.

I agree that not enough is happening but it's not quite
as bad as you say. And in particular for IPv6 I see some
activities. One example of large IPv6 multicast deployment
is M6Bone, http://www.m6bone.net/

Stig