Subject: [pim] Dense mode leaf node detection

From: Ashish Ranjan <[email-masked]>
Date: Wed, 13 Oct 2004 13:26:34 -0700

Hi,

   Based on new PIM-DM draft (dm-new-v2-05.txt), in a topology where
there are 2 routers on leaf, how does they prune the oif. The draft
has no mention of assert winner to go into prune state (in the absence
of a listener) unlike the older pim-dm draft.

For example.

              |                          |
             \ /                        \ /     
        +-----------+              +-----------+    
        |     A     |              |     B     | 
        |           |              |           |       
        +-----------+              +-----------+
  10.1.1.1/24|                           |  10.1.1.2/24
             +---------------------------+

In the above topology either of the router could be assert winner on
down i/f. Assuming A is assert winner and no listener for the stream
on the downstream i/f, how does A decide on pruning the upstream tree.
How would A's olist would be NULL. Or A would keep forwarding.   What
am I missing here.
 
Any clarification would be appreciated. I did not find any discussion
on this in this list.

thanks
-Ashish

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "Nicholas, Jonathan" <[email-masked]>
Date: Thu, 14 Oct 2004 07:40:24 -0400

When transitioning to an Assert Loser state on a downstream interface, a router sends a Prune on that interface to resolve the problem described.  Since there are no other routers on the net, no Join will be sent and the assert winner will transition to a Pruned state.

Jonathan Nicholas
Network Systems Engineer
ITT Aerospace/Communications Division

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Ashish Ranjan
> Sent: Wednesday, October 13, 2004 4:27 PM
> To: [email-masked]
> Subject: [pim] Dense mode leaf node detection
>
>
> Hi,
>

************************************
This e-mail and any files transmitted with it are proprietary and intended solely for the use of the individual or entity to whom they are addressed. If you have received this e-mail in error please notify the sender. Please note that any views or opinions presented in this e-mail are solely those of the author and do not necessarily represent those of ITT Industries, Inc. The recipient should check this e-mail and any attachments for the presence of viruses. ITT Industries accepts no liability for any damage caused by any virus transmitted by this e-mail.
************************************