Subject: [pim] PIM-DM:(S,G) Assert Message State Machine

From: Prashant Jhingran <[email-masked]>
Date: Fri, 04 Mar 2005 16:56:41 +0800

Hi All,

This is in reference to PIM-DM rfc 3973

Section: "4.6.4.  (S,G) Assert Message State Machine"

************************************************
+-------------------------------+---------------------------------------
-+
|                                             |            Previous
State                |
|
+------------+------------+------------+
|            Event                      |  No Info   |   Winner   |
Loser  |
+-------------------------------+------------+------------+------------+
| Receive Preferred    | ->L Send   | ->L Send   | ->L  Se    t    |
|    Assert OR             |                    |                     |
|
|   State Refresh         | Prune(S,G) | Prune(S,G) |  AT(S,G,I)  |
|                                    |    Set           |    Set
|                    | 
|                                    |  AT(S,G,I)  |    AT(S,G,I)|
|
+-------------------------------+---------------------------------------
--+

***********************************************

Consider the following scenerio [No Receivers].
SDR---------------------RT1-------------------RT2

-> SRM ---------> Assert L [ As per the Draft]
This seems to me a misleading behaviour, there should be an additional
check, like
AssertTrackingDesired() while processing of State Refresh Message and
thus the router RT1 should keep the Assert FSM in [NI] state.

Kindly comment on the same.

Regards,
Prashant Jhingran

Huawei Technologies 
Beijing, China
Ph# 00-86-10-82882016  (O)  
        00-86-10-62974038  (R)
www.huawei.com

"You see, all the problems in the world are created by those who want
'perfection.' "
-- Sri Sri Ravi Shankar  www.artofliving.org  

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "Nicholas, Jonathan - ACD " <[email-masked]>
Date: Mon, 7 Mar 2005 08:46:48 -0500

Hello,

I now understand the problem.

All routers must track the upstream router to be sure that any Graft(S,G) the router may need to originate gets directed to the correct upstream router.  Thus, AssertTrackingDesired(S,G) always evaluates to TRUE in PIM-DM.

Jonathan Nicholas
Network Systems Engineer 
ITT Aerospace/Communications Division

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Prashant Jhingran
Sent: Saturday, March 05, 2005 2:56 AM
To: [email-masked]
Subject: RE: [pim] PIM-DM:(S,G) Assert Message State Machine

Following is the detailed explanation of the same:

PIM Protocol Mode: DM.

Consider three router topology:
Source---->Router 1--------->------------------------Router
2------->--------------------------------Router 3

There are no receivers.

Now, Router 1[Acting as a Source Designated Router i.e. SDR] originates an SRM [State Refresh Message] towards Router 2. Then as per the section "4.6.4.  (S,G) Assert Message State Machine" of PIM-DM  RFC3973, the Assert FSM of Router 2 for this SG entry should transition to Looser state.

Since the OIF List or Router 2 is empty, the  transition in Assert FSM state on Router 2 seems to be unnecessary.

There should be an additional check, like AssertTrackingDesired() == True while processing of State Refresh Message and thus the Router 2 should keep the Assert FSM in [NI] state.

regards,
Prashant

-----Original Message-----
From: Nicholas, Jonathan - ACD [mailto:[email-masked]] 
Sent: Friday, March 04, 2005 9:37 PM
To: Prashant Jhingran; [email-masked]
Subject: RE: [pim] PIM-DM:(S,G) Assert Message State Machine

I'm afraid I don't understand your scenario.  What are SDR and SRM?  How is everything connected together?  What is wrong with RT1 being an Assert Loser?

Jonathan Nicholas
Network Systems Engineer
ITT Aerospace/Communications Division

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Prashant Jhingran
Sent: Friday, March 04, 2005 3:57 AM
To: [email-masked]
Subject: [pim] PIM-DM:(S,G) Assert Message State Machine

Hi All,

Consider the following scenerio [No Receivers]. SDR---------------------RT1-------------------RT2

-> SRM ---------> Assert L [ As per the Draft]
This seems to me a misleading behaviour, there should be an additional check, like
AssertTrackingDesired() while processing of State Refresh Message and thus the router RT1 should keep the Assert FSM in [NI] state.

Regards,
Prashant Jhingran

Huawei Technologies

Beijing, China

        00-86-10-62974038  (R)
www.huawei.com

"You see, all the problems in the world are created by those who want 'perfection.' "
-- Sri Sri Ravi Shankar  www.artofliving.org 

************************************
This e-mail and any files transmitted with it are proprietary and intended solely for the use of the individual or entity to whom they are addressed. If you have received this e-mail in error please notify the sender. Please note that any views or opinions presented in this e-mail are solely those of the author and do not necessarily represent those of ITT Industries, Inc. The recipient should check this e-mail and any attachments for the presence of viruses. ITT Industries accepts no liability for any damage caused by any virus transmitted by this e-mail.
************************************